Completed
Last Updated: 11 Feb 2019 10:08 by ADMIN
ADMIN
Created by: Rumen
Comments: 3
Category: UI for ASP.NET AJAX
Type: Bug Report
0
I'm using couple of Rad Editor controls in my webpart and using ToolProviderID for performance optimization.
I'm initializing one rad editor toolbar from server side and using the same toolbar to provide other rad editors with their toolbar, Bascially I'm using ToolProviderID attribute to initialize other RadEditors, after doing this the Comments and Track Changes feature stop working although their options are selected in the toolbar.


<telerik:RadEditor RenderMode="Lightweight" runat="server" ID="RadEditor1" EnableTrackChanges="true" EnableComments="true">
    <TrackChangesSettings Author="AuthorName" CanAcceptTrackChanges="true" UserCssId="reU0" />
    <Tools>
        <telerik:EditorToolGroup>
            <telerik:EditorTool Name="AcceptTrackChange" />
            <telerik:EditorTool Name="RejectTrackChange" />
            <telerik:EditorTool Name="AcceptAllTrackChanges" />
            <telerik:EditorTool Name="RejectAllTrackChanges" />
            <telerik:EditorTool Name="EnableTrackChangesOverride" />
        </telerik:EditorToolGroup>
    </Tools>
</telerik:RadEditor>
<telerik:RadEditor ID="RadEditor2" runat="server" ToolProviderID="RadEditor1" EnableTrackChanges="true" EnableComments="true"></telerik:RadEditor>
<telerik:RadEditor ID="RadEditor3" runat="server" ToolProviderID="RadEditor1" EnableTrackChanges="true" EnableComments="true"></telerik:RadEditor>
Completed
Last Updated: 20 Dec 2018 14:19 by ADMIN
Created by: Vinson
Comments: 1
Category: UI for ASP.NET AJAX
Type: Bug Report
0
When I try to replace a white space in RadEditor, it is able to replace the words at the first line. The second one and onwards are not able to replace.

Step:

1. Open 'Find And Replace' dialog.

2. Go to 'Replace' tab.

3. Enter a white space for 'Find' text box.

4. Enter any character or word for 'Replace With' text box.

5. Hit on 'Replace All' button.

Reproducible in content which contains table elements and in the live demo: https://demos.telerik.com/aspnet-ajax/editor/examples/overview/defaultcs.aspx
Completed
Last Updated: 13 Dec 2018 16:38 by ADMIN
Created by: BALA
Comments: 1
Category: UI for ASP.NET AJAX
Type: Feature Request
0
What is EOL for this version.
UI for ASP.NET AJAX R1 2017 SP1 (version 2017.1.228)
Completed
Last Updated: 05 Dec 2018 17:36 by MA
ADMIN
Created by: Vessy
Comments: 1
Category: UI for ASP.NET AJAX
Type: Bug Report
1
When the scripts are loaded through a script manager with enabled CDN and RadScriptManager.CombinedResource="Enabled", JS error will be thrown then the filtering button of the Grid is clicked.

Code to reproduce the problem:
        <telerik:RadScriptManager ID="RadScriptManager1" runat="server">
            <CdnSettings TelerikCdn="Enabled" CombinedResource="Enabled" />
        </telerik:RadScriptManager>

        <telerik:RadGrid ID="UserDetailsGrid" runat="server" AllowFilteringByColumn="true" OnNeedDataSource="UserDetailsGrid_NeedDataSource"
            EnableHeaderContextMenu="true" EnableHeaderContextFilterMenu="true">
        </telerik:RadGrid>

C#:
        protected void UserDetailsGrid_NeedDataSource(object sender, Telerik.Web.UI.GridNeedDataSourceEventArgs e)
        {
            var list = new[] {
                    new { FirstName = "F1", LastName ="L1"},
                    new { FirstName = "F2", LastName ="L2"},
                    new { FirstName = "F3", LastName ="L3"},
                    new { FirstName = "F4", LastName ="L4"}
                    }.ToList();
            UserDetailsGrid.DataSource = list;
        }
Completed
Last Updated: 28 Nov 2018 15:29 by ADMIN
Can be reproduced with the following page setup:

<%@ Page Language="C#" AutoEventWireup="true" CodeFile="Default.aspx.cs" Inherits="Default" %>
<%@ Register Assembly="Telerik.Web.UI" Namespace="Telerik.Web.UI" TagPrefix="telerik" %>
<!DOCTYPE html PUBLIC "-//W3C//DTD XHTML 1.0 Transitional//EN" "http://www.w3.org/TR/xhtml1/DTD/xhtml1-transitional.dtd">


<html xmlns="http://www.w3.org/1999/xhtml">
<head runat="server">
    <title></title>


</head>
<body>
    <form id="form1" runat="server">
    <telerik:RadScriptManager ID="RadScriptManager1" runat="server">
    </telerik:RadScriptManager>


    <div style="height:930px">
        Scroll down to bottom of the page and right mouse click to see context menu miss placement....
    </div>
   
        <telerik:RadEditor RenderMode="Classic" ID="redHtmlEditor" runat="server" 
            ContentAreaMode="Div">
           <Content>           
                    Right-click on image to see custom menu
                    <img style="marign-left: 6px" src="http://demos.telerik.com/aspnet-ajax/Editor/Img/productLogoLight.gif" />
                    <br/><br/>           
                    <p>Right-click here to see the custom Paragraph menu.<br/></p><br/>           
                    Right-click on the link to see the default link menu disabled: <a href="/">www.telerik.com</a>   
            </Content>
       </telerik:RadEditor>
    
    </form>
</body>
</html>

Completed
Last Updated: 27 Nov 2018 12:31 by ADMIN
Created by: Paul
Comments: 6
Category: UI for ASP.NET AJAX
Type: Feature Request
14
Adding a request as per the link below:

http://www.telerik.com/forums/javascript-intellisense-option-missing-in-vs-2017

Admin update:
Here are links to updated documentation that explains how to use JavaScript intellisense in VS 2017
- https://docs.telerik.com/devtools/aspnet-ajax/general-information/integration-with-visual-studio/how-to-use-javascript-intellisense-for-the-telerik-controls
- https://docs.telerik.com/devtools/aspnet-ajax/general-information/using-jquery/jquery-intellisense
Completed
Last Updated: 08 Nov 2018 15:00 by ADMIN
The ContextMenu popup is not position properly relative to its target element when the page is horizontally scrolled in Edge. The problem is reproducible with R2 2018.

Steps tp reproduce:
1. Run the code below and scroll the page to the right
2. Right click over a number


<!DOCTYPE html>

<html xmlns="http://www.w3.org/1999/xhtml">
<head runat="server">
    <title></title>
</head>
<body>
    <form id="form1" runat="server">
        <telerik:RadScriptManager ID="RadScriptManager1" runat="server">
        </telerik:RadScriptManager>
        <telerik:RadContextMenu ID="rcmMenu" runat="server">
            <Targets>
                <telerik:ContextMenuTagNameTarget TagName="a" />
            </Targets>
            <Items>
                <telerik:RadMenuItem Text="Menu Item 1" Value="a" />
                <telerik:RadMenuItem Text="Menu Item 2" Value="b" />
            </Items>
        </telerik:RadContextMenu>
        <div style="width: 3500px; height: 100px; position: relative; background-color: yellow;">
            <a style="position: absolute; left: 1000px; top: 40px;" onclick="return showMenu(event);">1000</a>
            <a style="position: absolute; left: 2000px; top: 40px;" onclick="return showMenu(event);">2000</a>
            <a style="position: absolute; left: 3000px; top: 40px;" onclick="return showMenu(event);">3000</a>
        </div>
    </form>
</body>
</html>


Completed
Last Updated: 07 Nov 2018 15:31 by ADMIN
ADMIN
Created by: Ivan Danchev
Comments: 0
Category: UI for ASP.NET AJAX
Type: Bug Report
0
Affects RadCloudUpload and RadAsyncUpload combined with RadProgressArea. Manifests most often on slow networks or very large files.
Scroll down for workarounds for both cases.

NOTE: RadCloudUpload issue is logged separately - https://feedback.telerik.com/Project/108/Feedback/Details/258958-cloudupload-progress-shows-more-than-100-when-uploading-a-file

WORKAROUND FOR PROGRESS AREA is to round down the data, as it seems the server reports more bytes uploaded than they actually are, and that tends to happen under slow network conditions

<telerik:RadAsyncUpload RenderMode="Lightweight" runat="server" ID="RadAsyncUpload1" MultipleFileSelection="Automatic" EnableInlineProgress="false" />
<telerik:RadProgressManager runat="server" ID="RadProgressManager1" />
<telerik:RadProgressArea RenderMode="Lightweight" runat="server" ID="RadProgressArea1" OnClientProgressUpdating="OnClientProgressUpdating" />
<script>
function OnClientProgressUpdating(sender, args) {
    //debugger
    if (args._progressData.PrimaryPercent > 100) {
        args._progressData.PrimaryPercent = 100;
    }
    if (args._progressData.PrimaryValue > args._progressData.PrimaryTotal) {
        args._progressData.PrimaryValue = args._progressData.PrimaryTotal;
    }
    console.log(args.get_progressData());
}
</script>

WORKAROUND FOR CLOUD UPLOAD is to add the following script at the end of the form that will override the built-in XHR handilng to change the way the totals are calculated:

        <script>
            Telerik.Web.UI.RadCloudUpload.HandlerUploader.prototype._initializeXmlHttpRequest = function () {
                this._xhr = new XMLHttpRequest();

                var that = this,
                    module = this._module,
                    xhr = this._xhr;

                xhr.onreadystatechange = function readyStateChanged() {
                    if (xhr.readyState == 4) {
                        if (xhr.status == 200) {
                            that._successfulResponseStatus(xhr);
                        }
                        else if (xhr.status != 0) {
                            that._failedResponseStatus(xhr);
                        }
                    }
                };

                xhr.upload.onprogress = function (event) {
                    that._uploadedSize += event.loaded;

                    var percents = Math.round((event.loaded / event.total) * 100) + "%";

                    module._renderingManager.updateRowProgress(that._uploadingEntity.row, percents, true);
                };
            }
        </script>
Completed
Last Updated: 05 Nov 2018 08:54 by Smit
After having a filter applied, filter value is not cleared when FilterOption was set to "NoFilter".


The following client-side logic would clear the textbox values before the filtering is applied if filter options are set to "NoFilter"

            function onCommand(sender, args) {
                if (args.get_commandName() == "HeaderContextMenuFilter") {
                    var firstTextBox = $("[id$='HCFMRTBFirstCond']")[0].control;
                    var firstFilterOption = args.get_commandArgument().split("|")[1];

                    var secondTextBox = $("[id$='HCFMRTBSecondCond']")[0].control;
                    var secondFilterOption = args.get_commandArgument().split("|")[3];

                    if (firstFilterOption.includes("NoFilter") && firstTextBox.get_value() != "") {
                        args.set_cancel(true);
                        var value = firstTextBox.get_value();
                        firstTextBox.clear();
                        var newArg = args.get_commandArgument().replace("|" + value + "|?", "||?");
                        args.get_tableView().fireCommand(args.get_commandName(), newArg);
                    }

                    if (secondFilterOption.includes("NoFilter") && secondTextBox.get_value() != "") {
                        args.set_cancel(true);
                        var value = firstTextBox.get_value();
                        secondTextBox.clear();
                        var newArg = args.get_commandArgument().replace("|" + value + "|?", "||?");
                        args.get_tableView().fireCommand(args.get_commandName(), newArg);
                    }
                }
            }
Completed
Last Updated: 30 Oct 2018 15:42 by ADMIN
Some colors (for example #ccffff, #ccccff, #e5f2ff, #eef9fc, #003366, #006400) are not properly  applied in the Colorize tab of the Visual Style Builder and choosing one of them results in setting a different color.
Completed
Last Updated: 27 Sep 2018 15:14 by ADMIN
ADMIN
Created by: Rumen
Comments: 0
Category: UI for ASP.NET AJAX
Type: Bug Report
1
I am seeing a strange problem when opening LinkManager dialog from RadEditor. The width of the dialog keeps decreasing on successive opening of the dialog. Sample page code to reproduce this is given below.
You can see a video of this issue at think URL : https://goo.gl/UuPwtA    
Sample page code (code-behind is empty)

<%@ Page Language="C#" AutoEventWireup="true"%>

<!DOCTYPE html PUBLIC "-//W3C//DTD XHTML 1.0 Transitional//EN" "http://www.w3.org/TR/xhtml1/DTD/xhtml1-transitional.dtd">

<html xmlns="http://www.w3.org/1999/xhtml">
<head runat="server">
    <title></title>
    <telerik:RadStyleSheetManager ID="RadStyleSheetManager1" runat="server" />
</head>
<body>
    <form id="form1" runat="server">
        <telerik:RadScriptManager ID="RadScriptManager1" runat="server">
        </telerik:RadScriptManager>
        <div>
            <telerik:RadEditor ID="RadEditor1" runat="server" ToolbarMode="Default" RenderMode="Lightweight"  Skin="Metro"></telerik:RadEditor>
        </div>
    </form>
</body>
</html>

Reproducible in every browser.
Completed
Last Updated: 03 Aug 2018 21:45 by Brad
Completed
Last Updated: 16 Jul 2018 11:16 by ADMIN
The RadFormDecorator decorated checkboxes in the Grid are hard to read when checked in the following skins:
BlackMetroTouch, Bootstrap, Glow, Metro, MetroTouch, Office2010Black, Telerik, WebBlue

Screenshot with Telerik Skin:
https://www.screencast.com/t/1P2hyvWNX

Steps to reproduce:
1. Open http://demos.telerik.com/aspnet-ajax/formdecorator/examples/formdecoratorandtelerikcontrols/defaultcs.aspx?skin=Telerik
2. Scroll to the Grid
3. Select one or all checkboxes
Result: The selected color of the checkbox almost matches the background color
Completed
Last Updated: 14 Jun 2018 11:21 by ADMIN
Workaround: Use the following styles

html .RadGrid_Windows7 .rgSave,
html .RadGrid_Windows7 .rgAdd,
html .RadGrid_Windows7 .rgRefresh,
html .RadGrid_Windows7 .rgEdit,
html .RadGrid_Windows7 .rgDel,
html .RadGrid_Windows7 .rgFilter,
html .RadGrid_Windows7 .rgPagePrev,
html .RadGrid_Windows7 .rgPageNext,
html .RadGrid_Windows7 .rgPageFirst,
html .RadGrid_Windows7 .rgPageLast,
html .RadGrid_Windows7 .rgExpand,
html .RadGrid_Windows7 .rgCollapse,
html .RadGrid_Windows7 .rgSortAsc,
html .RadGrid_Windows7 .rgSortDesc,
html .RadGrid_Windows7 .rgUpdate,
html .RadGrid_Windows7 .rgCancel,
html .RadGrid_Windows7 .rgUngroup,
html .RadGrid_Windows7 .rgExpXLS,
html .RadGrid_Windows7 .rgExpDOC,
html .RadGrid_Windows7 .rgExpPDF,
html .RadGrid_Windows7 .rgExpCSV {
    background-image: none;
}

html .RadGrid_Windows7 th.rgSorted {
        background-image: none;
}

html .RadGrid_Windows7 .rgMasterTable .rgSelectedCell,
html .RadGrid_Windows7 .rgSelectedRow {
        background-image: none;
}

html .RadGrid_Windows7 .rgMasterTable .rgActiveCell,
html .RadGrid_Windows7 .rgActiveRow,
html .RadGrid_Windows7 .rgHoveredRow {
           
        background-image: none;
}

html .RadGrid_Windows7 .rgEditRow {
        background-image: none;
}

html .RadGrid_Windows7 .rgPager {
    background-image: none;
}

    html .RadGrid_Windows7 .rgPager .rgPagerButton {
            background-image: none;
    }

html .RadGrid_Windows7 .rgNumPart a:hover,
html .RadGrid_Windows7 .rgNumPart a.rgCurrentPage {
        background-image: none;
}

    html .RadGrid_Windows7 .rgNumPart a:hover span,
    html .RadGrid_Windows7 .rgNumPart a.rgCurrentPage span {
            background-image: none;
    }

html .GridReorderTop_Windows7 {
    background-image: none;
}

html .GridReorderBottom_Windows7 {
    background-image: none;
}

html .RadGrid_Windows7 .rgGroupPanel {
    background-image: none;
}

html .RadGrid_Windows7 .rgGroupItem {
        background-image: none;
}

html .RadGrid_Windows7 .rgGroupHeader {
    background-image: none;
}

html .RadGrid_Windows7 .rgCommandRow {
    background-image: none;
}
Completed
Last Updated: 28 May 2018 06:13 by ADMIN
Created by: Jean-Marc
Comments: 3
Category: UI for ASP.NET AJAX
Type: Feature Request
5
Could it be possible to see you developing a chat component to offer chat possibilities on a telerik Ajax Website?

Would be great

Thanks for all you do to simplify our developer life !

Best

Jm Hetsch
Completed
Last Updated: 01 May 2018 14:40 by ADMIN
I would like the ability to generate a graphic (.jpg, .bmp) of page 1 of a pdf document so it can be placed in a grid cell.
Completed
Last Updated: 01 May 2018 14:28 by ADMIN
Created by: Manjushree
Comments: 1
Category: UI for ASP.NET AJAX
Type: Feature Request
0

			
Completed
Last Updated: 17 Apr 2018 11:53 by Raymond
There are two ways to avoid this:

- Define a tab order on the entire page so all necessary controls will have their TabIndex attribute set

- Remove the attribute from the menu with JS. Here follow a couple of examples. Using RenderMode="Lightweight" also may improve the situation if you do not use the NavigateUrl of the items, so <a> elements are not rendered.

     - Solution 1: Executes when the entire page has loaded
               function removeMenuTabIndex() {
                   $telerik.$(".RadMenu[tabindex=0]").removeAttr("tabindex");
                   Sys.Application.remove_load(removeMenuTabIndex);
               }
               Sys.Application.add_load(removeMenuTabIndex);

     - Solution 2: Add just after the menu so it executes while the DOM is loading, perhaps this can facilitate screen reader compatibility

        <telerik:RadMenu runat="server" ID="rm1" RenderMode="Lightweight">
                <Items>
                    <telerik:RadMenuItem Text="first"></telerik:RadMenuItem>
                    <telerik:RadMenuItem Text="second"></telerik:RadMenuItem>
                </Items>
        </telerik:RadMenu>
        <script>
            document.getElementById("<%=rm1.ClientID%>").removeAttribute("tabIndex");
        </script>
Completed
Last Updated: 16 Apr 2018 10:17 by ADMIN
Completed
Last Updated: 11 Apr 2018 10:52 by ADMIN
Javascript errors are thrown when pie chart with custom skin is loaded. The issue is introduced as of version 2017.1.118.

Code to reproduce:
        <telerik:RadHtmlChart ID="Telerik1" runat="server" Height="250px" Width="250px" EnableEmbeddedSkins="false" Skin="CMS_Black">
            <ChartTitle Text="Financial Aid Status1112">
                <Appearance>
                    <TextStyle Color="Red" FontSize="12" FontFamily="Verdana" Margin="11" Padding="22"></TextStyle>
                </Appearance>
            </ChartTitle>
            <PlotArea>
                <Series>
                    <telerik:PieSeries Name="TypeMemberCount1" NameField="Name" DataFieldY="Value">
                        <LabelsAppearance>
                            <ClientTemplate>
                               #=dataItem.Name#: #=dataItem._Value# (#=dataItem._Percentage#%)
                            </ClientTemplate>
                        </LabelsAppearance>
                    </telerik:PieSeries>
                </Series>
            </PlotArea>
            <Legend>
                <Appearance Position="Right" Visible="true">
                </Appearance>
            </Legend>
        </telerik:RadHtmlChart>


Code bihind:

    protected void Page_Load(object sender, EventArgs e)
    {
        Telerik1.DataSource = GetData();
        Telerik1.DataBind();

    }
    private DataTable GetData()
    {
        DataTable dt = new DataTable("ChargeData");
        
        dt.Columns.Add("Id", Type.GetType("System.Int32"));

        dt.Columns.Add("Name", Type.GetType("System.String"));
        dt.Columns.Add("Value", Type.GetType("System.Int32"));
        dt.Columns.Add("_Value", Type.GetType("System.Int32"));
        dt.Columns.Add("_Percentage", Type.GetType("System.Int32"));

        dt.Rows.Add(1, "Item 1", 10, 34, 10);
        dt.Rows.Add(2, "Item 2", 65, 34, 65);
        dt.Rows.Add(3, "Item 3", 25, 34, 25);
        return dt;
    }


web.config:

    <add key="Telerik.Skin" value="CMS_Black"/>

Ticket 1113172