Pending Review
Last Updated: 11 Nov 2015 13:16 by reinout
Approved
Last Updated: 14 Oct 2015 16:14 by ADMIN
Completed
Last Updated: 24 Sep 2015 10:03 by ADMIN
When you set Lightweight render mode via web.config, the image editor appears broken.

You can use the following setup in web.config as a workaround for the time being. Note that all instances of the RadToolBar will be rendered in Classic mode.
 <appSettings>
      ....
      <add key="Telerik.Web.UI.RenderMode" value="Auto" />   
      <add key="Telerik.Web.UI.ToolBar.RenderMode" value="Classic" />
       ....
</appSettings>
Approved
Last Updated: 10 Aug 2015 23:19 by Sparq
Steps to reproduce:
1. Open http://demos.telerik.com/aspnet-ajax/imageeditor/examples/overview/defaultcs.aspx in IE9
2. Upload the attached image.
3. Try to resize the image

Result: The browser crashes
Completed
Last Updated: 06 Aug 2015 10:35 by DavidS
Completed
Last Updated: 09 Jun 2015 10:02 by ADMIN
When the cropping box is resized through one of its left corners, the position of the cropping box is changed at all. The issue could be reproduced in all browsers. http://screencast.com/t/PDns6kPb
Completed
Last Updated: 05 May 2015 10:43 by ADMIN
ADMIN
Created by: Vessy
Comments: 1
Category: ImageEditor
Type: Bug Report
0
The new version allows shape resizing on the image editor. 

However this is not working in a stable fashion. Here is the list of steps to replicate

a. Draw a rectangle
b. Hold the central marker to drag the rectangle. it moves slightly and then nothing happens
c. Try holding any other marker to move the rectangle it does not work
Completed
Last Updated: 22 Apr 2015 12:57 by ADMIN
Adding ImageEditor inside a RadPanel breaks the RadPanels designer. The problematic behavior can be observed with the following configuration:

        <telerik:RadPanelBar ID="RadPanelBar1" Runat="server">
            <Items>
                <telerik:RadPanelItem runat="server" Text="Root RadPanelItem1">
                    <ContentTemplate>
                        <telerik:RadImageEditor ID="RadImageEditor1" runat="server" ImageUrl="~/Images/Jellyfish - Copy.jpg"></telerik:RadImageEditor>
                        <asp:Button runat="server" ID="dasd" />
                        <telerik:RadEditor ID="RadEditor1" runat="server"></telerik:RadEditor>
                    </ContentTemplate>
                </telerik:RadPanelItem>
            </Items>
        </telerik:RadPanelBar>
Declined
Last Updated: 09 Apr 2015 12:58 by ADMIN
ADMIN
Created by: Vessy
Comments: 1
Category: ImageEditor
Type: Feature Request
0
Images bigger than 10MB cannot be saved if the ImageEditor is used in enabled CanvasMode, even though the MaxJsonLenght property is configured. The ImageSaving event handler is also never called.


The only possible workaround for the moment is using the ImageEditor in disabled CanvasMode (CanvasMode="No")
Completed
Last Updated: 24 Dec 2014 14:48 by ADMIN
When the CanvasMode of the ImageEditor is enabled, the JPG images are saved as PNG.

Steps to reproduce:

1. Open the following online demo: http://demos.telerik.com/aspnet-ajax/imageeditor/examples/canvassupport/defaultcs.aspx

2. Use the configurator above the ImageEditor to enable the CanvasMode

3. Save the image, choosing the "Download image" option

4. The image, which original format is JPG is saved as a PNG (with increased size)

A video, demonstrating the issue is available here: http://screencast.com/t/FL3Gs6soz7F
Approved
Last Updated: 21 Jul 2014 12:45 by ADMIN
When the page is zoomed in iOS and Android devices, lines drawn are displaced downwards and to the right. Displacement increases with image zooming.

Configurations tested:
- iOS + Safari;
- Android + Chrome;
Approved
Last Updated: 17 Mar 2014 13:13 by ADMIN
When the command dialogs from two ImageEditors on a page are opened consecutively, the second dock is rendered with wrong position. The issue most probably comes from the fact the second dock element (ToolsPanel) is appended to its parent ImageEditor, but not to the form.

Assuring that each dock is appended to the form element can be used as a temporary workaround of the issue:

        <telerik:RadImageEditor ID="RadImageEditor1" runat="server" Width="680" Height="450" OnClientDialogLoaded="ClientDialogLoaded"
            ImageUrl="waterpool.jpg">
        </telerik:RadImageEditor>
        <telerik:RadImageEditor ID="RadImageEditor2" runat="server" Width="680" Height="450" OnClientDialogLoaded="ClientDialogLoaded"
            ImageUrl="waterpool.jpg">
        </telerik:RadImageEditor>
        <script>
            function ClientDialogLoaded(imageEditor, args) {
                setTimeout(function () {
                    $telerik.$("#<%=form1.ClientID %>").append($get(imageEditor.get_id() + "_ToolsPanel"));
                }, 0);
            }
        </script>
Declined
Last Updated: 01 Nov 2013 13:06 by ADMIN
When a big image(~3MB) is loaded into the ImageEditor ( with enabled CanvasMode) sometimes the image is not loaded into the controls or the whole page crashes. The issue could be reproduced in Google Chrome, with the 2013 Q1 SP1 version of the controls.
Completed
Last Updated: 04 Sep 2013 12:17 by ADMIN
ADMIN
Created by: Stamo Gochev
Comments: 0
Category: ImageEditor
Type: Bug Report
1
After the LIB (2013.1.423) the Save (on server) functionality of the ImageEditor doesn't work properly and throws a javascript error.
1 2