Pending Review
Last Updated: 30 Apr 2019 10:06 by ADMIN
If anchor links of GridButtonColumn do not define a text links are still rendered and screen readers read their href attribute. Anchor links with no text could define an attribute area-hidden="true".
Pending Review
Last Updated: 21 Jun 2017 18:33 by moegal
The FooterAggregateFormatString functionality of the Grid does not affect the Aggregates values format in a client-bound Grid.

Code to reproduce:
            <telerik:RadGrid RenderMode="Lightweight" ID="RadGrid1" runat="server" ClientDataSourceID="RadClientDataSource1" AllowPaging="true" AllowSorting="true" AllowFilteringByColumn="true" ShowFooter="true">
                <MasterTableView ClientDataKeyNames="CustomerID" EditMode="Batch" CommandItemDisplay="Top" BatchEditingSettings-HighlightDeletedRows="true">
                    <Columns>
                        <telerik:GridBoundColumn DataField="CustomerID" HeaderText="Customer ID"  Aggregate="Count" FooterAggregateFormatString="No currency sign here: {0:C}">
                        </telerik:GridBoundColumn>
                        <telerik:GridBoundColumn DataField="CompanyName" HeaderText="Company Name" ColumnEditorID="GridTextBoxEditor">
                        </telerik:GridBoundColumn>
                        <telerik:GridBoundColumn DataField="ContactName" HeaderText="Contact Name" ColumnEditorID="GridTextBoxEditor">
                        </telerik:GridBoundColumn>
                        <telerik:GridBoundColumn DataField="ContactTitle" HeaderText="Contact Title" ColumnEditorID="GridTextBoxEditor">
                        </telerik:GridBoundColumn>
                        <telerik:GridClientDeleteColumn HeaderText="Delete">
                            <HeaderStyle Width="70px" />
                        </telerik:GridClientDeleteColumn>
                    </Columns>
                </MasterTableView>
                <ClientSettings>
                    <ClientEvents OnUserAction="UserAction" />
                </ClientSettings>
            </telerik:RadGrid>
Pending Review
Last Updated: 05 Jan 2017 11:07 by Bo
The SpreadProcessing library gets into account the current server culture and the SpreadsheetDocumentProvider uses different decimal and list separators based on the culture while the RadSpreadsheet control supports only comma as a list separator and dot as a decimal separator. 

The JavaScript error that is thrown when using the "sv-SE" culture is caused by the fact that this culture uses the comma as a decimal separator and semicolon as a list separator. 

One possible workaround is to change the current thread's culture before creating the Spreadsheet's provider and then restore the culture.
Pending Review
Last Updated: 21 Jun 2016 14:52 by Alexandre
Using the client-side requestItems method of a RadComboBox to fire the refresh of it's items(with a call to clearCache before to ensure that the refresh is performed), doesn't always perform the async callback request, sometimes resulting in the "Loading" text being added at the top of the combo's items drop-down and staying there (as the callback to the server is never fired, so it's result never received). 

After quite a bit of trials, I finally managed to figure out that the issue arise when there is an async postback in progress on the page (to refresh an update panel) when requestItems is called.

Stepping through the requestItems call with IE F12 tools, I found that this is due to the fact that the Sys.WebForms.PageRequestManager do not perform callbacks if there is an async postback in progress. I think that the RadComboBox should detect that situation and wait until the end of the async postback to fire it's requestItems callback, otherwise the combo get stuck in the "loading in progress" state, waiting for the end of the callback that will never happens as the PageRequestManager did not start it. Additionally, in F12 Network tab, I can see that there is no request performed for the callback to request the items of the combo-box.

I reproduce the issue with the following steps:
1- Have a page with a RadComboBox, a ScriptManager with partial rendering enabled and an UpdatePanel.
2- In the browser, trigger the async postback to refresh the UpdatePanel
3- From JavaScript, while the async postback is in progress, call the requestItems method of the RadComboBox
4- Open the drop-down of the combo, and you can see the "Loading" text at the top, with the initial list of items. And it stays like this until another call is made to requestItems when there is no async post-back in progress which will actually perform the callback.
Pending Review
Last Updated: 02 Feb 2017 11:59 by ADMIN
ADMIN
Created by: Marin Bratanov
Comments: 0
Category: Button
Type: Bug Report
1
select an item from the dropdown, different than "1"
expected: buttons become enabled
actual: radbutton is still disabled

        <asp:Button ID="ButtonTest" runat="server" enabled="true" Text="Test" EnableViewState="False" />
        <telerik:RadPushButton ID="RadButtonTest" runat="server" Text="RadButtonTest" Enabled="True" EnableViewState="False" RenderMode="Lightweight"></telerik:RadPushButton>
        <asp:DropDownList runat="server" ID="DropDownTest" AutoPostBack="True" OnSelectedIndexChanged="SelectedIndexChanged_Test">
            <Items>
                <asp:ListItem Text="1" Value="1"></asp:ListItem>
                <asp:ListItem Text="2" Value="2"></asp:ListItem>
                <asp:ListItem Text="3" Value="3"></asp:ListItem>
                <asp:ListItem Text="4" Value="4"></asp:ListItem>
            </Items>
        </asp:DropDownList>

		protected void Page_LoadComplete(object sender, EventArgs e)
		{
			if (DropDownTest.SelectedValue == "1")
			{
				ButtonTest.Enabled = false;
				RadButtonTest.Enabled = false;
			}
			else//workaround
			{
				string script = string.Format("function f(){{$find('{0}').set_enabled({1});Sys.Application.remove_load(f);}}Sys.Application.add_load(f);",
												 RadButtonTest.ClientID, 
												 "true");
				ScriptManager.RegisterStartupScript(Page, Page.GetType(), "someKey", script, true);
			}
		}

		protected void SelectedIndexChanged_Test(object sender, EventArgs e)
		{
		}
Pending Review
Last Updated: 07 Apr 2017 12:32 by ADMIN
A workaround is to have the tile list use the Default skin and change the tiles classes with JavaScript in the OnClientTileDataBound event

			<asp:ScriptManager ID="Scriptmanager1" runat="server" />
			<telerik:RadSkinManager runat="server" ID="rsm1" Skin="mySkinName"></telerik:RadSkinManager>
			<telerik:RadClientDataSource runat="server" ID="RadClientDataSource1" PageSize="8" AllowPaging="true">
				<DataSource>
					<WebServiceDataSourceSettings BaseUrl="http://demos.kendoui.com/service/">
						<Select Url="products" DataType="JSONP" />
					</WebServiceDataSourceSettings>
				</DataSource>
			</telerik:RadClientDataSource>
			<telerik:RadTileList ID="rtl" runat="server" RenderMode="Classic" TileRows="3" SelectionMode="Multiple" OnClientTileDataBound="createTile" OnClientTileClicked="tileClicked" EnableEmbeddedSkins="false" Skin="Default" ClientDataSourceID="RadClientDataSource1">
				<DataBindings>
					<CommonTileBinding TileType="RadContentTemplateTile" DataNameField="ProductID" DataTitleTextField="ProductName" DataBadgeValueField="UnitPRice" Shape="Square" />
					<ContentTemplateTileBinding>
						<ClientContentTemplate>
					<div style="height: 150px; background-image: url('#= ProductName #');">
						<div style="padding: 5px 8px 3px 8px;">
							<div>#= ProductName #</div>
							<div style="font-size:0.8em; width: 134px; word-wrap:break-word; padding-bottom: 8px;">#= UnitsInStock #</div>
							<div class="field pad" >
								<img src="images/email.png" title="Can be emailed">
								</img>
							</div>
							<div class="field pad">
								<img src="images/SMS.png" title="Can receive SMS">
								</img>
							</div>
							<div class="field pad">
								<img src="images/noentry.png" title="Has a restricted password">
								</img>
							</div>
						</div>
					</div>
						</ClientContentTemplate>
					</ContentTemplateTileBinding>
					<ClientTilePeekTemplate>
				<div style="height: 150px; background-image: url('styles/#= ProductName #/images/large/user.jpg');">
					<div style="padding: 5px 8px 5px 8px; width: 134px; height: 140px; background-color: azure;">
						<div>#= ProductName #</div>
						<div class="field" style="font-size:0.8em; width: 100px;">#= ProductID #</div>
						<div class="field" style="font-size:0.8em; width: 34px; text-align: right;">#= ProductID #</div>
						<div class="field" style="font-size:0.8em; width: 100px;">#= ProductName #</div>
						<div class="field" style="font-size:0.8em; width: 34px; text-align: right;">#= ProductName #</div>
						<div class="field" style="font-size:0.8em; width: 100px;">#= UnitPrice #</div>
						<div class="field" style="font-size:0.8em; width: 34px; text-align: right;">#= UnitPrice #</div>
						<div class="field" style="font-size:0.8em; width: 100px;">#= UnitsInStock #</div>
						<div class="field" style="font-size:0.8em; width: 34px; text-align: right;">#= Discontinued #</div>
					</div>
				</div>
					</ClientTilePeekTemplate>
				</DataBindings>
			</telerik:RadTileList>
			<script>
				function createTile(sender, args) {
					var tileElem = $telerik.$(args.get_tile().get_element());
					tileElem.removeClass("RadTile_Default").addClass("RadTile_mySkinName");
				}
				function tileClicked() {
				}
			</script>
Pending Review
Last Updated: 30 May 2017 07:01 by Satish
"Loading..." text in Combobox with Virtual Scrolling is visible on first set of items loading.
It shows first time "Loading..." text. on scrolling it loads items from PageMethods/WebService but "Loading..." text it not visible i.e. because it is first <LI> item so it is not visible.

Instead of first <LI> item, it  should be at position where it always display while loading more items.

same issue is also in telerik demo website : http://demos.telerik.com/aspnet-ajax/combobox/examples/populatingwithdata/autocompletesql/defaultcs.aspx
Pending Review
Last Updated: 30 May 2017 07:14 by Satish
Put more than two RadDatePicker with single SharedCalendar on page. some RadDatePicker are in side of UpdatePanel with a button in it. when I press that button RadDatePicker behaviour is strange. 
RadDatePicker inside UpdatePanel not opening Calendar popup while RadDatePicker outside UpdatePanel opens calendar popup but gives javascript error on any date selection. the javascript error is "Unable to get property '_selectedDates' of undefined or null reference".
It looks like it is destroying shared calendar object on partial postback.
Please find below sample code to replicate the issue. after clicking "Submit" button, it doesn't open calendar popup for "Date 2" and for "Date 1" it opens but doesn't allow to select date and gives JavaScript error.

----------------------
<asp:ScriptManager ID="sc1" runat="server" />
<telerik:RadCalendar ID="dtCal" runat="server" EnableMultiSelect="false" />
Date 1:
<telerik:RadDatePicker ID="dt1" Width="103px" runat="server" SharedCalendarID="dtCal" />
<hr />
<asp:UpdatePanel runat="server" ID="up">
	<ContentTemplate>
		Date 2:
		<telerik:RadDatePicker ID="dt2" Width="103px" runat="server" SharedCalendarID="dtCal" />
		<br />
		<asp:Button runat="server" ID="btnDT" Text="Submit" />
	</ContentTemplate>
</asp:UpdatePanel>
----------------------

When i add all controls in UpdatePanel it works properly. but Actual code is much more complex than above sample with too many lines of javascript code and many date pickers on single page and simply all Calendar and DatePicker controls can not be moved in UpdatePanel.
Pending Review
Last Updated: 19 Jan 2017 22:55 by bryan
Created by: bryan
Comments: 0
Category: DropDownList
Type: Bug Report
1
RadDropDownList has an attribute "DropdownWidth" that controls the width of the LIST when it drops down.   

If you set the width to a specific number of pixels (say 200px) then there is no issue.   But if you set it to "100%"  then I would have expected it to be 100% of the owner controls width.   But this is not the case, and it becomes very evident when the RadDropDownList is used with a template column of a RadGrid.  

In a RadGrid template column, this setting causes the LIST width to expand all the way to the right edge of the screen.   This seems to me to be a bug, as it makes no sense to behave this way.   You can see this behavior in the screenshot I have attached.  

It becomes more evident that this was not the intended functionality (and must be a bug) when you substitute the control with a RadComboBox, having exactly the same attributes.  This will use the combo's default settings and show a dropdown list.  With the RadCombBox the LIST does not expand to the far right of the screen, it behaves as expected, having 100% of the combobox width.  

I would expect both controls to work identically with their LISTS when setting the "DropdownWidth" attribute to "100%".
Pending Review
Last Updated: 05 Jul 2017 12:32 by ADMIN
ADMIN
Created by: Rumen
Comments: 0
Category: Window
Type: Bug Report
1
When I try to close the RadWindow on mobile (Chrome Mobile, Chrome Mobile desktop emulator) by clicking on the default Close button (aka X button), if I have a clickable element behind the X button, this one also grabs the input and triggers the OnClick event of the behind element.

The problem can be reproduced in the following demo http://demos.telerik.com/aspnet-ajax/window/examples/radopen/defaultcs.aspx.

Workaround:
<script>   
        function OnClientShow(sender, args) {
            $telerik.$(".rwCloseButton").bind("touchstart", function (e) {
                $telerik.cancelRawEvent(e);
            });
       }
</script>
<telerik:RadWindow OnClientBeforeShow="OnClientShow" RenderMode="Lightweight" ID="RadWindow1" runat="server" ShowContentDuringLoad="false" Width="400px"
                Height="400px" Title="Telerik RadWindow" Behaviors="Default">
</telerik:RadWindow>
Pending Review
Last Updated: 18 Oct 2017 23:54 by Daniel
When setting client events in a RadTextBox and using an EmptyMessage, the EmptyMessage will trigger the event on page load.  This is true for a multiple TextMode but others are untested. 
Pending Review
Last Updated: 19 Jan 2018 10:26 by ADMIN
The full stract trace of the error can be found in the attached file.
Pending Review
Last Updated: 25 Aug 2017 08:11 by Arvind
For Bug Report :

Note: We are using MM/dd/yyyy as Internal Date format to prevent issue while inserting or updating value.

Steps to reproduce:
When we use dd-MM-yyyy and yyyy-dd-MM Date DisplayFformat for RadDatePicker/RadDateTimePicker control as well as view mode in Radgrid Batch Edit mode it's render behaviour is inconsistent
1. When dd is less than or equal to 12 then while rendering in edit mode Month and Date is interchanged
2. When dd is greather than 12 then while rendering in edit mode Month and Date is rendered correctly.
Pending Review
Last Updated: 08 Nov 2018 14:27 by Attila Antal
ADMIN
Created by: Attila Antal
Comments: 0
Category: UI for ASP.NET AJAX
Type: Bug Report
1
Images that reside in the grid will get resized (scaled down with about 3-5 %) which might cause issues, specially if exporting bar-codes, thus the bar-code scanners won't be able to read them.

Current workaround is to use the Telerik Documents Processing Library  and build the table manually where the images are inserted without changing the size.

Here is an example:

        protected void RadGrid1_InfrastructureExporting(object sender, GridInfrastructureExportingEventArgs e)
        {
            Telerik.Web.UI.ExportInfrastructure.Table table = e.ExportStructure.Tables[0];

            Workbook workbook = new Workbook();
            workbook.Worksheets.Add();

            Worksheet worksheet = workbook.ActiveWorksheet;


            foreach (var row in table.Rows)
            {
                if (row.Index > 1)
                {
                    worksheet.Rows[row.Index - 1].SetHeight(new RowHeight(55, true));
                }

                foreach (var cell in row.Cells)
                {
                    if (row.Index == 1 || cell.ColIndex != 2)
                    {
                        worksheet.Cells[cell.Index.Y - 1, cell.Index.X - 1].SetValue(cell.Value.ToString());
                    }
                    else
                    {
                        FloatingImage image = new FloatingImage(worksheet, new CellIndex(cell.Index.Y - 1, cell.Index.X - 1), 0, 0);
                        Stream stream = File.Open(Server.MapPath(cell.Value.ToString()), FileMode.Open);
                        using (stream)
                        {
                            image.ImageSource = new Telerik.Windows.Documents.Media.ImageSource(stream, "jpg");
                        }
                        worksheet.Shapes.Add(image);
                    }
                }
            }

            byte[] data;

            using (MemoryStream ms = new MemoryStream())
            {
                XlsxFormatProvider xlsProvider = new XlsxFormatProvider();
                xlsProvider.Export(workbook, ms);
                data = ms.ToArray();
            }

            Response.ContentType = "application/vnd.openxmlformats-officedocument.spreadsheetml.sheet";
            Response.Headers.Remove("Content-Disposition");
            Response.AppendHeader("Content-Disposition", "attachment; filename=" + RadGridLista.ExportSettings.FileName + ".xlsx");
            Response.BinaryWrite(data);
            Response.End();
        }
Pending Review
Last Updated: 12 Feb 2019 13:36 by ADMIN
Steps to reproduce the error.

Create a ClientDeleteColumn with CommandName="Delete" and wire up the onCommand client-event to RadGrid.

<telerik:RadGrid ID="RadGrid1" runat="server">
    <MasterTableView>
        <Columns>
            <telerik:GridClientDeleteColumn CommandName="Delete" ButtonType="LinkButton"></telerik:GridClientDeleteColumn>
        </Columns>
    </MasterTableView>
    <ClientSettings>
        <ClientEvents OnCommand="OnCommand" />
    </ClientSettings>
</telerik:RadGrid>

The event handler does not need to do anything.

function OnCommand(sender, args) {
}
Pending Review
Last Updated: 18 Jul 2019 12:22 by ADMIN

If the Page culture is set to anything other than "en-US", RadDatePicker in the HeaderContextMenu will loose the correct format and swaps the Day with the Month after filtering.

Pending Review
Last Updated: 03 Jun 2019 08:01 by ADMIN
When Grouping in RadGrid while EnableLinqExpressions is set to True and some of the records contain null values will throw the exception: Object cannot be cast to DBNull
Pending Review
Last Updated: 08 Oct 2019 03:03 by Kasim
Created by: Kasim
Comments: 2
Category: Window
Type: Bug Report
1

Bug 1:

When RadWindow behavior is set to Maximize/Minimize only, the expected behavior is while minimized, it must only show Maximize button and when maximized, it should show minimize button. 

Currently, it is showing restore button on minimizing and then it restores to a random size.

Bug 2:

Page reloads on maximizing the minimized page.

  1. If the page requires authentication, the user has to login again.
  2. If the user is on some of the internal pages on a portal, the user is redirected to the login page without referer URL.
Pending Review
Last Updated: 17 Oct 2019 08:39 by ADMIN
Created by: Jeff
Comments: 1
Category: TabStrip
Type: Bug Report
0

Accessibility Insights is reporting invalid markup on all tabs in the TabList.

When consulting the online aria specifications I see that elements with role="tablist" support aria-level="#" where number is > 0.  (https://www.w3.org/TR/wai-aria-1.2/#tablist) However, elements with role="tab" do not. (https://www.w3.org/TR/wai-aria-1.2/#tab)

If possible, we would like to see the aria-level tag moved to the correct page elements in the next release. (Thanks for correcting the aria-level="0" problem previously.) 

I believe this may be the compliance issue Sunil was reporting previously here: https://feedback.telerik.com/aspnet-ajax/1413112-this-ul-should-only-contain-li-elements-without-an-aria-assigned-role

1 2 3 4