Won't Fix
Last Updated: 30 Apr 2015 12:33 by Elena
For the time being the following workaround can be used:

    <style>
        .k-chart .k-tooltip, .k-sparkline .k-tooltip, .k-stockchart .k-tooltip {
            background-image: url("//:image/png;base64,iVBORw0KGgoAAAANSUhEUgAAABQAAAAWCAYAAADAQbwGAAAAGXRFWHRTb2Z0d2FyZQBBZG9iZSBJbWFnZVJlYWR5ccllPAAAADNJREFUeNpi/P//vwMDFQELEP8beQb+HTWQYgP/DHoD/466cAR4edRAyg38P6hLbIAAAwCnWhhVsxvdCAAAAABJRU5ErkJggg==") !important;
        }
    </style>
Completed
Last Updated: 26 Feb 2015 18:19 by ADMIN
ADMIN
Created by: Danail Vasilev
Comments: 0
Category: HtmlChart
Type: Bug Report
0
For the time being the CommonTooltipsAppearance.Shared property must be set to false. For example:

        <telerik:RadHtmlChart ID="RadHtmlChart2" runat="server" Layout="Sparkline" Width="100" Height="150">
            <PlotArea>
                <CommonTooltipsAppearance Shared="false"></CommonTooltipsAppearance>
                <Series>
                    <telerik:LineSeries>
                        <TooltipsAppearance>
                            <ClientTemplate>
                                Value: #=value# <br />
                                Category #=category#
                            </ClientTemplate>
                        </TooltipsAppearance>
                        <SeriesItems>
                            <telerik:CategorySeriesItem Y="30" />
                            <telerik:CategorySeriesItem Y="10" />
                            <telerik:CategorySeriesItem Y="20" />
                        </SeriesItems>
                    </telerik:LineSeries>
                </Series>
                <XAxis>
                    <Items>
                        <telerik:AxisItem LabelText="item 1" />
                        <telerik:AxisItem LabelText="item 2" />
                        <telerik:AxisItem LabelText="item 3" />
                    </Items>
                </XAxis>
            </PlotArea>
        </telerik:RadHtmlChart>
Completed
Last Updated: 06 Oct 2015 14:48 by ADMIN
Unplanned
Last Updated: 29 Jul 2016 13:08 by Phil
Created by: Phil
Comments: 0
Category: HtmlChart
Type: Bug Report
0
Under the standard definition of data format strings, range scaling can be applied (i.e. divide by 1000) using , prefixing the implied or explicit decimal place.
e.g. DataFormatString="{0:#,#,}" will display 3000000 as 3,000

This works on RadPivotGrid correctly, but RadHTMLChart does not work either on data labels, axis labels, or pretty much anywhere else. Apparently a problem with kendo.format(), which does not do this as per documentation for DataFormatString

N.B. This is commonly used in finance presentations to globally present in $thousands.
Completed
Last Updated: 13 Nov 2015 12:20 by ADMIN
When data-bound categorical series has zeros in the x-axis labels they are parsed and the zeros disappear. For example:
ASPX:

            <asp:ScriptManager ID="ScriptManager1" runat="server"></asp:ScriptManager>
            <telerik:RadHtmlChart runat="server" ID="Radhtmlchart1">
                <PlotArea>
                    <Series>
                        <telerik:ColumnSeries DataFieldY="Score1"></telerik:ColumnSeries>
                   </Series>

                   <XAxis DataLabelsField="Student">
                    </XAxis>
                </PlotArea>
            </telerik:RadHtmlChart>

C#:

    protected void Page_Load(object sender, EventArgs e)
    {
        Radhtmlchart1.DataSource = GetData();
        Radhtmlchart1.DataBind();
    }
    protected DataTable GetData()
    {
        DataTable table = new DataTable();

        table.Columns.Add("Student", typeof(string));
        table.Columns.Add("Score1", typeof(int));

        table.Rows.Add(new object[] { "0806014562", 40 });
        table.Rows.Add(new object[] { "0806014562", 50 });
        table.Rows.Add(new object[] { "0806014562", 70 });
        return table;
    }
Workarounds:
1) Use format string to add the desired missing zeros when parsed.

<LabelsAppearance DataFormatString="0{0}"></LabelsAppearance>

2) Add items programmatically

    protected void Page_Load(object sender, EventArgs e)
    {
        Radhtmlchart1.DataSource = GetData();
        Radhtmlchart1.DataBind();

        DataTable currDT = GetData();
        for (int i = 0; i < currDT.Rows.Count; i++)
        {
            AxisItem currItem = new AxisItem(currDT.Rows[i]["Student"].ToString());
            Radhtmlchart1.PlotArea.XAxis.Items.Add(currItem);
        }
    }
Unplanned
Last Updated: 29 Jul 2014 08:11 by Sean
Created by: Sean
Comments: 0
Category: HtmlChart
Type: Bug Report
0
I have a stacked bar RadHtmlChart that is created programmatically in the code behind.
When I create the chart, and set the width to Unit.Pixel(1500), it works fine, as shown in Working.png. However, when I change the value to Unit.Percentage(90), the chart is not rendered properly at all.

Any fixes/workarounds for this?

Seán


For the time being you must set percentage to the chart's wrapper. For example:
CSS:
	<style type="text/css">
		html, body, form {
			padding: 0;
			margin: 0;
			height: 100%;
			overflow: hidden;
		}

		.myChart {
			width: 100% !important;
			height: 100% !important;
		}
	</style>
ASPX:
		<div style="width: 30%; height: 40%; border: 1px solid green;">
			<telerik:RadHtmlChart runat="server" ID="RadHtmlChart1" CssClass="myChart" Width="600px" Height="400px">
				<PlotArea>
					<Series>
						<telerik:ColumnSeries Name="Product 1">
							<SeriesItems>
								<telerik:CategorySeriesItem Y="15000" />
								<telerik:CategorySeriesItem Y="23000" />
								<telerik:CategorySeriesItem Y="10000" />
							</SeriesItems>
						</telerik:ColumnSeries>
					</Series>
					<XAxis>
						<Items>
							<telerik:AxisItem LabelText="1" />
							<telerik:AxisItem LabelText="2" />
							<telerik:AxisItem LabelText="3" />
						</Items>
					</XAxis>
				</PlotArea>
				<ChartTitle Text="Product sales for 2011">
				</ChartTitle>
				<Legend>
					<Appearance Position="Bottom" />
				</Legend>
			</telerik:RadHtmlChart>
		</div>
Won't Fix
Last Updated: 20 Jan 2016 11:52 by ADMIN
A workaround is to use the ClientTemplate and change the strings manually with some JavaScript (http://www.telerik.com/help/aspnet-ajax/htmlchart-client-templates-for-tooltips-and-labels-execute-javascript-and-display-html.html), e.g.:
<telerik:RadHtmlChart runat="server" ID="RadHtmlChart1" Width="400px" Height="400px">
	<PlotArea>
		<Series>
			<telerik:BarSeries>
			<LabelsAppearance>
			<ClientTemplate>
				#if (value > 0) {# $#=value# #} else {# -$#=value * -1# #} #
			</ClientTemplate>
			</LabelsAppearance>
				<SeriesItems>
					<telerik:CategorySeriesItem Y="20" />
					<telerik:CategorySeriesItem Y="10" />
					<telerik:CategorySeriesItem Y="-30" />
				</SeriesItems>
			</telerik:BarSeries>
		</Series>
	</PlotArea>
</telerik:RadHtmlChart>
Completed
Last Updated: 09 Nov 2015 12:43 by ADMIN
Series tooltips are not visible in a Stock chart when the same series is added programmatically in the plotarea and the navigator simultaneously.

The workaround is to:
1) Create different series for the plot area and the navigator.
2) Explicitly set the tooltips' visibility with JS like this:
        <script type="text/javascript">
            function pageLoad() {
                var chart = $find("Chart");
                var series = chart._chartObject.options.series[0];
                series.tooltip.visible = true;
                //repaint the chart to apply the changes
                chart.repaint();
            }
        </script>

Completed
Last Updated: 27 Jul 2016 11:51 by ADMIN
The CSS styles of the selection hint of the navigator in HtmlChart are not applied correctly in a data navigation scenario.

The workaround is to override the styles that you need like this:
        .k-navigator-hint .k-tooltip {
            border: 2px solid red !important;
            color: #000 !important;
        }
Declined
Last Updated: 09 Jun 2016 06:43 by ADMIN
Won't Fix
Last Updated: 19 Jan 2016 16:48 by ADMIN
Currently labels of SeriesItems with values greater or equal  to the YAxis MaxValue are being cut:

    When chart title is not set.
    AND the labels position is set to Above for AreaSeries, LineSeries, ScatterSeries and ScatterLineSeries.
    OR the labels position is set to outsideEnd for ColumnSeries.
    In FireFox, Opera and WebKit browsers.

For the time being the chart title can be set with space character.
Completed
Last Updated: 15 May 2013 09:31 by ADMIN
In a chart that has stacked bar series and a line series the bar series become column series when the chart is data-bound.

The solution is to declare the BarSeries above the LineSeries as follows:
            <%--BarSeries are declared above the LineSeries--%>
            <telerik:BarSeries Name="B1">
                <Items>
                    <telerik:SeriesItem YValue="10" />
                    <telerik:SeriesItem YValue="20" />
                    <telerik:SeriesItem YValue="30" />
                </Items>
            </telerik:BarSeries>
            <%--LineSeries are declared below the BarSeries--%>
            <telerik:LineSeries Name="L1">
                <Items>
                    <telerik:SeriesItem YValue="15" />
                    <telerik:SeriesItem YValue="10" />
                    <telerik:SeriesItem YValue="20" />
                </Items>
            </telerik:LineSeries>
Completed
Last Updated: 09 Nov 2015 12:52 by Capital
When Series are created programmatically, Axes settings are not preserved after postback. The workaround is to create an empty series in the markup. For example:

        <telerik:RadHtmlChart ID="RadHtmlChart1" runat="server">
...
            <PlotArea>
                <YAxis>...</YAxis>
                <XAxis>...</XAxis>
                <Series>
                    <telerik:ScatterLineSeries Name=" ">
                        <Appearance FillStyle-BackgroundColor="Transparent"></Appearance>
                    </telerik:ScatterLineSeries>
                </Series>
            </PlotArea>
        </telerik:RadHtmlChart>
Declined
Last Updated: 01 Nov 2013 13:06 by Gregory
Created by: Gregory
Comments: 0
Category: HtmlChart
Type: Bug Report
0
Does not visualize data for some of the cases. I attached a project related to this bug. In the code there is an option with data which RadHtmlChart do visualize and there is option for data which RadHtmlChard don't visualize.

All the code is located in Default.aspx

PS: With tooltip commented data do visualized in both cases.

Gregory.
Unplanned
Last Updated: 09 Nov 2015 14:05 by ADMIN
Completed
Last Updated: 20 Jul 2016 12:58 by ADMIN
Created by: Imported User
Comments: 1
Category: HtmlChart
Type: Bug Report
0
Hover over first legend item highlights all chart sections for donut chat type.
Hover over the rest of the legend items doesn't highlight the corresponding section of the donut chart.
Completed
Last Updated: 21 Jun 2017 10:30 by ADMIN
ADMIN
Created by: Stamo Gochev
Comments: 1
Category: HtmlChart
Type: Bug Report
0
The workaround is to set <MarkersAppearance Visible="false"  />.
Completed
Last Updated: 05 Jun 2015 08:32 by ADMIN
ADMIN
Created by: Marin Bratanov
Comments: 3
Category: HtmlChart
Type: Bug Report
0

			
Completed
Last Updated: 27 Jan 2016 09:52 by ADMIN
Currently when RadHtmlChart is placed inside  RadSplitter with RadSlidingZone a JavaScript error is thrown when the following conditions are met:

1.RadHtmlChart doesn't have its width property set

2.The position of the RadHtmlChart's legend is changed in the codebehind

The workaround is to set the width property of the chart.