Completed
Last Updated: 06 Jun 2016 15:29 by Andrey
Created by: akom
Comments: 1
Category: Editor
Type: Bug Report
3
Instructions:
In IE11 when we select an image and change from Design to HTML mode or try to apply any paragraph style to it, the browser gets unresponsive. 

To get a better understanding, please refer to the following videos:
http://screencast.com/t/xufHlK0bew
http://screencast.com/t/YcVcqygVY7GE

Demo page: http://demos.telerik.com/aspnet-ajax/editor/examples/overview/defaultcs.aspx?skin=Default
Completed
Last Updated: 16 Jul 2015 05:02 by siddhi
Trying to operate with images in RadEditor under IE11 leads to unresponsiveness. For example, using the paragraph style, selecting an image and switching to HTML and Design mode, etc.

You can workaround that by forcing the compatibility mode of the IE to IE8:

<meta http-equiv="X-UA-Compatible" content="IE=8" />
Completed
Last Updated: 27 Aug 2015 06:49 by Khushboo
ADMIN
Created by: Vessy
Comments: 1
Category: Editor
Type: Bug Report
3
When link is given to any image or text, Unlink command should get enabled. But it gets enabled for text only while remains disabled for images.
http://screencast.com/t/xHgru58pzKL

The issue has been reproducible since 2015 Q1 release
Unplanned
Last Updated: 27 Jan 2016 09:26 by ADMIN
ADMIN
Created by: Vessy
Comments: 3
Category: Editor
Type: Bug Report
3
ImageManager loses the selection after an image has been edited into the ImageEditor and saved with new file name.

video: http://screencast.com/t/rZIp4iioehE
Completed
Last Updated: 05 Nov 2018 14:44 by ADMIN
ADMIN
Created by: Rumen
Comments: 0
Category: Editor
Type: Bug Report
3
Steps to reproduce:
1. Go to the Editor demo page in Chrome
2. CTRL+A on the editor and hit delete
3. Hit Delete or Backspace again
Result: Uncaught TypeError Appears in the console
Completed
Last Updated: 28 Dec 2018 10:31 by ADMIN
When EnableComments is set to true, the content from the clipboard is pasted twice in an empty editor.

RadEditor Configuration:

<telerik:RadEditor runat="server"
    EnableComments="true">
    <Tools>
        <telerik:EditorToolGroup>
            <telerik:EditorTool Name="Bold" />
            <telerik:EditorTool Name="Italic" />
            <telerik:EditorTool Name="Underline" />
            <telerik:EditorSeparator />
            <telerik:EditorTool Name="Undo" />
            <telerik:EditorTool Name="Redo" />
            <telerik:EditorTool Name="Cut" />
            <telerik:EditorTool Name="Copy" />
            <telerik:EditorTool Name="Paste" />
            <telerik:EditorTool Name="PastePlainText" Text="Paste Plain Text" />
            <telerik:EditorTool Name="FindAndReplace" Text="Find and Replace" />
            <telerik:EditorSeparator />
            <telerik:EditorTool Name="Indent" />
            <telerik:EditorTool Name="Outdent" />
            <telerik:EditorTool Name="InsertOrderedList" Text="Numbered List" />
            <telerik:EditorTool Name="InsertUnorderedList" Text="Bulleted List" />
            <telerik:EditorTool Name="LinkManager" />
            <telerik:EditorTool Name="Unlink" />
            <telerik:EditorSeparator />
            <telerik:EditorTool Name="AjaxSpellCheck" Text="Spell Check" />
            <telerik:EditorTool Name="InsertSymbol" Text="Insert Symbol" />
        </telerik:EditorToolGroup>
        <telerik:EditorToolGroup>
            <telerik:EditorTool Name="AcceptTrackChange" Text="Accept Change" />
            <telerik:EditorTool Name="RejectTrackChange" Text="Reject Change" />
            <telerik:EditorTool Name="AcceptAllTrackChanges" Text="Accept All Changes" />
            <telerik:EditorTool Name="RejectAllTrackChanges" Text="Reject All Changes" />
            <telerik:EditorTool Name="EnableTrackChangesOverride" Text="Track Changes" />
            <telerik:EditorTool Name="AddComment" Text="Add Comment" />
            <telerik:EditorTool Name="RemoveComment" Text="Remove Comment" />
            <telerik:EditorTool Name="RemoveAllComments" Text="Remove All Comments" />
            <telerik:EditorTool Name="ImageManager" Text="Insert Image" />
        </telerik:EditorToolGroup>
    </Tools>
</telerik:RadEditor>
Potential workaround:
<script type="text/javascript">
    function OnClientPasteHtml(sender, args) {
        var commandName = args.get_commandName();
        var value = args.get_value();
 
        if (commandName == "Paste" && Telerik.Web.Browser.ie) {
            args.set_value(value);
            args.set_cancel(true);
        }
    }
</script>
<telerik:RadEditor runat="server" Height="300px" StripFormattingOptions="Span,Font,Css" EnableTrackChanges="true" OnClientPasteHtml="OnClientPasteHtml"
    ContentFilters="FixEnclosingP,RemoveScripts,FixUlBoldItalic,IECleanAnchors,MozEmStrong,ConvertFontToSpan,ConvertToXhtml,IndentHTMLContent,EncodeScripts,OptimizeSpans,ConvertTags,StripCssExpressions,RemoveExtraBreaks"
    EnableComments="true" NewLineMode="P" EditModes="Design,Html">
</telerik:RadEditor>
Unplanned
Last Updated: 27 Mar 2018 12:54 by Imported User
RadEditor does not offer resx localization for the following Track Changes strings "Inserted by ", "Formatted by ", "Deleted by " as well as for the strings in the Comments dialog: Title, Save, Cancel and Edit.
Unplanned
Last Updated: 22 May 2018 06:24 by ADMIN
ADMIN
Created by: Marin Bratanov
Comments: 0
Category: Editor
Type: Bug Report
2
When there is a hidden <tfoot> element in the table, the Delete Row command in the editor context menu cannot delete the last row in IE. Works with other rows and other browsers.

WORKAROUND: use visibility: collapse for the footer rows instead of dispay:none for the footer

Repro steps:
- Use the markup attached below
- right click the last row in any table
- choose Row > Delete Row 

Expected: row is always deleted

Actual: in IE you cannot delete the last row of the second table
Completed
Last Updated: 20 Sep 2016 14:44 by conall
ADMIN
Created by: Marin Bratanov
Comments: 2
Category: Editor
Type: Bug Report
2
			<telerik:RadEditor ID="RadEditor1" runat="server">
				<Content>
				select and delete some of the "th" content, the entire cell element will be deleted instead of its content
					<table>

						<thead>
							<tr>
								<th>th1</th>
								<th>th2</th>
								<th>th3</th>
							</tr>
						</thead>

						<tr>
							<td>1</td>
							<td>2</td>
							<td>3</td>
						</tr>

					</table>
				</Content>
			</telerik:RadEditor>
			<script>
				//workaraound

				Telerik.Web.UI.Editor.DeleteSelectionCommand.prototype.deleteNodeContent = function (node) {
					var utils = Telerik.Web.UI.Editor.Utils;
					if (utils.isTag(node, "td") || utils.isTag(node, "th")) {
						utils.removeChildren(node);
						node.innerHTML = NBSP;
					} else {
						remove(node);
					}
				}
				
				function remove(node) {
					node.parentNode.removeChild(node);
				}
			</script>
Completed
Last Updated: 27 Mar 2019 18:10 by ADMIN
You can press Delete or Backspace again to delete the remaining content
Declined
Last Updated: 27 Mar 2019 17:41 by ADMIN
Created by: John
Comments: 1
Category: Editor
Type: Bug Report
2
When part of a table from MS Excel is copied and pasted into RadEditor under Edge, the RadEditor inserts an image instead of the html for the table. It inserts <img alt="" src="data:image/png;base64, ... " /> instead of the html. IE 11, Chrome and Firefox all paste the html in the RadEditor but MS Edge pastes as an image. Is there a way for the radeditor to override this so the html is pasted instead of an image?
Completed
Last Updated: 06 Apr 2015 14:43 by ADMIN
Linking an image inserted through the ImageManager via the LinkManager does not place the creating link on the right place - the <a> tag is inserted eithr inside the <img> one or beside it. The issue could be reproduced in IE11.

You can see the issue reproduced in the attached video.

Steps to reproduce:
1. Open http://demos.telerik.com/aspnet-ajax/editor/examples/overview/defaultcs.aspx in IE11
2. Type some text in the Editor
3. Open the IamgeManager and insert an image
4. Select the inserted image and open the Link Manager

Expected result: the image tag is wrapped inside an <a> tag
Actual result: The <a> tag is inserted inside the <img> one
Completed
Last Updated: 10 Dec 2014 08:26 by ADMIN
When RadEditor is set with width of 100% switching to Full Screen mode and going back from Full Screen to the initial mode, the content area becomes only few lines high.

The following temporary solution should resolve the layout issue for common scenarios:

<telerik:RadEditor ID="txtComments" runat="server" Width="100%" 
	OnClientCommandExecuted="OnClientCommandExecuted">
</telerik:RadEditor>

<script type="text/javascript">
	function OnClientCommandExecuted(sender, args) {
		if (args.get_commandName() === "ToggleScreenMode") {
			sender.repaint();
		}
	}
</script>
Completed
Last Updated: 18 Sep 2014 12:43 by ADMIN
Created by: Steve Williams
Comments: 4
Category: Editor
Type: Bug Report
2
A page which exhibits the error is included below.  I have a ticket open with Chromium as well: https://code.google.com/p/chromium/issues/detail?id=412772&thanks=412772&ts=1410359622

Problematic page: http://imodblue.imodules.com/s/1197/social.aspx?sid=1197&gid=1&pgid=2219&content_id=1815   (click the Registration button)

Only crashes when the RadEditor is referenced on the page, even if it remains hidden.  I'm working on trying to strip it down to a simpler example, but maybe the full page is enough for you guys to help me diagnose it.

We are on an older version in production, 2012.3.1023.35.  The crash was reproducible with version 2014.2.724.45, but there's no public site with that version that I can use as an example.
Completed
Last Updated: 26 Aug 2015 14:02 by Siddhi
If the user creates a link with the first word in the editor and then decides to insert a new paragraph, even though the link is moved to the 2nd paragraph the same link is also created in the first paragraph.
Completed
Last Updated: 24 Nov 2015 11:06 by ADMIN
For the time being you can disable the StripCssExpressions  filter:
    protected void Page_Load(object sender, EventArgs e)
    {
		RadEditor1.DisableFilter(Telerik.Web.UI.EditorFilters.StripCssExpressions);
    }

Alternative approach to fix the issue is removing the StripCssExpressions filter from the client-side filters collection, so that the server-side functionality could still sanitize the HTML content:

<telerik:RadEditor runat="server" ID="RadEditor1" OnClientInit="OnClientInit">
	
</telerik:RadEditor>

<script type="text/javascript">
	function OnClientInit(sender, args) {
		sender.set_contentFilters(sender.get_contentFilters() - Telerik.Web.UI.EditorFilters.StripCssExpressions);
	}
</script>
Completed
Last Updated: 07 Jun 2016 07:38 by ADMIN
Created by: Khushboo
Comments: 1
Category: Editor
Type: Bug Report
2
When link is given to image or text, Unlink command should get enabled. But it gets enabled for text only while remains disabled for images. 

To get a better understanding, please refer to the following video:
http://screencast.com/t/xHgru58pzKL
Completed
Last Updated: 27 Feb 2014 09:54 by ADMIN
 If there are textarea tags or style tags in the HTML content of RadEditor, after completing the spell check  the content is repeated several times. 
Completed
Last Updated: 04 Sep 2019 14:24 by ADMIN
Release Q1 2014
The error is Sys.InvalidOperationException: Sys.InvalidOperationException: Component 'RadEditor1_dialogOpener' was not found.

When not enabled RadEditor should merely show its content, when Enabled is toggled to true it should render toolbars and add its functionality.

A possible workaround is using the Visible property instead and a div with runat=server as a placeholder for the editor while it is not rendered (its Content property will still return the HTML in it). Thus, the innerHTML server property of the div can be used to set the HTML from RadEditor in it.
Completed
Last Updated: 03 May 2016 13:40 by Doug Maxwell
When HTML content is set to the editor and has stylization with the inline style attribute the 'ConvertInlineStylesToAttributes' filter converts some of them to attributes, but after a post back they disappear.