Won't Fix
Last Updated: 01 Oct 2015 14:56 by ADMIN
Workaround:
Set DisablePlugins="true" or
set RenderMode="Lightweight"
Won't Fix
Last Updated: 21 Jan 2016 17:02 by ADMIN
ADMIN
Created by: Hristo Valyavicharski
Comments: 2
Category: AutoCompleteBox
Type: Bug Report
1

					
			
Won't Fix
Last Updated: 25 Sep 2015 11:44 by ADMIN
Won't Fix
Last Updated: 20 Sep 2018 07:55 by ADMIN
Color items should persist the Title property/attribute so that when hovered, the text to be shown in the tool.
Won't Fix
Last Updated: 22 Jan 2020 13:40 by Peter
An error is thrown when RadButton NavigateUrl is defined in content page with tilde and the master page is up one level.

Workaround: Remove the tilde from the navigate url.
Won't Fix
Last Updated: 17 Oct 2016 15:55 by ADMIN
The issue is not reproducible for RadDropDownList with RenderMode="Lightweight" .
Won't Fix
Last Updated: 21 Sep 2016 13:04 by ADMIN
The scripts of the controls are not combined in a single request, when the web.config key Telerik.ScriptManager.TelerikCdn.CombinedResource has value Enabled:

Steps to reproduce
1. Ad the following configuration in the web config and open a page containing RadControl.

<appSettings>
    <add key="Telerik.ScriptManager.TelerikCdn" value="Enabled"/>
    <add key="Telerik.ScriptManager.TelerikCdn.CombinedResource" value="Enabled" />
  </appSettings>

Result: The scripts are not combined.


Workaround:

Enable the script combining in the ScriptManager declaration:

    <telerik:RadStyleSheetManager runat="server">
        <CdnSettings CombinedResource="Enabled" TelerikCdn="Enabled" />
    </telerik:RadStyleSheetManager>
Won't Fix
Last Updated: 25 Apr 2017 13:28 by ADMIN
ADMIN
Created by: Anton
Comments: 1
Category: UI for ASP.NET AJAX
Type: Bug Report
1
The issue can be workarounded by calling preventDefault of the mousedown event when ComboBox item is clicked:
<telerik:RadScriptManager runat="server" />
<script>
	var onDocumentClick = Telerik.Web.UI.RadComboBox.prototype._onDocumentClick;
	Telerik.Web.UI.RadComboBox.prototype._onDocumentClick = function (e) {
		if (!e) e = event;

		var target = e.target || e.srcElement;

		while (target.nodeType !== 9) {
			if (!target.parentNode || target == this.get_element() || target == this.get_dropDownElement()) {
				e.preventDefault();
				return;
			}

			target = target.parentNode;
		}
		onDocumentClick.call(this, e);
	};
</script>

<telerik:RadComboBox ID="RadComboBox1" runat="server" RenderMode="Lightweight" OnClientBlur="OnClientBlur"
	CheckBoxes="true">
	<Items>
		<telerik:RadComboBoxItem Text="Item1" Value="1" />
		<telerik:RadComboBoxItem Text="Item2" Value="2" />
		<telerik:RadComboBoxItem Text="Item3" Value="3" />
		<telerik:RadComboBoxItem Text="Item4" Value="4" />
	</Items>
</telerik:RadComboBox>

<script>
	function OnClientBlur(sender, args) {
		console.log("Blur event");
	}
</script>
Won't Fix
Last Updated: 27 Mar 2017 11:01 by ADMIN
This is a duplicate of http://feedback.telerik.com/Project/108/Feedback/Details/210060, see there for a workaround and for status updates.


You can change the DPI settings in Windows from the Display Settings. Setting a size of 125% and clicking on a button will throw a server exception:


-------

Input string was not in a correct format.

Description: An unhandled exception occurred during the execution of the current web request. Please review the stack trace for more information about the error and where it originated in the code. 

Exception Details: System.FormatException: Input string was not in a correct format.

Source Error: 
An unhandled exception was generated during the execution of the current web request. Information regarding the origin and location of the exception can be identified using the exception stack trace below.

Stack Trace: 
[FormatException: Input string was not in a correct format.]
   System.Number.StringToNumber(String str, NumberStyles options, NumberBuffer& number, NumberFormatInfo info, Boolean parseDecimal) +12526913
   System.Number.ParseInt32(String s, NumberStyles style, NumberFormatInfo info) +120
   Telerik.Web.UI.RadImageButton.LoadPostData(String postDataKey, NameValueCollection postCollection) +256
   Telerik.Web.UI.RadWebControl.System.Web.UI.IPostBackDataHandler.LoadPostData(String postDataKey, NameValueCollection postCollection) +16
   System.Web.UI.Page.ProcessPostData(NameValueCollection postData, Boolean fBeforeLoad) +457
   System.Web.UI.Page.ProcessRequestMain(Boolean includeStagesBeforeAsyncPoint, Boolean includeStagesAfterAsyncPoint) +1833
Won't Fix
Last Updated: 12 Apr 2019 16:40 by ADMIN
ADMIN
Created by: Ianko
Comments: 1
Category: FormDecorator
Type: Bug Report
1
The tooltip is not showing when RadFormDecorator decorate asp:CheckBox and asp:RadioButton. For example:

<telerik:RadFormDecorator ID="RadFormDecorator1" runat="server" DecoratedControls="All" />
  
<asp:CheckBox runat="server" Text="Update" ToolTip="Update Last Name" />
<asp:RadioButton runat="server" Text="Update" ToolTip="Update Last Name" />

------------------------------------------------------------------------------------------------------------------------------------------------------------------------

Removing the title attribute from the label element fixes the issue: 

<telerik:RadScriptManager runat="server" ID="RadScriptManager1">
    <Scripts>
        <asp:ScriptReference Assembly="Telerik.Web.UI" Name="Telerik.Web.UI.Common.Core.js" />
        <asp:ScriptReference Assembly="Telerik.Web.UI" Name="Telerik.Web.UI.Common.jQuery.js" />
    </Scripts>
</telerik:RadScriptManager>
 
<telerik:RadFormDecorator ID="RadFormDecorator1" runat="server" DecoratedControls="All" />
 
<script type="text/javascript">
    function pageLoad() {
        $telerik.$("label[class*='rfdRadio'],label[class*='rfdCheckbox']").removeAttr("title");
    }
</script>
 
<asp:CheckBox runat="server" Text="Update" ToolTip="Update Last Name" />
<asp:RadioButton runat="server" Text="Update" ToolTip="Update Last Name" />
Won't Fix
Last Updated: 13 Sep 2017 06:45 by ADMIN
Won't Fix
Last Updated: 19 Mar 2019 14:26 by ADMIN
Load in IE this demo: http://demos.telerik.com/aspnet-ajax/editor/examples/overview/defaultcs.aspx

Enter in HTML mode - <p><a href="stm:b4f0c9ac-9a08-4c9f-8caf-39ccd4a83fc9" class="stm" contenteditable="false">Statement 111</a></p>

Switch to Design mode

Search for Statement with the Find and Replace dialog

The dialog won't be able to locate and highlight the link
Won't Fix
Last Updated: 17 Nov 2017 11:24 by ADMIN
If the selection mode of the Grid is different than row selection, no cell of the detailed grid gets selected. The bug is introduced with version 2016 R3 SP1

Steps to reproduce:
1. Run the following demo locally  http://demos.telerik.com/aspnet-ajax/grid/examples/hierarchy/declarative-relations/defaultcs.aspx

2. and add this configuration:
       <telerik:RadGrid ...>
            <ClientSettings>
                <Selecting CellSelectionMode="SingleCell" />
            </ClientSettings>
Won't Fix
Last Updated: 28 Sep 2017 14:06 by ADMIN
Won't Fix
Last Updated: 14 Jun 2018 09:38 by ADMIN
RadRotator stops working after Ctrl+F5 refresh if the ItemWidth is not set in Firefox. After the refresh RadRotator looses its item width calculation and show only the first item, the others and rendered on the next row.

Video: https://www.screencast.com/t/hqYDQrPsemK

1. Run the code below in Firefox
2. Press Ctrl + F5

Result: The rotator does not rotate the items anymore

                    <telerik:RadRotator ID="RadRotatorLogosTelerik" RotatorType="AutomaticAdvance" Skin="Metro" RenderMode="Lightweight" Visible="true" runat="server" EnableRandomOrder="false"
                        Height="180px" Width="980px"
                        ItemHeight="80px">
                        <Items>
                            <telerik:RadRotatorItem>
                                <ItemTemplate>
                                    <div id="imgitemTemplate">
                                        <asp:Image ID="Image1" runat="server" AlternateText="becken" ImageUrl="https://placeimg.com/980/80/tech" />
                                    </div>
                                </ItemTemplate>
                            </telerik:RadRotatorItem>
                            <telerik:RadRotatorItem>
                                <ItemTemplate>
                                    <div id="imgitemTemplate">
                                        <asp:Image ID="Image2" runat="server" AlternateText="goodis" ImageUrl="https://placeimg.com/980/80/animals" />
                                    </div>
                                </ItemTemplate>
                            </telerik:RadRotatorItem>
                            <telerik:RadRotatorItem>
                                <ItemTemplate>
                                    <div id="imgitemTemplate">
                                        <asp:Image ID="Image3" runat="server" AlternateText="kubo" ImageUrl="https://placeimg.com/980/80/arch" />
                                    </div>
                                </ItemTemplate>
                            </telerik:RadRotatorItem>
                        </Items>
                    </telerik:RadRotator>
Won't Fix
Last Updated: 08 Jun 2016 14:59 by ADMIN
The problem could be described with the following behavior:
·         Cannot insert a link with the Link Manager;
·         If switched to HTML mode cannot return to Design mode, switching to Preview – allows Design mode.
·         A JavaScript error is thrown on focusing and on editing the content area. 

Possible fixes are: 
o   Removing the Modernizr JavaScript file;
o   Setting the RadEditor with ContentAreaMode="Iframe" property;
Won't Fix
Last Updated: 28 Jun 2016 16:24 by ADMIN
When a Hyperlink element is set with an onclick handler, after passing through the Preview mode it is being stripped under IE7. Also related problem is that the link in the Preview mode are clickable and the URL set to the href attribute is opened in new tab/window.

Possible solution for both bugs is to override the function responsible for the conversion of such attributes in the Preview mode with this JavaScript code:

Telerik.Web.UI.Editor.Utils.setTargetsForPreview = function (editor) {
	var contentArea = editor.get_contentArea();
	var links = contentArea.getElementsByTagName("A");
	for (var i = 0, l = links.length; i < l; i++) {
		var link = links[i];
		//handle targets
		var target = link.getAttribute("target");
		if (target != null) {
			link.setAttribute("re_target", target);
		}
		if (target != "_blank")
			link.setAttribute("target", "blank");
		//handle ckick event
		var oldOnClick = (link.getAttributeNode('onclick')
			&& link.getAttributeNode('onclick').value)
			|| link.getAttribute("onclick");

		if (oldOnClick != null) {
			link.setAttribute('re_onclick', oldOnClick);
		}

		link.setAttribute('onclick', 'return false;');

		if (typeof link.onclick === "string") {
			link.onclick = function () {
				return false;
			};
		}
	}
};

Telerik.Web.UI.Editor.Utils.restoreTargetsAfterPreview = function (editor) {
	var contentArea = editor.get_contentArea();
	var links = contentArea.getElementsByTagName("A");
	for (var i = 0, l = links.length; i < l; i++) {
		var link = links[i];
		//handle targets
		var oldValue = link.getAttribute("re_target");
		if (oldValue != null && oldValue != "null") {
			link.setAttribute("target", oldValue);
		}
		else {
			link.removeAttribute("target");
		}
		//handle anchors urls
		var oldOnClick = link.getAttribute("re_onclick");
		link.onclick = null;
		if (oldOnClick != null && oldOnClick != "null") {
			link.setAttribute('onclick', oldOnClick);
		}
		else {
			link.removeAttribute("onclick");
		}
		link.removeAttribute("re_onclick");
		link.removeAttribute("re_target");
	}
};


Note that this script must be placed in a script tag right after the RadEditor control.
Won't Fix
Last Updated: 16 Apr 2015 09:47 by Elena
In SharePoint 2010 if a site is created with UI version 3 (The MOSS interface) and RadEditor is set as a feature for rich text fields from the site settings. When a page is edited and an additional Content Editor Webpart is added, after editing its content, the RadEditor's content is lost.
Won't Fix
Last Updated: 06 Jul 2016 15:17 by ADMIN
Created by: Mark Stiles
Comments: 1
Category: UI for ASP.NET AJAX
Type: Feature Request
1
An ArgumentOutOfRange exception is thrown when using a horizontal barchart with AutoLayout = true.

[ArgumentOutOfRangeException: Length cannot be less than zero.
Parameter name: length]
   System.String.InternalSubStringWithChecks(Int32 startIndex, Int32 length, Boolean fAlwaysCopy) +10695301
   System.String.Substring(Int32 startIndex, Int32 length) +10
   Telerik.Charting.TextBlock.get_VisibleText() +194