Declined
Last Updated: 07 Jun 2017 14:35 by ADMIN
Implementing a fix for the Lightweight RenderMode is likely to cause regressions:
- https://feedback.telerik.com/Project/108/Feedback/Details/166590-fix-the-compatibility-of-radbutton-in-lightweight-with-image-in-cookieless-sessio
- https://feedback.telerik.com/Project/108/Feedback/Details/66505-fix-the-compatibility-of-radbutton-with-custom-image-that-contains-special-symbol

Thus, there are several workarounds:
- use the Classic RenderMode, if possible
- use the script below
- use CSS to set the icon instead of a property (example further down)

JS workaround:
			<telerik:RadButton runat="server" ID="rb1" RenderMode="Lightweight">
				<Icon PrimaryIconUrl="~/Circle_Green_20.png" />
			</telerik:RadButton>
			<telerik:RadPushButton runat="server" ID="rpb1" text="sample text">
				<Icon Url="Circle_Green_20.png" />
			</telerik:RadPushButton>
			<script>
				function repaintButtons() {
					$telerik.$(".RadButton.rbIconButton, .RadButton.rbIconOnly").each(function (index, elem) {
						if (elem && elem.control && elem.control.repaint) {
							elem.control.repaint();
						}
					});
					//uncomment this if you want the method to fire after each partial postback as well
					//Sys.Application.remove_load(repaintButtons);
				}
				Sys.Application.add_load(repaintButtons);
			</script>


CSS workaround:

			<telerik:RadButton runat="server" ID="rb1" RenderMode="Lightweight" CssClass="myCustomIcon" Text="some text">
				<Icon PrimaryIconUrl="Circle_Green_20.png" />
			</telerik:RadButton>
			<style>
				.myCustomIcon .rbPrimaryIcon
				{
					background-image: url(Circle_Green_20.png);
				}
			</style>
Declined
Last Updated: 27 Jan 2014 10:30 by ADMIN
Declined with the following description:
Telerik controls can be found on the client-side through the findControl() method exposed by the Telerik client static library (http://www.telerik.com/help/aspnet-ajax/telerik-static-client-library.html). For example:
JavaScript:
	<telerik:RadCodeBlock ID="RadCodeBlock1" runat="server">
		<script>
			function pageLoad() {
				var btn1 = $get("<%=RadButton1.ClientID %>");
				var btn2 = $telerik.findControl(btn1, "RadButton2");
				btn2.set_text("New text");
			}
		</script>
	</telerik:RadCodeBlock>
ASPX:
		<telerik:RadButton runat="server" ID="RadButton1" Width="190"
			Height="190">
			<ContentTemplate>
				<span>RadButton Content</span>
				<telerik:RadButton ID="RadButton2" runat="server" Text="OldText" />
			</ContentTemplate>
		</telerik:RadButton>
Declined
Last Updated: 17 Jun 2014 08:32 by ADMIN
ADMIN
Created by: Danail Vasilev
Comments: 0
Category: Button
Type: Bug Report
0
Declined with the reason:

Item is a duplicate of http://feedback.telerik.com/Project/108/Feedback/Details/127356
Declined
Last Updated: 16 Mar 2015 16:17 by Sylvain
Created by: Sylvain
Comments: 0
Category: Button
Type: Bug Report
0

			
Declined
Last Updated: 25 Aug 2014 14:21 by ADMIN
Declined
Last Updated: 02 Jun 2017 10:23 by ADMIN
Checkbox buttons are missing when ToggleType='CustomToggle' in Lightweight rendering. The issue is introduced in 2017 R1 release.

Code to reproduce:
        <telerik:RadButton runat="server" ID="btnEnableTrace" RenderMode="Lightweight"
            ButtonType="ToggleButton" ToggleType="CustomToggle">
            <ToggleStates>
                <telerik:RadButtonToggleState PrimaryIconCssClass="rbToggleCheckbox"></telerik:RadButtonToggleState>
                <telerik:RadButtonToggleState PrimaryIconCssClass="rbToggleCheckboxChecked"></telerik:RadButtonToggleState>
            </ToggleStates>
        </telerik:RadButton>