Completed
Last Updated: 02 Jun 2017 14:50 by ADMIN
With the latest version R1 2017 SP1 the image icon of RadButton is not aligned inside a content template of RadPanelbar. See the attached screenshot for more information and test the code:

<%@ Page Language="C#" AutoEventWireup="true" %>

<!DOCTYPE html>

<html xmlns="http://www.w3.org/1999/xhtml">
<head runat="server">
    <title></title>

</head>
<body>
    <form id="form1" runat="server">
        <telerik:RadScriptManager runat="server" ID="sm"></telerik:RadScriptManager>

        <style>
            body {
                font: 12px "segoe ui",arial,sans-serif;
            }
        </style>
        <telerik:RadPanelBar runat="server" ID="RadPanelBar1" Width="100%">
            <Items>
                <telerik:RadPanelItem Text="Filtering and configuration" Expanded="True">
                    <ContentTemplate>

                        <telerik:RadButton RenderMode="Lightweight" ID="RadButton_HierarchyLoadMode" Width="300px" runat="server" ButtonType="ToggleButton" Checked="true" ToggleType="CheckBox">
                            <ToggleStates>
                                <telerik:RadButtonToggleState Text="Yes - Each comment will load  only when clicked" PrimaryIconCssClass="p-i-checkbox rbToggleCheckbox" />
                                <telerik:RadButtonToggleState Text="No - All comments will be loaded when the report starts or the datasource is changed." PrimaryIconCssClass="p-i-checkbox-checked rbToggleCheckboxChecked" />
                            </ToggleStates>
                        </telerik:RadButton>
                        <telerik:RadButton RenderMode="Lightweight" ID="RadButton_SaveGridSettings" runat="server" Text="Save Grid Settings" Width="140px">
                            <Icon PrimaryIconCssClass="rbSave"></Icon>
                        </telerik:RadButton>

                    </ContentTemplate>
                </telerik:RadPanelItem>
            </Items>
            <ExpandAnimation Type="None" />
            <CollapseAnimation Type="None" />
        </telerik:RadPanelBar>
    </form>
</body>
</html>


The problem is not reproducible with the R3 2016 build.
Completed
Last Updated: 15 Oct 2015 08:38 by ADMIN
Completed
Last Updated: 10 Oct 2016 11:23 by ADMIN
Completed
Last Updated: 09 Jul 2015 13:13 by ADMIN
Completed
Last Updated: 23 Feb 2015 12:47 by ADMIN
Completed
Last Updated: 10 Dec 2014 14:40 by ADMIN
Completed
Last Updated: 20 Sep 2016 12:48 by ADMIN
ADMIN
Created by: Ivan Danchev
Comments: 0
Category: PanelBar
Type: Bug Report
0

			
Completed
Last Updated: 02 Sep 2016 14:49 by ADMIN
ADMIN
Created by: Nencho
Comments: 0
Category: PanelBar
Type: Feature Request
0

			
Completed
Last Updated: 19 Jul 2016 15:30 by ADMIN