Unplanned
Last Updated: 11 Sep 2013 15:04 by ADMIN
ADMIN
Created by: Vessy
Comments: 0
Category: Splitter
Type: Bug Report
0
When a Sliding pane have to be resized over a RadPane, containing a heavy weight object (Silverlight, PDF, Flash, etc.) its size is not calculated properly.
Unplanned
Last Updated: 02 Dec 2013 16:44 by ADMIN
ADMIN
Created by: Vessy
Comments: 0
Category: Splitter
Type: Bug Report
0
The border of the splitbar disappears on hover. The issue is reproducible in IE - http://screencast.com/t/QfaZIZirSZfB
Unplanned
Last Updated: 06 Jan 2015 15:40 by ADMIN
The tabs get hidden when a top oriented SlidingPane is docked inside a horizontal SlidingZone. The issue is reproducible when the resize mode of the parent Splitter is != AdjacentPane.

Steps to reproduce:
1. Run the following code:

        <div style="padding: 200px">
            <telerik:RadSplitter runat="server" ID="RadSplitter2" Orientation="Horizontal" ResizeMode="Proportional">
                <telerik:RadPane runat="Server" ID="radpane11" Height="20px" MaxWidth="980" Scrolling="None" BackColor="Green">
                    <telerik:RadSlidingZone ID="ListMetricsSlidingZone" runat="server" Height="25px" DockedPaneId="ListMetricsPane" SlideDirection="Top">
                        <telerik:RadSlidingPane ID="ListMetricsPane" Title="DEF" runat="server">
                            1111
                        </telerik:RadSlidingPane>
                        <telerik:RadSlidingPane ID="ListHistorySlidingPane1" Title="XYZ" Font-Size="X-Large" runat="server">
                            222
                        </telerik:RadSlidingPane>
                    </telerik:RadSlidingZone>
                </telerik:RadPane>
                <telerik:RadPane runat="Server" ID="radpane33" Scrolling="None">
                </telerik:RadPane>
            </telerik:RadSplitter>
        </div>

2. Undock and dock a sliding pane.

Expected: The tabs remains visible all the time (change the Splitters ResizeMode="AdjacentPane" for reference)
Unplanned
Last Updated: 17 Feb 2020 15:08 by ADMIN
Endless Loading screen is shown over RadPane when the set_showContentDuringLoad(false) method before changing the contentUrl of a RadPane (which is already showing another external page).
 

Workaround: Set the ShowContentDuringLoad="false" property of the RadPane in the markup initially

 

Code to reproduce the bug:

        <script>
            function loadNewPage() {
                var contentPane = $find("RadPane2");
                contentPane.set_showContentDuringLoad(false);
                contentPane.set_contentUrl("newContentPage.aspx");
            }
        </script>
 
        <telerik:RadSplitter ID="RadSplitter1" runat="server" Width="100%" Orientation="Horizontal" Height="800px">
            <telerik:RadPane ID="RadPanel1" runat="server" Height="30px">
                <asp:Button Font-Italic="true" runat="server" Text="Load New Page" OnClientClick="loadNewPage(); return false;" />
            </telerik:RadPane>
            <telerik:RadPane ID="RadPane2" runat="server" ContentUrl="https://www.wikipedia.com">
            </telerik:RadPane>
        </telerik:RadSplitter>