Declined
Last Updated: 08 Oct 2019 08:13 by ADMIN
Created by: Vasssek
Comments: 1
Category: Input
Type: Bug Report
0

Hi,

I have problem with typing into RadMaskedTextBox. I detected that problem is causing MaxLength property. In IE11, Chrome and Firefox, everything is working fine, but in Edge user couldn't type text into input.

<telerik:RadMaskedTextBox ID="txt_PFR1" runat="server" Width="110px" TabIndex="1" 
                                                    MaxLength="5" Mask="PFRaa">
                                                </telerik:RadMaskedTextBox>

Result text should be PFR and two characters, e.g. PFR12 or PFRaX, or... 

I suppose that this property is useless in this control instead of RadTextBox. Could you please remove it, if it doesn't have any other usage purpose ?

Regards

Vasssek

 

Declined
Last Updated: 28 Jun 2019 11:50 by ADMIN
Created by: product
Comments: 1
Category: Grid
Type: Bug Report
0
In GridTableView.cs, you provide a function
 protected virtual GridTableView CreateTableView() (Line 7828).
This function can be overloaded to return derived classes from GridTableView.

But, this is not overloadable completely. Because you create a GridTableView directly in protected void BuildDetailTablesFromDataSource() (Line 8808), too.
There you would have to call a virtual creator function, too.

This is necessary, because I have a lot of Trouble with your DataBind which I was able to fix with an overload. It is much to hard to make this bug visible for you, I really tried to do so already, but I had to fix this that way, because your GridTableView without my derivation fails in our szenario.

The call stack for that problem, I'd had to fix, is always like:
Exception of type 'System.Web.HttpUnhandledException' was thrown. ---> System.IndexOutOfRangeException: Cannot find column CheckSum.
                  at System.Data.DataTable.ParseSortString(String sortString)
                  at System.Data.DataView.set_Sort(String value)
                  at Telerik.Web.UI.GridEnumerableFromDataView.PerformTransformation()
                  at Telerik.Web.UI.GridEnumerableFromDataView.TransformEnumerable()
                  at Telerik.Web.UI.GridTableView.GetEnumerator(Boolean useDataSource, GridEnumerableBase resolvedDataSource, ArrayList dataKeysArray, Boolean shouldClearDataKeys)
                  at Telerik.Web.UI.GridTableView.CreateControlHierarchy(Boolean useDataSource)
                  at Telerik.Web.UI.GridTableView.CreateChildControls(IEnumerable dataSource, Boolean useDataSource)
                  at System.Web.UI.WebControls.CompositeDataBoundControl.PerformDataBinding(IEnumerable data)
                  at System.Web.UI.WebControls.DataBoundControl.OnDataSourceViewSelectCallback(IEnumerable data)
                  at Telerik.Web.UI.GridTableView.PerformSelect()
                  at Telerik.Web.UI.GridTableView.DataBind()
                  at Telerik.Web.UI.GridItemBuilder.BindDetailTable(GridDataItem parentItem, GridTableView cloned)
                  at Telerik.Web.UI.GridItemBuilder.BindDetailTables(GridDataItem parentItem, GridNestedViewItem detailItem)
                  at Telerik.Web.UI.GridItemBuilder.CreateItems(GridGroupingContext group)
                  at Telerik.Web.UI.GridTableView.CreateItems(IEnumerator enumerator, GridColumn[] columns, ControlCollection controls)
                  at Telerik.Web.UI.GridTableView.CreateControlHierarchy(Boolean useDataSource)
                  at Telerik.Web.UI.GridTableView.CreateChildControls(IEnumerable dataSource, Boolean useDataSource)
                  at System.Web.UI.WebControls.CompositeDataBoundControl.PerformDataBinding(IEnumerable data)
                  at System.Web.UI.WebControls.DataBoundControl.OnDataSourceViewSelectCallback(IEnumerable data)
                  at Telerik.Web.UI.GridTableView.PerformSelect()
                  at Telerik.Web.UI.GridTableView.DataBind()


In that, your DataTableView gets an invalid sort Expression string. Therefore, I overwrote DataBind.

But this is not possible in all cases, if you create GridViewTable() objects on your own.

Best regards
Declined
Last Updated: 17 Dec 2018 13:20 by ADMIN
RadGrid filter command is not triggered for strings containing "and" word.

Video: https://www.screencast.com/t/j649UvPQ3z6

Steps to reproduce:
Filter by "SUNBAY AND LEONA A" in the following demo:
https://demos.telerik.com/aspnet-ajax/grid/examples/functionality/filtering/excel-like-filtering/defaultcs.aspx
Declined
Last Updated: 22 Mar 2019 10:56 by ADMIN
The content of RadEditor does not get styled in div mode in IE11. The styling tag is added before the selected content, instead of around it (e.g. strong tag).

https://www.screencast.com/t/HoqeLyeZX

Steps to reproduce:
1. Open in IE11:  https://demos.telerik.com/aspnet-ajax/editor/examples/contentareamodediv/defaultcs.aspx
2. Clear whole content and write some new symbols
3. Try to style the new content (e.g. make it bold)
Declined
Last Updated: 27 Mar 2019 14:12 by ADMIN
ADMIN
Created by: Rumen
Comments: 1
Category: UI for ASP.NET AJAX
Type: Bug Report
1
We are current experiencing a whitescreen with Telerik UI Controls for asp.net Ajax in chrome browser when the zoom level is less than 100. We observed a white screen instead of the rendered controls within main content area of our masterpage. The masterpage has several sections, header, left, mainconten, right and footer sections all divided by RadSplitter/RadPane controls. I attached a sample solution and screenshots of the observed issue.

Step to Reproduce:

- Open solution in Visual Studio

- Run choosing Chrome Browser

- Resize browser to 90%

- Reload the page

Expected

Page is rendered

Observed

White screen in the main content area

See attached screenshots
Declined
Last Updated: 21 Mar 2019 05:51 by ADMIN
Hi,

MissingValue set to Gap or Zero doesn't work in RadHtmlChart with ScatterLineSeries.

Interpolation is done instead.

              <telerik:RadHtmlChart runat="server">
                    <PlotArea>
                        <Series>
                            <telerik:ScatterLineSeries Name="Test" DataFieldX="XValue"
                                DataFieldY="YValue" MissingValues="Gap">
                                <SeriesItems>
                                    <telerik:ScatterSeriesItem X="1" Y="8" />
                                    <telerik:ScatterSeriesItem X="2" Y="9" />
                                    <telerik:ScatterSeriesItem X="3" Y="4" />
                                    <telerik:ScatterSeriesItem X="4" Y="6" />
                                    <telerik:ScatterSeriesItem X="5" Y="7" />
                                    <telerik:ScatterSeriesItem X="8" Y="1" />
                                    <telerik:ScatterSeriesItem X="9" Y="5" />
                                    <telerik:ScatterSeriesItem X="10" Y="4" />
                                </SeriesItems>
                            </telerik:ScatterLineSeries>
                        </Series>
                    </PlotArea>
                </telerik:RadHtmlChart>


The workaround described in the following link doesn't work either :
https://feedback.telerik.com/Project/108/Feedback/Details/44399-fix-the-functionality-of-the-missingvalue-property-when-set-to-gap-in-areaserie

Can you please fix this bug ?

Thanks and regards.
Declined
Last Updated: 06 Aug 2019 09:13 by ADMIN
Created by: JF
Comments: 2
Category: Spreadsheet
Type: Bug Report
0
I have two lines that was set to a certain height,

Each time I save the sheet, those two lines expand by 8 pixels.

Does anyone are reading those bug reports?
Declined
Last Updated: 06 Apr 2018 12:55 by ADMIN
The agregate sum value shown in the bottom of the TreeList columns displays bigger sum than the actual one (it seems that the child items values are also taken into consideration).

Steps to reproduce:
1. Open http://demos.telerik.com/aspnet-ajax/treelist/examples/columns/aggregates/defaultcs.aspx?show-source=true

2. Check the sum shown in the Population column

Actual: It shows 10,702,470,081.00

Expected: It should be 6,464,732,588.00
Declined
Last Updated: 02 Jun 2017 10:23 by ADMIN
Checkbox buttons are missing when ToggleType='CustomToggle' in Lightweight rendering. The issue is introduced in 2017 R1 release.

Code to reproduce:
        <telerik:RadButton runat="server" ID="btnEnableTrace" RenderMode="Lightweight"
            ButtonType="ToggleButton" ToggleType="CustomToggle">
            <ToggleStates>
                <telerik:RadButtonToggleState PrimaryIconCssClass="rbToggleCheckbox"></telerik:RadButtonToggleState>
                <telerik:RadButtonToggleState PrimaryIconCssClass="rbToggleCheckboxChecked"></telerik:RadButtonToggleState>
            </ToggleStates>
        </telerik:RadButton>
Declined
Last Updated: 16 Apr 2019 15:51 by ADMIN
Created by: Igor
Comments: 2
Category: TagCloud
Type: Bug Report
0
When Telerik CDN is enabled, the RadTagCloud control is not able to get (error 404)
href="https://d35islomi5rx1v.cloudfront.net/ajaxz/2017.1.228/TagCloud.scss href="https://d35islomi5rx1v.cloudfront.net/ajaxz/2017.1.228/Bootstrap/TagCloud.Bootstrap.scss
Declined
Last Updated: 16 Apr 2019 15:58 by ADMIN
I skipped the 3rd quarter 2016 update (2016.3.1027) for my copy of Telerik UI for ASP.NET.AJAX, since we were in code lock down at that time. 

 Later i installed the 4th quarter version (2016.4.1021.0)

Now, I still get a notice to install the previous version  (2016.3.1027) that I skipped.

That's annoying, and probably not possible. Right?

Is there anything we can do about this situation?

Thanks in advance
Tommy Heath
theath@teamenders.com
Declined
Last Updated: 26 Apr 2019 07:59 by ADMIN
Created by: Kaarthic
Comments: 1
Category: Grid
Type: Bug Report
0
I have added Listview in Header template in Template column, its showing the data on the grid as expected. When I am exporting to Excel or PDF its not exporting the header. Header you see in headertemplate.jpg is not exporting to PDF

Thanks
Declined
Last Updated: 12 Apr 2019 16:50 by ADMIN
Created by: Wei Dong
Comments: 1
Category: Ajax
Type: Bug Report
0
Hi guy,

      I want use alert function in radajaxmanager,  After i  set  radajaxmanager.alert, if code is running it ,page will pop-up a window. but this window is not middle positon in current page.
How can i  solve this question.thanks.


David
Declined
Last Updated: 20 Sep 2016 05:32 by ADMIN
Hi,

I am getting the below issue on button click.Its working fine in all browsers ,but not in Edge.Please help.

Microsoft Edge SCRIPT65535: Argument not optional

It is saying grid is not available.
Declined
Last Updated: 27 Mar 2019 17:41 by ADMIN
Created by: John
Comments: 1
Category: Editor
Type: Bug Report
2
When part of a table from MS Excel is copied and pasted into RadEditor under Edge, the RadEditor inserts an image instead of the html for the table. It inserts <img alt="" src="data:image/png;base64, ... " /> instead of the html. IE 11, Chrome and Firefox all paste the html in the RadEditor but MS Edge pastes as an image. Is there a way for the radeditor to override this so the html is pasted instead of an image?
Declined
Last Updated: 21 Mar 2019 10:25 by ADMIN
Created by: Ravi
Comments: 1
Category: Editor
Type: Bug Report
0
Hi Telerik Team,

There is one recent problem we faced when using RadEditor. The bottom line is distorted.

We are using version telerik version ASP.NET AJAX Q2 2016.

Attached is the screenshot of html. 

Declined
Last Updated: 21 Mar 2019 11:53 by ADMIN
Created by: Ravi
Comments: 1
Category: Editor
Type: Bug Report
0
Hi Telerik Team,

There is one recent problem we faced when copy paste from word document to Rad Editor. The spacing between the paragraphs is more than what exists in the word document.

The property we are using while copy paste from document to RadEditor

    radTextEditor.StripFormattingOptions = Telerik.Web.UI.EditorStripFormattingOptions.MSWordNoMargins | Telerik.Web.UI.EditorStripFormattingOptions.ConvertWordLists;

The functionality working fine in IE 11.

We are using version telerik version ASP.NET AJAX Q2 2016.

Also there is a default font of Times New Roman in Edge browser which not in IE 11

Attached is the screenshot of html. 

Please look into this.
Declined
Last Updated: 14 Oct 2016 10:48 by ADMIN
Created by: pranav
Comments: 2
Category: Editor
Type: Bug Report
0
Hi Telerik Team,

There is one recent problem we faced when copy paste of email address doesn't get open in outlook as HREF property is not set in Edge Browser. The functionality working fine in IE 11.

We are using version telerik version ASP.NET AJAX Q2 2016.

Attached is the screenshot of html. 
Declined
Last Updated: 28 Mar 2019 16:23 by ADMIN
Created by: jose antonio
Comments: 1
Category: PivotGrid
Type: Bug Report
0
When setting datasource if the data is a dynamic type it wont render anything.

My type is IEnumerable<dynamic>

Cheers
Declined
Last Updated: 14 Jun 2016 07:46 by ADMIN
Having a font/span tag with applied inline font-size style cannot be formatted by FontSize tool.  

This is a possible workaround that removes font-size inline style when size attribute is to be added:

<telerik:RadEditor runat="server" ID="RadEditor1" OnClientCommandExecuting="OnClientCommandExecuting">
    <Tools>
        <telerik:EditorToolGroup>
            <telerik:EditorTool Name="FontSize" />
        </telerik:EditorToolGroup>
    </Tools>
    <Content>
       <p><span style="font-size:15px;">text</span></p>
    </Content>
</telerik:RadEditor>

<script>
    function OnClientCommandExecuting(editor, args) {
        var command = args.get_commandName();
        if (command === "FontSize") {
            $telerik.$(editor.getSelectedElement()).css("font-size", "");
        }
    }
</script>
1 2 3 4 5 6