Declined
Last Updated: 28 Jun 2019 11:50 by ADMIN
Created by: product
Comments: 1
Category: Grid
Type: Bug Report
0
In GridTableView.cs, you provide a function
 protected virtual GridTableView CreateTableView() (Line 7828).
This function can be overloaded to return derived classes from GridTableView.

But, this is not overloadable completely. Because you create a GridTableView directly in protected void BuildDetailTablesFromDataSource() (Line 8808), too.
There you would have to call a virtual creator function, too.

This is necessary, because I have a lot of Trouble with your DataBind which I was able to fix with an overload. It is much to hard to make this bug visible for you, I really tried to do so already, but I had to fix this that way, because your GridTableView without my derivation fails in our szenario.

The call stack for that problem, I'd had to fix, is always like:
Exception of type 'System.Web.HttpUnhandledException' was thrown. ---> System.IndexOutOfRangeException: Cannot find column CheckSum.
                  at System.Data.DataTable.ParseSortString(String sortString)
                  at System.Data.DataView.set_Sort(String value)
                  at Telerik.Web.UI.GridEnumerableFromDataView.PerformTransformation()
                  at Telerik.Web.UI.GridEnumerableFromDataView.TransformEnumerable()
                  at Telerik.Web.UI.GridTableView.GetEnumerator(Boolean useDataSource, GridEnumerableBase resolvedDataSource, ArrayList dataKeysArray, Boolean shouldClearDataKeys)
                  at Telerik.Web.UI.GridTableView.CreateControlHierarchy(Boolean useDataSource)
                  at Telerik.Web.UI.GridTableView.CreateChildControls(IEnumerable dataSource, Boolean useDataSource)
                  at System.Web.UI.WebControls.CompositeDataBoundControl.PerformDataBinding(IEnumerable data)
                  at System.Web.UI.WebControls.DataBoundControl.OnDataSourceViewSelectCallback(IEnumerable data)
                  at Telerik.Web.UI.GridTableView.PerformSelect()
                  at Telerik.Web.UI.GridTableView.DataBind()
                  at Telerik.Web.UI.GridItemBuilder.BindDetailTable(GridDataItem parentItem, GridTableView cloned)
                  at Telerik.Web.UI.GridItemBuilder.BindDetailTables(GridDataItem parentItem, GridNestedViewItem detailItem)
                  at Telerik.Web.UI.GridItemBuilder.CreateItems(GridGroupingContext group)
                  at Telerik.Web.UI.GridTableView.CreateItems(IEnumerator enumerator, GridColumn[] columns, ControlCollection controls)
                  at Telerik.Web.UI.GridTableView.CreateControlHierarchy(Boolean useDataSource)
                  at Telerik.Web.UI.GridTableView.CreateChildControls(IEnumerable dataSource, Boolean useDataSource)
                  at System.Web.UI.WebControls.CompositeDataBoundControl.PerformDataBinding(IEnumerable data)
                  at System.Web.UI.WebControls.DataBoundControl.OnDataSourceViewSelectCallback(IEnumerable data)
                  at Telerik.Web.UI.GridTableView.PerformSelect()
                  at Telerik.Web.UI.GridTableView.DataBind()


In that, your DataTableView gets an invalid sort Expression string. Therefore, I overwrote DataBind.

But this is not possible in all cases, if you create GridViewTable() objects on your own.

Best regards
Declined
Last Updated: 17 Dec 2018 13:20 by ADMIN
RadGrid filter command is not triggered for strings containing "and" word.

Video: https://www.screencast.com/t/j649UvPQ3z6

Steps to reproduce:
Filter by "SUNBAY AND LEONA A" in the following demo:
https://demos.telerik.com/aspnet-ajax/grid/examples/functionality/filtering/excel-like-filtering/defaultcs.aspx
Declined
Last Updated: 16 Apr 2019 15:58 by ADMIN
I skipped the 3rd quarter 2016 update (2016.3.1027) for my copy of Telerik UI for ASP.NET.AJAX, since we were in code lock down at that time. 

 Later i installed the 4th quarter version (2016.4.1021.0)

Now, I still get a notice to install the previous version  (2016.3.1027) that I skipped.

That's annoying, and probably not possible. Right?

Is there anything we can do about this situation?

Thanks in advance
Tommy Heath
theath@teamenders.com
Declined
Last Updated: 26 Apr 2019 07:59 by ADMIN
Created by: Kaarthic
Comments: 1
Category: Grid
Type: Bug Report
0
I have added Listview in Header template in Template column, its showing the data on the grid as expected. When I am exporting to Excel or PDF its not exporting the header. Header you see in headertemplate.jpg is not exporting to PDF

Thanks
Declined
Last Updated: 20 Sep 2016 05:32 by ADMIN
Hi,

I am getting the below issue on button click.Its working fine in all browsers ,but not in Edge.Please help.

Microsoft Edge SCRIPT65535: Argument not optional

It is saying grid is not available.
Declined
Last Updated: 17 Apr 2018 19:23 by ADMIN
Created by: Shivi
Comments: 2
Category: Grid
Type: Bug Report
1
Hello Sir

As I was workimg on Print functionality of RadGrid data.

While working on this functionality I found issue of "Print Preview" in chrome. Its working fine in IE and Firefox but in Chrome blank screen is coming with Print Preview Failed.

While searching on it I found "RadGrid Not Printing in Chrome" Post on telerik developer forum, I have created Telerik account and also reply to this post. 

Sir can you please help me regarding this issue. I look forward to hearing from you.

Regards
Declined
Last Updated: 08 Oct 2015 10:02 by Imported User
The problem for which the bug was opened was not actually caused by the RadGrid. It was triggered by wrong configuration of the test sample. The parent container which held the grid had disabled ViewState in which case it is expected for the filter values and filter functions to not persist.
Declined
Last Updated: 18 Aug 2016 18:16 by wildyaker
Created by: Matthew
Comments: 4
Category: Grid
Type: Bug Report
1
Reference: http://www.telerik.com/forums/radgrid-column-header-and-data-item-alignment-problem

This has apparently been an issue with RadGrid for a long time, according to the above thread. I have done a significant amount of testing to isolate this bug and have attached a self-contained solution in VB.NET 4.0 (VS 2010).

I removed all the surplus RadGrid properties I could in order to simplify the debugging process on your end and included my notes in the code and on the test page. There is indeed some peculiar behavior with the control.

Regards,
Matthew
Declined
Last Updated: 23 Dec 2014 09:41 by ADMIN
Declined
Last Updated: 19 Jan 2015 15:53 by ADMIN
Created by: David
Comments: 1
Category: Grid
Type: Bug Report
0
I am using the following grid:
   <telerik:RadGrid style="overflow: hidden" CssClass="dm-Grid" ID="gridView" runat="server" AllowPaging="false" PageSize="25" Skin="TylerSilver" EnableEmbeddedSkins="false" EnableViewState="true"
            ExportSettings-ExportOnlyData="true" ExportSettings-IgnorePaging="true" AutoGenerateColumns="false" SortingSettings-SortedBackColor="#F0F0F0" EnableAlternatingRowColor="true"
            EnableAjaxSkinRendering="true" AllowSorting="true" ShowGroupPanel="false" GroupPanel-Enabled="false"
            ClientIdMode="AutoId" AllowFilteringByColumn="true" onneeddatasource="gridView_NeedDataSource" Onitemcreated="gridView_ItemCreated" onitemdatabound="gridView_ItemDataBound">
            <clientsettings>
        <clientevents onrowselected="RowSelected" onrowdeselected="RowSelected" oncolumnclick="OnColumnClick" OnColumnSwapped="ColumnSwapped" OnGridCreated="OnGridCreated"/>
    </clientsettings>
        </telerik:RadGrid>

Columns are dynamic, created in code-behind to match configurable datasets, via gridView.Columns.Add.  Each column has UniqueName, SortExpression, and HeaderText properties set - first two to the field name, last to plain-English version of the field name with spaces, etc.  Data binding is via a data table created from search results:

 gridView.DataSource = allDocumentsTable;

and using the following JS to activate the header cell context menus:

 function ShowColumnHeaderMenu(ev, index) {
            var grid = $find("<%=gridView.ClientID %>");
            var columns = grid.get_masterTableView().get_columns();
            columns[index - 1].showHeaderMenu(ev, 5, 5);
        }

I'm able to group columns using the menu but the "ungroup" command in the menu does not work.  If I turn on the grouping panel as a test (we do not want this UI style in production code), I can ungroup columns using the panel, but that does not change the behavour of the ungroup command in the header menu; it still does not work.

I've tried this with the Q2 2014 release and the problem is reproducible in that version.
Declined
Last Updated: 19 Jan 2015 16:25 by ADMIN
Vertical Column Headers using rgRotateHeader seem to be a different, less readable, font than the regular horizontal column headers.  Please see attachment.  All those column headers are set to the same font.  To my eye, the rotated headers look quite poor.
Declined
Last Updated: 03 Nov 2014 13:03 by Elena
RadGrid cannot edit in IE8 under 2014Q2
javascript thows errors:
URI: http://localhost/Telerik.Web.UI.WebResource.axd?_TSM_HiddenField_=RadScriptManager1_TSM&compress=1&_TSM_CombinedScripts_=%3b%3bSystem.Web.Extensions%2c+Version%3d4.0.0.0%2c+Culture%3dneutral%2c+PublicKeyToken%3d31bf3856ad364e35%3azh-CN%3a8f393b2b-3315....

To fix the upper problem, we appyied 2014Q2SP1, however, in IE8, javascript thows new errors:
“sys is undefined” 
and the RadGrid does not display in web. But this is ok in debuging mode.
Declined
Last Updated: 03 Nov 2014 12:31 by Elena
I want column width state maintain on postback. here with i am attaching may aspx page
Declined
Last Updated: 03 Nov 2014 12:29 by Elena
Created by: Padmasinh
Comments: 2
Category: Grid
Type: Bug Report
2
My Sort order of records is persisting in normal radgrid but when i am using radgrid with grouping its not persisting.

The ragGrid during page load are as folllows.

Customer group Name        Customer Name      Sort Order
Group 1
                                              Very High                    1
                                                High                          2
                                               ABC                           3

and the filer for columns format are as follow

<telerik:GridBoundColumn HeaderText="Customer Name" FilterControlAltText="Filter column1 column"
                                    DataField="Name" UniqueName="Name" FilterControlWidth="150px" AutoPostBackOnFilter="true"
                                    HtmlEncode="true" CurrentFilterFunction="Contains" ShowFilterIcon="false">
                                </telerik:GridBoundColumn>

And when i filter the grid on customer name with "high" word the grid shows results as follow

Customer group Name        Customer Name      Sort Order
Group 1
                                                  High                        2
                                              Very  High                   1
                                               
And i am needdatasource event then also this problem occurring so please provide me any solution.
Declined
Last Updated: 03 Nov 2014 12:28 by Elena
Created by: Padmasinh
Comments: 1
Category: Grid
Type: Bug Report
1
grid line are not showing here with i am attaching the my aspx page and the current output page screen shot. this issue are randomly generated may be generate on first page load or on page scroll some lines visible or invisible. But grid line are always shown in IE8.
Declined
Last Updated: 03 Nov 2014 12:21 by Elena
Created by: Sunil Sutar
Comments: 1
Category: Grid
Type: Bug Report
0
Hi Team,

Please go through the ticket.
http://www.telerik.com/account/support-tickets/view-ticket.aspx?threadid=821301

Here' there is javascript error on Filter click. We have attached the example in first thread.

The example contains a grid with a runtime header column addition. When the filters are on with Grid, clicking any of the filter icon to open "filter menu" causes a JavaScript error.

 If we skip the code to add "Runtime header column", there is no such error. But there is requirement of our client to have such header "Skip to Content" button in the header above filter.

Please see,
 - We are using a webcontrol, AECTelerikGrid as attached.
 - This should display "Skip to Content" in the header bar.
 - After this, click on any of the filters and this will result in JS error as attached.



Thanks,
Sunil
Declined
Last Updated: 03 Nov 2014 15:01 by ADMIN
We are using version 2012.Q3 of Telerik, for the RadGrid control.

Once we updated to VS 2013 Update 2, we experienced a rendering problem on our development machines for all RadGrids on our site.

Upon further review we found out that this was due to the Browser Link feature in VS 2013. Browser Link appears to inject code between the development environment and the web server(s).

We were able to fix this upon finding an article pointing us towards the Browser Link feature. However it did take quite a while to figure out the issue, so we wanted to pass this along so that you could create a Knowledge Base article about this so that others can find the solution more easily and quickly.

Resolution:
Add the following item to the AppSettings section of the Web.config
<add key="vs:EnableBrowserLink" value="false" />

References:
http://weblogs.asp.net/imranbaloch/archive/2013/10/23/messy-html-and-js-errors-when-you-install-visual-studio-2013.aspx

http://stackoverflow.com/questions/19513631/radgrid-rendering-differently-in-different-machine-of-100-same-application-when

http://www.asp.net/visual-studio/overview/2013/using-browser-link 
(what is Browser Link)
Declined
Last Updated: 16 Jun 2014 13:35 by Imported User
1 2 3