Completed
Last Updated: 29 Sep 2015 12:05 by ADMIN
FileBrowser dialogs cannot upload files greater than 200kb when AsyncUpload is disabled (i.e., the Upload control is used instead). 
Completed
Last Updated: 02 Oct 2015 10:05 by ADMIN
The RadEditor is posting multiple symbols when you select to insert a symbol. This happen when the RenderMode is set to LightWeight. The problem is reproducible also when inserting code snippets via the "Insert Code snippet" tool.
video - http://screencast.com/t/DfBMWrW4Px7I

Steps to reproduce:
1. Open http://demos.telerik.com/aspnet-ajax/editor/examples/rendermodes/defaultcs.aspx
2. Try to insert a symbol through "Insert Symbol" command
    Result: Two symbols are inserted instead of one
Completed
Last Updated: 11 Sep 2015 08:53 by Jenny
ADMIN
Created by: Danail Vasilev
Comments: 2
Category: Editor
Type: Bug Report
5

			
Unplanned
Last Updated: 27 Jul 2016 08:58 by Sunil
Unplanned
Last Updated: 01 Sep 2015 07:04 by ADMIN
When there are words highlighted as wrong and triggering the Finish Spellchecking without correcting any words, subsequent editing of words inside the sentence causes random cursor replacement. 

Workaround:

<telerik:RadEditor ID="RadEditor1" runat="server" OnClientLoad="OnClientLoad">
    <Content>Whether you need a mere Textbox with Google-like spellchecker, or a Word-like content authoring environment, the result is the same: clean <strong>XHTML</strong></Content>
</telerik:RadEditor>

<script>
    function OnClientLoad(sender, args) {
        sender.add_spellCheckLoaded(spellCheckLoaded)
    }

    function spellCheckLoaded(sender) {
        var editor = sender;
        var spell = editor.get_ajaxSpellCheck();

        spell.add_spellCheckEnd(function (sender, args) {
            editor.set_html(editor.get_html(true));
        });
    }
</script>
Completed
Last Updated: 29 Sep 2015 11:10 by ADMIN
The click event of the button is not prevented and the native anchor behavior occurs. This causes the page to scroll to the top and a # to appear in the URL. 

You can use the following code snippet to prevent the native click behavior of the anchor element and workaround the issue:

<telerik:RadEditor runat="server" ID="RE1" ToolbarMode="Floating" OnClientLoad="OnClientLoad"></telerik:RadEditor>

<script>
    function OnClientLoad(sender, args) {
        $telerik.$(".RadEditor a[title='Toggle Floating Toolbar']").attr("href", "javascript:void(0);")
    }
</script>
Won't Fix
Last Updated: 14 Jan 2016 11:33 by ADMIN
Completed
Last Updated: 27 Aug 2015 06:49 by Khushboo
ADMIN
Created by: Vessy
Comments: 1
Category: Editor
Type: Bug Report
3
When link is given to any image or text, Unlink command should get enabled. But it gets enabled for text only while remains disabled for images.
http://screencast.com/t/xHgru58pzKL

The issue has been reproducible since 2015 Q1 release
Completed
Last Updated: 07 Jun 2016 07:38 by ADMIN
Created by: Khushboo
Comments: 1
Category: Editor
Type: Bug Report
2
When link is given to image or text, Unlink command should get enabled. But it gets enabled for text only while remains disabled for images. 

To get a better understanding, please refer to the following video:
http://screencast.com/t/xHgru58pzKL
Unplanned
Last Updated: 11 Aug 2015 16:03 by ADMIN
ContentEditable=true attribute is added to the body element of the Editor's content when resizing a table in RadEditor in Chrome.

http://screencast.com/t/0s3QlydHv
Unplanned
Last Updated: 07 Jun 2016 07:40 by Christophe
Created by: Christophe
Comments: 0
Category: Editor
Type: Bug Report
0
Hi,
There is a bug with the "Play" parameter while I insert a SWF movie.
If I uncheck this parameter, the movie still play in Chrome/Mozilla.
This bug is  from this parameter that isn't added in the Embed tag although it is in the object tag.

Example :
<object classid="clsid:D27CDB6E-AE6D-11cf-96B8-444553540000" width="150" height="150">
<param name="Movie" value="/aspnet-ajax/Editor/images/UserDir/Marketing/Reporting_banner.swf">
<param name="play" value="false">
<param name="quality" value="high">
<param name="wmode" value="transparent">
<param name="loop" value="false">
<param name="menu" value="false"><embed src="/aspnet-ajax/Editor/images/UserDir/Marketing/Reporting_banner.swf" width="150" height="150" type="application/x-shockwave-flash" pluginspage="http://www.macromedia.com/go/getflashplayer" quality="high" wmode="transparent" loop="false" menu="false"></object>

Thanks a lot
Chris.
Completed
Last Updated: 21 Aug 2015 15:31 by ADMIN
The error causes the editor's content area not to render. 

The following script can be used as a temporary workaround:

<telerik:RadEditor runat="server" ID="RadEdior1" OnClientSelectionChange="OnClientSelectionChange">
</telerik:RadEditor>

<script type="text/javascript">
    function OnClientSelectionChange(editor, args) {
        if (!editor.getSelectedElement()) {
            editor.focusFirstText();
        }
    }
</script>

Completed
Last Updated: 01 Dec 2015 12:14 by ADMIN
ADMIN
Created by: Ianko
Comments: 1
Category: Editor
Type: Bug Report
0
When user has changed image properties via Image Properties dialog, changes are getting cleared when area is being added via Image Map Editor. 
Completed
Last Updated: 16 Jul 2015 05:02 by siddhi
Trying to operate with images in RadEditor under IE11 leads to unresponsiveness. For example, using the paragraph style, selecting an image and switching to HTML and Design mode, etc.

You can workaround that by forcing the compatibility mode of the IE to IE8:

<meta http-equiv="X-UA-Compatible" content="IE=8" />
Completed
Last Updated: 08 Sep 2015 10:34 by Luigi Gaeta
When there is a need to open dialogs in browser's window instead of RadWindow, the UseClassicDialogs property is being used. With the release of Q2 2015 the functionality stopped working and throws JS error when a dialog is opened. 

To workaround this behavior you can apply the JS patch as shown below:  

    <telerik:RadEditor runat="server" ID="RadEditor1"></telerik:RadEditor>
    
    <script type="text/javascript">
        Telerik.Web.UI.RadDialogOpener.prototype._applyParameters = function (dialogName, container) {
            //If no parameters provided, return
            var parameters = this._getDialogParameters(dialogName);
            if (!parameters) return;
    
            var parametersUrlPart = "&dp=" + encodeURIComponent(parameters);
            var baseUrl = this._getBaseDialogUrl(dialogName);
            var totalUrlLength = baseUrl.length + parametersUrlPart.length;
    
            var parametersPassedFromClient = this._dialogParametersProviderTypeName == "";
            var parametersPassedThroughUrl = parametersPassedFromClient && totalUrlLength <= this.get_dialogUrlLengthLimit();
    
            if (parametersPassedThroughUrl) {
                //NEW: If the dialog features the same URL, do not reload it
                var curUrl = container.get_navigateUrl();
                var url = baseUrl + parametersUrlPart;
    
                if (curUrl != url) {
                    if (this.get_useClassicDialogs() || container.isCreated()) {
                        container.setUrl(url);
                    }
                    else {
                        container.set_navigateUrl(url);
                    }
                }
                else //Reinitialize
                {
                    var contentFrame = container.get_contentFrame();
                    if (contentFrame && contentFrame.contentWindow && contentFrame.contentWindow.$find) {
                        //TODO: Probably implement a global function initializeDialog that will be called automatically - easy for custom dialogs
                        var initDialog = contentFrame.contentWindow.initDialog;
                        if (initDialog) {
                            contentFrame.contentWindow.setTimeout(function () { initDialog(); }, 1);
                        }
                    }
                }
            }
            else {
                container.setUrl(baseUrl);
                container.DialogParameters = parameters;
            }
        };
    
    </script>
Completed
Last Updated: 06 Jun 2016 15:29 by Andrey
Created by: akom
Comments: 1
Category: Editor
Type: Bug Report
3
Instructions:
In IE11 when we select an image and change from Design to HTML mode or try to apply any paragraph style to it, the browser gets unresponsive. 

To get a better understanding, please refer to the following videos:
http://screencast.com/t/xufHlK0bew
http://screencast.com/t/YcVcqygVY7GE

Demo page: http://demos.telerik.com/aspnet-ajax/editor/examples/overview/defaultcs.aspx?skin=Default
Completed
Last Updated: 21 Jul 2015 11:58 by ADMIN
Such a scenario is reproducible when RadEditor is used in Template container and the control is AJAX-enabled. For example, in an EditTemplate or InsertTemplate. 

To workaround this bug, you need to assure that the base CSS resource is loaded before RadEditor. To do so, add manually the resource in the head element of the page:

<head runat="server">
    <title></title>
    <telerik:RadCodeBlock ID="RadCodeBlock1" runat="server">
        <link href='<%= Page.ClientScript.GetWebResourceUrl(typeof(RadEditor), "Telerik.Web.UI.Skins.EditorLite.css") %>'
            rel="stylesheet" type="text/css" />
    </telerik:RadCodeBlock>
</head>
Completed
Last Updated: 31 Jul 2015 11:16 by ADMIN
The scenario is very specific. It is reproducible only under IE11 when RadEditor is loaded in an iframe, in Div content area mode, with AutoResizeHeight="true" and Skin is set to MetroTouch or BlackMetroTouch
Completed
Last Updated: 28 Jul 2015 08:23 by ADMIN
Deleting all content in editor (e.g.,  Ctrl+A and delete), and switching to HTML mode, an unwanted &nbsp; is always present. Whereas, the content should be empty. 
Completed
Last Updated: 08 Jul 2015 08:20 by MS
The behavior of Paste tools should be the same as in Firefox, Chrome, etc., where the clipboard access is also forbidden.