Completed
Last Updated: 25 Nov 2016 15:48 by ADMIN
Thead and tfoot elements get deleted with deleting content of table in Google Chrome.

On the RadEditor demo page [http://demos.telerik.com/aspnet-ajax/editor/examples/overview/defaultcs.aspx]

Replace the content with a table with a thead tbody tfoot caption

<table>
   <caption>ABC</caption>
   <thead>
      <tr>
         <th>A</th>
         <th>B</th>
         <th>C</th>
      </tr>
   </thead>
   <tfoot>
      <tr>
         <td>FOOT</td>
         <td>FOOT</td>
         <td>FOOT</td>
      </tr>
   </tfoot>
   <tbody>
      <tr>
         <td>A1</td>
         <td>B1</td>
         <td>C1</td>
      </tr>
      <tr>
         <td>A2</td>
         <td>B2</td>
         <td>C2</td>
      </tr>
      <tr>
         <td>A3</td>
         <td>B3</td>
         <td>C3</td>
      </tr>
   </tbody>
</table>

Select some content across the tbody, tfoot, thead and caption and delete 

Expected results: the content of the TD and TH should be remove

Actual results: the THEAD and TFOOT elements are removed

More details check the attached delete_thead_tfoot.gif file.

Workaround: 
<telerik:RadEditor ID="RadEditor1" runat="server">
</telerik:RadEditor>

<script>
	(function () {
		var $E = Telerik.Web.UI.Editor;
		var utils = $E.Utils;
		var cmdPrototype = $E.DeleteSelectionCommand.prototype;
		var shouldCollectNode = cmdPrototype.shouldCollectNode;
		cmdPrototype.shouldCollectNode = function (node) {
			return shouldCollectNode.call(this, node) && !utils.isTag(node, "thead") && !utils.isTag(node, "tfoot");
		};
	})();
</script>
Completed
Last Updated: 27 Oct 2016 13:27 by ADMIN
In R3 2016 SP1 when a RadEditor with RenderMode=Classic is disposed and RadScriptManager is used, a JavaScript error is thrown:
IE:  Object doesn't support property or method 'dispose'
Chrome: Uncaught TypeError: this._contextMenuFunctionality.dispose is not a function

FIXED in R3 2016 SP2 (2016.3.1027)

There are three workarounds:
- Set EnableScriptCombine to false for the RadScriptManager (not applicable when CDN is used)
- OR set RenderMode=Lightweight for the RadEditor (you can do this in the web.config for all control instance in the web app if they do not define the Classic mode exiplicitly)
- OR add the following function override at the end of your page:

			<telerik:RadScriptManager ID="RadScriptManager1" runat="server" >
			</telerik:RadScriptManager>

			<%-- WORKAROUND 1: SET EnableScriptCombine="false" TO RADSCRIPTMANAGER--%>

			<asp:Button ID="Button1" Text="click to postback and break the editor" runat="server" />

			<telerik:RadEditor ID="txtInstructions" runat="server">
			</telerik:RadEditor>

			<%-- WORKAROUND 2: SET RenderMode="Lightweight" TO RADEDITOR--%>


			<%--WORKAROUND 3: ADD THE FOLLOWING SCRIPT TO THE END OF THE FORM--%>
			<script>

				Telerik.Web.UI.Editor.DefaultToolAdapter.prototype.dispose = function ()
				{
					delete this._fakeToolbarParentCreated;
					var toolbars = this._getToolBarElements();
					if (toolbars) {
						for (var i = 0; i < toolbars.length; i++) {
							$clearHandlers(toolbars[i]);
						}
					}
					this._tools = [];
					this._disposeToolbarModeHandlers();
					var wnd = this._toolbarHolder;
					if (wnd && wnd.dispose) wnd.dispose();
					var contextMenuFunctionality = this._contextMenuFunctionality;
					if (contextMenuFunctionality && contextMenuFunctionality.dispose) contextMenuFunctionality.dispose();
					Telerik.Web.UI.Editor.DefaultToolAdapter.callBaseMethod(this, "dispose");
				}
			</script>
Completed
Last Updated: 14 Oct 2016 12:37 by ADMIN
ADMIN
Created by: Marin Bratanov
Comments: 0
Category: Editor
Type: Bug Report
0

			
Approved
Last Updated: 06 May 2019 12:26 by ADMIN
Problem:

In the RadEditor we have the NewLineMode set to Div
We are also using a ToolsFile xml document to control the tools available in RadEditor.
The problem is the InsertParagraph tool now inserts <div> tags instead of <p> tags.
We want to keep the NewLineMode behavior as DIV while still having a tool that can insert a paragraph (i.e. a <p> tag).

To replicate this problem:

On the RadEditor demo page, first set "NEW LINES AS" to "Divs".
Then, in the editor content area just above the "Destinations" table, Type in three lines:
Comment1
Comment2
Comment3

If you then toggle to the HTML tab, you will see that the Comment1 line is (incorrectly) bracketed by a <p> tag while the Comment2 and Comment3 lines are (correctly) bracketed by <div> tags.

Next, go back to the Design tab and position yourself at the beginning of the Comment3 line then click the [Insert Paragraph] button.

In the newly inserted "paragraph" type "Comment2b".

If you then toggle to the HTML tab you will see that Comment2b is incorrectly bracketed by a <div> tag.  It should be a <p> tag.

Approved
Last Updated: 28 Sep 2016 15:05 by ADMIN
Changing the background color for the second/subsequent paragraph causes background color for first/previous paragraph to be lost/changed.  This is a browser-specific bug.

Reproduction steps:

    Navigate Internet Explorer/Edge browser to: Telerik RadEditor Demo Page
    Select-all and delete.
    With cursor at the beginning, select a background color from the toolbar.
    Type some text.
    Hit the Enter key to start a second paragraph
    Select the "no-fill" background color from the toolbar.

Results:

-The background color for the first/previous paragraph is removed.
Completed
Last Updated: 06 Oct 2016 15:07 by ADMIN
Current workaround is provided in the archive below. It consists of a function override that prevents the attribute loss. Below the workaround is the repro sample that invokes the validation.
Completed
Last Updated: 02 Nov 2016 14:15 by Clintrak_it
Approved
Last Updated: 14 Sep 2016 15:08 by ADMIN
When part of a table from MS Excel is copied and pasted into RadEditor under Edge, the RadEditor inserts an image instead of the html for the table. It inserts <img alt="" src="data:image/png;base64, ... " /> instead of the html.

Steps to reproduce:

Open http://demos.telerik.com/aspnet-ajax/editor/examples/overview/defaultcs.aspx in MS Edge.On the editor select the html and delete everything.
On the editor select design
Open any Excel file copy a couple of cells
Paste in the Editor
On the editor select html
Instead if html the there is an image tag
<img alt="" src="data:image/png;base64,iVBOR ... YII=" />

With firefox, IE 11 and Chrome the html is pasted. For MS Edge the Image tag is pasted.

Workaround:
<telerik:RadEditor runat="server" ID="RadEditor"></telerik:RadEditor>
<script>   
    Telerik.Web.UI.Editor.Utils.containsHtmlAtClipboard = function(oEvent) {
        var result = oEvent && oEvent.clipboardData && oEvent.clipboardData.getData &&
            oEvent.clipboardData.types && oEvent.clipboardData.types.length &&
            Telerik.Web.UI.Editor.Utils.containsElement(/text\//i, oEvent.clipboardData.types);
 
        return result;
    }
</script>
Declined
Last Updated: 27 Mar 2019 17:41 by ADMIN
Created by: John
Comments: 1
Category: Editor
Type: Bug Report
2
When part of a table from MS Excel is copied and pasted into RadEditor under Edge, the RadEditor inserts an image instead of the html for the table. It inserts <img alt="" src="data:image/png;base64, ... " /> instead of the html. IE 11, Chrome and Firefox all paste the html in the RadEditor but MS Edge pastes as an image. Is there a way for the radeditor to override this so the html is pasted instead of an image?
Completed
Last Updated: 27 Mar 2019 18:10 by ADMIN
You can press Delete or Backspace again to delete the remaining content
Completed
Last Updated: 20 Sep 2016 14:44 by conall
ADMIN
Created by: Marin Bratanov
Comments: 2
Category: Editor
Type: Bug Report
2
			<telerik:RadEditor ID="RadEditor1" runat="server">
				<Content>
				select and delete some of the "th" content, the entire cell element will be deleted instead of its content
					<table>

						<thead>
							<tr>
								<th>th1</th>
								<th>th2</th>
								<th>th3</th>
							</tr>
						</thead>

						<tr>
							<td>1</td>
							<td>2</td>
							<td>3</td>
						</tr>

					</table>
				</Content>
			</telerik:RadEditor>
			<script>
				//workaraound

				Telerik.Web.UI.Editor.DeleteSelectionCommand.prototype.deleteNodeContent = function (node) {
					var utils = Telerik.Web.UI.Editor.Utils;
					if (utils.isTag(node, "td") || utils.isTag(node, "th")) {
						utils.removeChildren(node);
						node.innerHTML = NBSP;
					} else {
						remove(node);
					}
				}
				
				function remove(node) {
					node.parentNode.removeChild(node);
				}
			</script>
Completed
Last Updated: 12 Sep 2016 11:41 by ADMIN
ADMIN
Created by: Niko
Comments: 0
Category: Editor
Type: Bug Report
0
When copying text using the keyboard, the content is not copied. Instead is is marked as deleted and the selection is moved to the end of the selection.
Completed
Last Updated: 16 Sep 2016 13:53 by ADMIN
Finding is stuck to the last possible occurrence and cannot proceed to the next match.
Declined
Last Updated: 21 Mar 2019 10:25 by ADMIN
Created by: Ravi
Comments: 1
Category: Editor
Type: Bug Report
0
Hi Telerik Team,

There is one recent problem we faced when using RadEditor. The bottom line is distorted.

We are using version telerik version ASP.NET AJAX Q2 2016.

Attached is the screenshot of html. 

Declined
Last Updated: 21 Mar 2019 11:53 by ADMIN
Created by: Ravi
Comments: 1
Category: Editor
Type: Bug Report
0
Hi Telerik Team,

There is one recent problem we faced when copy paste from word document to Rad Editor. The spacing between the paragraphs is more than what exists in the word document.

The property we are using while copy paste from document to RadEditor

    radTextEditor.StripFormattingOptions = Telerik.Web.UI.EditorStripFormattingOptions.MSWordNoMargins | Telerik.Web.UI.EditorStripFormattingOptions.ConvertWordLists;

The functionality working fine in IE 11.

We are using version telerik version ASP.NET AJAX Q2 2016.

Also there is a default font of Times New Roman in Edge browser which not in IE 11

Attached is the screenshot of html. 

Please look into this.
Declined
Last Updated: 14 Oct 2016 10:48 by ADMIN
Created by: pranav
Comments: 2
Category: Editor
Type: Bug Report
0
Hi Telerik Team,

There is one recent problem we faced when copy paste of email address doesn't get open in outlook as HREF property is not set in Edge Browser. The functionality working fine in IE 11.

We are using version telerik version ASP.NET AJAX Q2 2016.

Attached is the screenshot of html. 
Approved
Last Updated: 19 Sep 2016 08:06 by Gurjeet
When using Table Wizard to insert a new table inside a table cell, the selected table is replaced by the one created from Table Wizard. 

Currently, the workaround is to use the plain InsertTable tool in order to nest tables. 
Completed
Last Updated: 01 Sep 2016 13:34 by ADMIN
The formatting of nested lists is lost when pasting from Word in IE10. The issue is reproducible also in IE8 and I9.
Approved
Last Updated: 30 Jun 2016 13:04 by ADMIN
Having some text and input inside: Highlight it in order to copy and paste leads and the content area will scroll to the top of the content area. Also, you cannot highlight the input in order to copy and paste it. 
Completed
Last Updated: 24 Jun 2016 13:05 by ADMIN
Having multiple paragraphs that are formatted with color and font-size as inline styles, selecting them and applied font-size by using RealFontSize tool causes these issues:

1. Only first paragraph is properly decorated;
2. Second paragraph is stripped from any inline styles at all;
3. The next paragraphs stay without any changes applied.


Possible workaround is to disable the ConvertFontToSpan filter:

RadEditor1.DisableFilter(EditorFilters.ConvertFontToSpan);