Approved
Last Updated: 02 Oct 2019 14:01 by ADMIN
  1. Open your demo for Batch Editing: https://demos.telerik.com/aspnet-ajax/grid/examples/data-editing/batch-editing/defaultcs.aspx
  2. Add a new row
  3. Enter values
  4. Click on x to delete

Expected: the row disappears.

Actual result: nothing happens.

 

 

Approved
Last Updated: 10 Jul 2019 15:56 by ADMIN
I have found that there is a bug when working with tables in the editor in inline editing mode in Safari on Mac - https://demos.telerik.com/aspnet-ajax/editor/examples/inline-editing/defaultcs.aspx.

In the normal editing mode, you can edit the table properties by right clicking inside the table to get the context menu, then choose table properties, add row etc.

In Inline editing mode, it shows the context menu but when you click on any item it says to select the table. None of the other context menu commands like inserting rows etc work.

I have tested on your demo site and you should be able to simulate it there.
Approved
Last Updated: 05 Jun 2019 11:26 by ADMIN

Hello,

I enabled the ShowButton property to the radtextbox, but while writing and the words reach the button I can't see the final of the text. 

<telerik:RadTextBox ID="RadTextBox1" runat="server" ShowButton="true"></telerik:RadTextBox>

If I disable the ShowButton and write something in the radtextbox, I can see the final words. 

How I can fix this? 

Thanks,
Edson

Approved
Last Updated: 07 May 2019 11:43 by ADMIN
In Classic RenderMode, Windows7 skin, TreeView nodes are higher when inside ContentTemplate of RadPanelBarItem:



<div>
    wrong:
    <telerik:RadPanelBar RenderMode="Classic" Skin="Windows7" runat="server" ID="RadPanelBar1" Width="100%" Height="100%">
        <Items>
            <telerik:RadPanelItem Text="Custom" Expanded="true">
                <ContentTemplate>
                    <telerik:RadTreeView RenderMode="Classic" Skin="Windows7" ID="radTreeView" runat="server">
                        <Nodes>
                            <telerik:RadTreeNode  Text="Custom">
                                <Nodes>
                                </Nodes>
                            </telerik:RadTreeNode>
                            <telerik:RadTreeNode  Text="Custom">
                                <Nodes>
                                </Nodes>
                            </telerik:RadTreeNode>
                            <telerik:RadTreeNode  Text="Custom">
                                <Nodes>
                                </Nodes>
                            </telerik:RadTreeNode>
                        </Nodes>
                    </telerik:RadTreeView>
                </ContentTemplate>
            </telerik:RadPanelItem>
        </Items>
    </telerik:RadPanelBar>
</div>
<div>
        OK:
    <telerik:RadTreeView ID="radTreeView2" RenderMode="Classic" Skin="Windows7" runat="server">
        <Nodes>
            <telerik:RadTreeNode Text="Custom">
                <Nodes>
                </Nodes>
            </telerik:RadTreeNode>
            <telerik:RadTreeNode  Text="Custom">
                <Nodes>
                </Nodes>
            </telerik:RadTreeNode>
            <telerik:RadTreeNode  Text="Custom">
                <Nodes>
                </Nodes>
            </telerik:RadTreeNode>
        </Nodes>
    </telerik:RadTreeView>
</div>


Approved
Last Updated: 19 Apr 2019 09:41 by ADMIN

Using CommandItemTemplate (Grid - Command Item) for Editing DetailTable records and selecting an item after filtering or from another page, one item from the first page is put for editing instead. Open the attached GIF animation (EditSelectedEditWrongItem.gif) to see it in action.

 

Currently the workaround we offer is to handle the EditSelected command manually for all the DetailTables Except for the Master.

 

Grid markup:

 

        <telerik:RadGrid ID="RadGrid1" runat="server" AllowPaging="True" Width="100%" PageSize="3"
            OnItemCommand="RadGrid1_ItemCommand"
            OnDetailTableDataBind="RadGrid1_DetailTableDataBind"
            OnNeedDataSource="RadGrid1_NeedDataSource">
            <MasterTableView Name="MasterTable" AutoGenerateColumns="true" DataKeyNames="OrderID">
                <DetailTables>
                    <telerik:GridTableView Name="ChildTable" DataKeyNames="OrderID" AutoGenerateColumns="true" CommandItemDisplay="Top">
                        <CommandItemTemplate>
                            <asp:LinkButton ID="btnEditSelected" runat="server" CommandName="EditSelected" CssClass="btn btn-default">Edit Selected</asp:LinkButton>
                        </CommandItemTemplate>
                    </telerik:GridTableView>
                </DetailTables>
            </MasterTableView>
            <ClientSettings>
                <Selecting AllowRowSelect="true" />
            </ClientSettings>
        </telerik:RadGrid>

 

C# - ItemCommand

 

    protected void RadGrid1_ItemCommand(object sender, GridCommandEventArgs e)
    {
        // Logic applies for all the tables (detail tables) which are not named "MasterTable"
        if(e.Item.OwnerTableView.Name != "MasterTable" && e.CommandName == RadGrid.EditSelectedCommandName)
        {
            e.Canceled = true;

            GridTableView detailTable = e.Item.OwnerTableView;

            if (detailTable.OwnerGrid.SelectedIndexes.Count == 0)
            {
                return;
            }

            foreach (GridDataItem selectedItem in detailTable.OwnerGrid.SelectedItems)
            {
                selectedItem.Edit = true;
            }

            detailTable.Rebind();
        }
    }

 

VB - ItemCommand


Protected Sub RadGrid1_ItemCommand(ByVal sender As Object, ByVal e As GridCommandEventArgs)
    If e.Item.OwnerTableView.Name <> "MasterTable" AndAlso e.CommandName = RadGrid.EditSelectedCommandName Then
        e.Canceled = True
        Dim detailTable As GridTableView = e.Item.OwnerTableView

        If detailTable.OwnerGrid.SelectedIndexes.Count = 0 Then
            Return
        End If

        For Each selectedItem As GridDataItem In detailTable.OwnerGrid.SelectedItems
            selectedItem.Edit = True
        Next

        detailTable.Rebind()
    End If
End Sub

Approved
Last Updated: 11 Apr 2019 08:09 by ADMIN
Created by: Don Leduc
Comments: 1
Category: UI for ASP.NET AJAX
Type: Bug Report
0
I have a big problem here. I have the following code and this code is launched in RadWindow as well:

<telerik:RadTabStrip runat="server" ID="RadTabStrip2" MultiPageID="RadMultiPage2" SelectedIndex="0">
    <Tabs>
        <telerik:RadTab Text="Add Response"></telerik:RadTab>
    </Tabs>
</telerik:RadTabStrip>
<telerik:RadMultiPage runat="server" ID="RadMultiPage2" SelectedIndex="0">
    <telerik:RadPageView runat="server" ID="RadPageView11">
 
            <telerik:RadEditor Width="100%" EditModes="Design" ID="reReqCom" runat="server"  ContentAreaCssFile="~/AppRoot/Xml/RadEditor/EditorContentArea.css"
                ToolsFile="~/AppRoot/Xml/RadEditor/BasicTools.xml" Skin="Material" />
 
    </telerik:RadPageView>
</telerik:RadMultiPage>

 
The problem here is only using the iPhone (ioS), that the user is NOT able to select onto the RadEditor to begin typing. Seems to somehow block it out. I have stripped down to the basic code above and tested.

Can you tell us if this is a known issue?

Is there a workaround?

 

Don
Approved
Last Updated: 29 Mar 2019 12:38 by ADMIN
When the DatePicker is with enabled WAI-ARIA support, Jaws reads "link 11" instead of the selected date "Monday, March 11, 2019".
Approved
Last Updated: 22 Mar 2019 11:10 by ADMIN
I am exporting all the appointments using the RadScheduler's Export Calendar functionality (RadScheduler.ExportToICalendar(apptCollection, true)). 

I have the scheduler working with both regular and recurring appointments in my project with RadScheduler along with different timezone for each of the appointments within the scheduler properly. 

However, when I export the same through the above API as an ICS file, I am seeing that the date time is always coming out as UTC on recurring events giving me the wrong results in Outlook. 
Approved
Last Updated: 20 Mar 2019 15:22 by ADMIN

<telerik:RadNumericTextBox ID="RadNumericTextBox2" runat="server" MaxValue="9223372036854775807" Value="545445456456465454">
    <NumberFormat AllowRounding="false" DecimalDigits="0" />
</telerik:RadNumericTextBox>

MaxValue property is set to use the maximum value of int64: 9223372036854775807

Original value introduced is: 545445456456465454

Value becomes:  545445456456465000

Approved
Last Updated: 20 Mar 2019 15:35 by ADMIN
Some of the arrows in the Mobile Menu are missing in Chrome



<telerik:RadMenu ID="RadMenu1" RenderMode="Mobile" runat="server" ></telerik:RadMenu>

protected void Page_Load(object sender, EventArgs e)
{
    RadMenu1.RenderMode = RenderMode.Mobile;
    RadMenu1.Width = 300;
    for (int i = 0; i < 10; i++)
    {
        var radmenuItem = new RadMenuItem();
        radmenuItem.Text = "demo radmenu item " + i.ToString();
        for (int j = 0; j < 10; j++)
        {
            var radmenuItemChild = new RadMenuItem();
            radmenuItemChild.Text = "demo radmenu item child " + j.ToString();
            radmenuItem.Items.Add(radmenuItemChild);
        }
 
        RadMenu1.Items.Add(radmenuItem);
    }
}
Approved
Last Updated: 12 Feb 2019 16:15 by ADMIN

When attempting to view the page in design view, here's what it looks like:

 

Here is the markup:

    <telerik:RadPanelBar ID="RadPanelBar1" runat="server">
        <Items>
            <telerik:RadPanelItem runat="server" Expanded="True" PreventCollapse="true">
                <HeaderTemplate>
                    <div ID="content-header">
                        Auditing Report | GPO Changes For User
                    </div>
                </HeaderTemplate>
                <ContentTemplate>
                    <div ID="content-body">
                        <telerik:ReportViewer ID="ReportViewer1" runat="server" ReportBookID="" Width="100%" Height="12in">
                        </telerik:ReportViewer>
                    </div>
                </ContentTemplate>
            </telerik:RadPanelItem>
        </Items>
    </telerik:RadPanelBar>

Approved
Last Updated: 20 Dec 2018 17:16 by ADMIN
Created by: Sunil Sutar
Comments: 1
Category: UI for ASP.NET AJAX
Type: Bug Report
1
url to test with JAWS - https://demos.telerik.com/aspnet-ajax/combobox/examples/wai-aria-support/defaultcs.aspx

When I use JAWS to read the combobox present on this demo it reads as follows - ComboBox readonly - Alice Mutton. To change the selection press the arrow keys.

Over here, why JAWS is reading "readonly". It's not readonly. It's making our screenreader blind users confusing.

I drilled down more into the problem and found that, the input element below has the aria-readonly=true set though the combobox is not readonly.
Here is the html generated for above combobox from telerik demo site -

<input name="ctl00$ContentPlaceholder1$RadComboBox2" class="rcbInput radPreventDecorate" id="ctl00_ContentPlaceholder1_RadComboBox2_Input" role="combobox" aria-busy="false" aria-disabled="false" aria-expanded="false" aria-haspopup="true" aria-readonly="true" aria-owns="ctl00_ContentPlaceholder1_RadComboBox2_listbox" aria-autocomplete="none" type="text" readonly="readonly" value="Alice Mutton" autocomplete="off">

I understand that this input control should be readonly so that aria users should not type and go haywire. But looks like to maintain the readonly=readonly property, telerik is generating aria-readonly=true for this _Input control and resulting this issue.

When you change this attribute aria-readonly="true" to aria-readonly="false", JAWS read it correctly as follows - ComboBox - Alice Mutton. To change the selection press the arrow keys.
Approved
Last Updated: 19 Dec 2018 11:58 by ADMIN

Hi,

As per title and I also find out it able to reproduce in the demo site: https://demos.telerik.com/aspnet-ajax/editor/examples/overview/defaultcs.aspx

Step:

1. Change to 'HTML' mode.

2. Open 'Find And Replace' dialog.

3. Enter a word to find and hit the 'Find' button.

Notice that the word does not get highlighted. It only happens in 'HTML' mode, 'Design' mode working fine.

Please help as this feature is very useful in my project.

Thank you.

Approved
Last Updated: 01 Nov 2018 12:35 by ADMIN
ADMIN
Created by: Vessy
Comments: 1
Category: UI for ASP.NET AJAX
Type: Bug Report
1
RadButton's focus state styling is missing in Bootstrap.

Steps to reproduce:
1. Open https://demos.telerik.com/aspnet-ajax/button/examples/keyboardsupport/defaultcs.aspx?skin=Bootstrap
2. Focus any of the first buttons using the Tab key
    Result: No focus styles are applied
    Expected: Follow the steps above in Sunset skin

-----------------------------------------
Workaround:

        button.RadButton.rbButton:focus {
            box-shadow: 0 3px 5px rgba(0, 0, 0, 0.125) inset;
        }

Approved
Last Updated: 22 Oct 2018 14:21 by ADMIN
Approved
Last Updated: 19 Oct 2018 14:35 by ADMIN
The issue is as we are deleting the entire line which contains bullets, it doesn't delete the bullets. We are using server side AcceptTrackChanges() method and it keeps the background color of the deleted lines. 

ASPX

<telerik:RadEditor RenderMode="Lightweight" ID="RadEditor1" EnableTrackChanges="true" runat="server" Width="750px"
    Height="400px" ToolsFile="~/ToolsFile.xml">
    <TrackChangesSettings Author="RadEditorUser" CanAcceptTrackChanges="true" UserCssId="reU0"></TrackChangesSettings>
    <Content>
        <ol>
            <li>test
            <ol>
                <li>test2</li>
            </ol>
            </li>
            <li>test3</li>
        </ol>
    </Content>
</telerik:RadEditor>
<asp:Button Text="Get Content" OnClick="GetContent" runat="server" />
<br />
EditorWithoutTracking:<br />
<asp:TextBox runat="server" id="EditorWithoutTracking" TextMode="MultiLine" Width="1000px" Height="500px"/><br />
EditorWithTracking:<br />
<asp:TextBox runat="server" id="EditorWithTracking" TextMode="MultiLine" Width="1000px" Height="500px"/>

Codebehind

    protected void GetContent(object sender, EventArgs e)
    {
        EditorWithoutTracking.Text = RadEditor1.Content;
        RadEditor1.AcceptTrackChanges();
        EditorWithTracking.Text = RadEditor1.Content;
    }



Approved
Last Updated: 26 Sep 2018 15:52 by Kavitha
When Scrolling is enabled with Frozen columns in RadGrid, horizontal scrollbar not visible in Microsoft Edge.

Issue appears in Microsoft Edge Version:
- Microsoft Edge 42.17134.1.0
- Microsoft EdgeHTML 17.17134



WORKAROUND:

Apparently, setting the horizontal scrollbar's height to 17 pixels will make Microsoft Edge display it. (Note: in case it still not displaying, you may try with 18px)

To set the height, you can choose one of the options below:

1. Using CSS style to increase the size of the horizontal scrollbar by one pixel.

<style type="text/css">
    .RadGrid div[id$="_Frozen"] {
        height: 18px;

        /* or  */
        /*padding-bottom: 1px;*/
    }
</style>


2. Using JavaScript

Subscribe the grid to its GridCreated client-side event, and in the event handler increase the element's height with the scrollbar then revert it back to its original size with a delay:

<script type="text/javascript">
    function GridCreated(sender, args) {
        $('div[id$="_Frozen"]').height(17);
    }
</script>
Approved
Last Updated: 03 Aug 2018 11:42 by ADMIN
ADMIN
Created by: Peter Milchev
Comments: 0
Category: UI for ASP.NET AJAX
Type: Bug Report
0
Workaround: 

.rtsDropClueLeft {
    margin: -0.5em 0 0 -0.75em;
}

    .rtsDropClueLeft:before {
        content: "\e005";
    }

.rtsDropClueRight {
    margin: -0.5em 0 0 -0.25em;
}

    .rtsDropClueRight:before {
        content: "\e007";
    }
Approved
Last Updated: 27 Jul 2018 10:59 by ADMIN
The click event of the toolbar is triggered only when the user clicks outside of the set button icon (the text or the button element). Clicking directly over the icon does not perform any action in IE11.

video: https://www.screencast.com/t/K50K4X8Ck

Code to reproduce:
            <telerik:RadToolBar runat="server" ID="ToolBar1">
                <Items>
                    <telerik:RadToolBarButton
                        ImageUrl="//d585tldpucybw.cloudfront.net/sfimages/default-source/labs/kendo/kendoka-states.png"
                        NavigateUrl="Default.aspx"
                        Text="Link"/>
                    <telerik:RadToolBarButton
                        ImageUrl="//d585tldpucybw.cloudfront.net/sfimages/default-source/labs/kendo/kendoka-states.png"
                        NavigateUrl="Default.aspx"/>
                </Items>
            </telerik:RadToolBar>
Approved
Last Updated: 04 May 2018 14:25 by ADMIN
ADMIN
Created by: Rumen
Comments: 0
Category: UI for ASP.NET AJAX
Type: Bug Report
0
Below is my steps to find this issue:

1. Open the browser with IE 10 mode or genuine IE10.
2. Create a table with Editor.
3. Right click the table and then select table properties. Then click Table Layouts tab and select a style.
4. Click OK, the style can be kept this moment in Design tab.
5. Click HTML tab and find the CSS details are missing and click Design tab again, the style cannot be kept.
6. There is no reproduces with chrome or IE 11. 
7. I also test this case from your ow site https://demos.telerik.com/aspnet-ajax/editor/examples/overview/defaultcs.aspx


A video repro is also attached
1 2 3 4 5 6