Completed
Last Updated: 29 Jul 2019 07:48 by ADMIN

We are evaluating whether to use Telerik to redesign a legacy web app written using an old version of Telerik.

After downloading Trial version on fresh install of windows, I can't add ajax control to form. `I am using visual studio 2019, this is the first version of Telerik installed on this computer.  I just get the "Error Creating Control RadScriptManager1. They do show up in the toolbox so this surprises me.

Very latest version.

7/28/2019

Could it be a license issue?

Completed
Last Updated: 14 Aug 2019 12:34 by ADMIN
Created by: Chris Dalessandri
Comments: 3
Category: UI for ASP.NET AJAX
Type: Bug Report
0

Reproduction steps:

Go to the Telerik demo at https://demos.telerik.com/aspnet-ajax/textbox/overview/defaultcs.aspx
In the Comment box, type "one two".  Do not let the textbox lose focus.
Highlight "two" and start to drag it to move it before "one". The other text ("one") will disappear, and is gone forever, as far as I can tell.

It can be also reproduced with this configuration:

<telerik:RadTextBox RenderMode="Lightweight" runat="server" ID="RadTextBox3" Width="200px" EmptyMessage="Enter comment" TextMode="MultiLine" Height="100px" Resize="None"></telerik:RadTextBox>

Completed
Last Updated: 16 May 2019 15:54 by ADMIN
Created by: Sergey
Comments: 1
Category: UI for ASP.NET AJAX
Type: Bug Report
3

Hello,

There seems to be a bug with the RadEditor "Find and Replace" feature. I have recorded a screencast available here documenting the issue and will also provide below the information written: https://www.screencast.com/t/MXFawxIPp

Reproduction Steps:

Expected: '<img' is replaced with '<picture'

Actual:'<img' is replaced with '&lt;picture'

Notes:This seems to be an issue with encoding as &lt; is a less than tag. As you can see in the video, I do not think there is a way to escape the character to allow it to be replaced correctly. If you have additional questions, please ask.

 

Best Regards

Completed
Last Updated: 09 Apr 2019 13:40 by ADMIN
Created by: Anne
Comments: 1
Category: UI for ASP.NET AJAX
Type: Bug Report
0
Completed
Last Updated: 11 Apr 2019 08:13 by ADMIN

I have a problem with the deletecommand of the asp.net radgrid control (Telerik.Web.UI 2019.1.215.40).

This happens only in the latest release of Chrome.

I hope you can replicate this issue and eventually fix it. 

Completed
Last Updated: 10 Apr 2019 15:26 by ADMIN
When the ribbon bar is set to RibbonBarFloating, RibbonBarPageTop or RibbonBarShowOnFocus the menus cut off so you can't access menu items that would be displayed below bounds of the ribbon bar.

You can see this happening at:

https://demos.telerik.com/aspnet-ajax/controls/examples/integration/ribbonbarandeditor/defaultcs.aspx?product=editor

I have also supplied a snip of the issue.
Completed
Last Updated: 27 Mar 2019 21:46 by ADMIN
After the alert was confirmed, a Post Back is expected which does not happen due to a JavaScript exception: Cannot read property 'toString' of null
Completed
Last Updated: 10 Apr 2019 15:28 by ADMIN
Bug introduced in build 2019.1.115+ causes 3 extra <p>&nbsp;</p> when user presses Enter key in FireFox.  Happens when Editor is in a Wizard with more than one step.  Bug does not occur in builds prior to 2019.1.115.

Try this to reproduce:

 <telerik:RadWizard runat="server" ID="rwMain" BorderStyle="Solid" BorderColor="LightGray" BorderWidth="1px" RenderMode="Lightweight" DisplayNavigationButtons="True">
        <WizardSteps>
            <telerik:RadWizardStep ID="RadWizardStep2" Title="Content Template" StepType="Step">
                <h1>hello!</h1>
            </telerik:RadWizardStep>
            <telerik:RadWizardStep ID="RadWizardStep3" Title="Content Editor" StepType="Step">
                <telerik:RadEditor ID="ContentEditor" runat="server" RenderMode="Lightweight"></telerik:RadEditor>
            </telerik:RadWizardStep>
        </WizardSteps>
    </telerik:RadWizard>
Completed
Last Updated: 10 Apr 2019 15:41 by ADMIN

This can be reproduced with the following sample:

<telerik:RadWindow runat="server" ID="RadWindowWithEditor" Height="1000px" OnClientShow="fixEditor"
 
    OpenerElementID="Button5">
    <ContentTemplate>
        <telerik:RadEditor RenderMode="Lightweight" runat="server" ID="RadEditor1" Width="700px" Height="700px">
            <Content>
Lorem ipsum dolor sit amet
            </Content>
        </telerik:RadEditor>
    </ContentTemplate>
</telerik:RadWindow>
<asp:Button ID="Button5" Text="open the RadWindow" runat="server" />
<script type="text/javascript">
    function fixEditor() {
        setTimeout(function () {
            $find("<%=RadEditor1.ClientID %>").onParentNodeChanged();
        }, 100);
    }
</script>

 

Completed
Last Updated: 27 Feb 2019 08:52 by Marin
Completed
Last Updated: 20 Mar 2019 15:28 by ADMIN
Created by: MailUp Dev
Comments: 5
Category: UI for ASP.NET AJAX
Type: Bug Report
0
Using Firefox 64.0,  selecting an image doesn't appear the resizing handles which are located on each corner of the object
Completed
Last Updated: 20 Dec 2018 14:19 by ADMIN
Created by: Vinson
Comments: 1
Category: UI for ASP.NET AJAX
Type: Bug Report
0
When I try to replace a white space in RadEditor, it is able to replace the words at the first line. The second one and onwards are not able to replace.

Step:

1. Open 'Find And Replace' dialog.

2. Go to 'Replace' tab.

3. Enter a white space for 'Find' text box.

4. Enter any character or word for 'Replace With' text box.

5. Hit on 'Replace All' button.

Reproducible in content which contains table elements and in the live demo: https://demos.telerik.com/aspnet-ajax/editor/examples/overview/defaultcs.aspx
Completed
Last Updated: 11 Feb 2019 10:08 by ADMIN
ADMIN
Created by: Rumen
Comments: 3
Category: UI for ASP.NET AJAX
Type: Bug Report
0
I'm using couple of Rad Editor controls in my webpart and using ToolProviderID for performance optimization.
I'm initializing one rad editor toolbar from server side and using the same toolbar to provide other rad editors with their toolbar, Bascially I'm using ToolProviderID attribute to initialize other RadEditors, after doing this the Comments and Track Changes feature stop working although their options are selected in the toolbar.


<telerik:RadEditor RenderMode="Lightweight" runat="server" ID="RadEditor1" EnableTrackChanges="true" EnableComments="true">
    <TrackChangesSettings Author="AuthorName" CanAcceptTrackChanges="true" UserCssId="reU0" />
    <Tools>
        <telerik:EditorToolGroup>
            <telerik:EditorTool Name="AcceptTrackChange" />
            <telerik:EditorTool Name="RejectTrackChange" />
            <telerik:EditorTool Name="AcceptAllTrackChanges" />
            <telerik:EditorTool Name="RejectAllTrackChanges" />
            <telerik:EditorTool Name="EnableTrackChangesOverride" />
        </telerik:EditorToolGroup>
    </Tools>
</telerik:RadEditor>
<telerik:RadEditor ID="RadEditor2" runat="server" ToolProviderID="RadEditor1" EnableTrackChanges="true" EnableComments="true"></telerik:RadEditor>
<telerik:RadEditor ID="RadEditor3" runat="server" ToolProviderID="RadEditor1" EnableTrackChanges="true" EnableComments="true"></telerik:RadEditor>
Completed
Last Updated: 05 Nov 2018 08:54 by Smit
After having a filter applied, filter value is not cleared when FilterOption was set to "NoFilter".


The following client-side logic would clear the textbox values before the filtering is applied if filter options are set to "NoFilter"

            function onCommand(sender, args) {
                if (args.get_commandName() == "HeaderContextMenuFilter") {
                    var firstTextBox = $("[id$='HCFMRTBFirstCond']")[0].control;
                    var firstFilterOption = args.get_commandArgument().split("|")[1];

                    var secondTextBox = $("[id$='HCFMRTBSecondCond']")[0].control;
                    var secondFilterOption = args.get_commandArgument().split("|")[3];

                    if (firstFilterOption.includes("NoFilter") && firstTextBox.get_value() != "") {
                        args.set_cancel(true);
                        var value = firstTextBox.get_value();
                        firstTextBox.clear();
                        var newArg = args.get_commandArgument().replace("|" + value + "|?", "||?");
                        args.get_tableView().fireCommand(args.get_commandName(), newArg);
                    }

                    if (secondFilterOption.includes("NoFilter") && secondTextBox.get_value() != "") {
                        args.set_cancel(true);
                        var value = firstTextBox.get_value();
                        secondTextBox.clear();
                        var newArg = args.get_commandArgument().replace("|" + value + "|?", "||?");
                        args.get_tableView().fireCommand(args.get_commandName(), newArg);
                    }
                }
            }
Completed
Last Updated: 08 Nov 2018 15:00 by ADMIN
The ContextMenu popup is not position properly relative to its target element when the page is horizontally scrolled in Edge. The problem is reproducible with R2 2018.

Steps tp reproduce:
1. Run the code below and scroll the page to the right
2. Right click over a number


<!DOCTYPE html>

<html xmlns="http://www.w3.org/1999/xhtml">
<head runat="server">
    <title></title>
</head>
<body>
    <form id="form1" runat="server">
        <telerik:RadScriptManager ID="RadScriptManager1" runat="server">
        </telerik:RadScriptManager>
        <telerik:RadContextMenu ID="rcmMenu" runat="server">
            <Targets>
                <telerik:ContextMenuTagNameTarget TagName="a" />
            </Targets>
            <Items>
                <telerik:RadMenuItem Text="Menu Item 1" Value="a" />
                <telerik:RadMenuItem Text="Menu Item 2" Value="b" />
            </Items>
        </telerik:RadContextMenu>
        <div style="width: 3500px; height: 100px; position: relative; background-color: yellow;">
            <a style="position: absolute; left: 1000px; top: 40px;" onclick="return showMenu(event);">1000</a>
            <a style="position: absolute; left: 2000px; top: 40px;" onclick="return showMenu(event);">2000</a>
            <a style="position: absolute; left: 3000px; top: 40px;" onclick="return showMenu(event);">3000</a>
        </div>
    </form>
</body>
</html>


Completed
Last Updated: 14 Jun 2018 11:21 by ADMIN
Workaround: Use the following styles

html .RadGrid_Windows7 .rgSave,
html .RadGrid_Windows7 .rgAdd,
html .RadGrid_Windows7 .rgRefresh,
html .RadGrid_Windows7 .rgEdit,
html .RadGrid_Windows7 .rgDel,
html .RadGrid_Windows7 .rgFilter,
html .RadGrid_Windows7 .rgPagePrev,
html .RadGrid_Windows7 .rgPageNext,
html .RadGrid_Windows7 .rgPageFirst,
html .RadGrid_Windows7 .rgPageLast,
html .RadGrid_Windows7 .rgExpand,
html .RadGrid_Windows7 .rgCollapse,
html .RadGrid_Windows7 .rgSortAsc,
html .RadGrid_Windows7 .rgSortDesc,
html .RadGrid_Windows7 .rgUpdate,
html .RadGrid_Windows7 .rgCancel,
html .RadGrid_Windows7 .rgUngroup,
html .RadGrid_Windows7 .rgExpXLS,
html .RadGrid_Windows7 .rgExpDOC,
html .RadGrid_Windows7 .rgExpPDF,
html .RadGrid_Windows7 .rgExpCSV {
    background-image: none;
}

html .RadGrid_Windows7 th.rgSorted {
        background-image: none;
}

html .RadGrid_Windows7 .rgMasterTable .rgSelectedCell,
html .RadGrid_Windows7 .rgSelectedRow {
        background-image: none;
}

html .RadGrid_Windows7 .rgMasterTable .rgActiveCell,
html .RadGrid_Windows7 .rgActiveRow,
html .RadGrid_Windows7 .rgHoveredRow {
           
        background-image: none;
}

html .RadGrid_Windows7 .rgEditRow {
        background-image: none;
}

html .RadGrid_Windows7 .rgPager {
    background-image: none;
}

    html .RadGrid_Windows7 .rgPager .rgPagerButton {
            background-image: none;
    }

html .RadGrid_Windows7 .rgNumPart a:hover,
html .RadGrid_Windows7 .rgNumPart a.rgCurrentPage {
        background-image: none;
}

    html .RadGrid_Windows7 .rgNumPart a:hover span,
    html .RadGrid_Windows7 .rgNumPart a.rgCurrentPage span {
            background-image: none;
    }

html .GridReorderTop_Windows7 {
    background-image: none;
}

html .GridReorderBottom_Windows7 {
    background-image: none;
}

html .RadGrid_Windows7 .rgGroupPanel {
    background-image: none;
}

html .RadGrid_Windows7 .rgGroupItem {
        background-image: none;
}

html .RadGrid_Windows7 .rgGroupHeader {
    background-image: none;
}

html .RadGrid_Windows7 .rgCommandRow {
    background-image: none;
}
Completed
Last Updated: 27 Sep 2018 15:14 by ADMIN
ADMIN
Created by: Rumen
Comments: 0
Category: UI for ASP.NET AJAX
Type: Bug Report
1
I am seeing a strange problem when opening LinkManager dialog from RadEditor. The width of the dialog keeps decreasing on successive opening of the dialog. Sample page code to reproduce this is given below.
You can see a video of this issue at think URL : https://goo.gl/UuPwtA    
Sample page code (code-behind is empty)

<%@ Page Language="C#" AutoEventWireup="true"%>

<!DOCTYPE html PUBLIC "-//W3C//DTD XHTML 1.0 Transitional//EN" "http://www.w3.org/TR/xhtml1/DTD/xhtml1-transitional.dtd">

<html xmlns="http://www.w3.org/1999/xhtml">
<head runat="server">
    <title></title>
    <telerik:RadStyleSheetManager ID="RadStyleSheetManager1" runat="server" />
</head>
<body>
    <form id="form1" runat="server">
        <telerik:RadScriptManager ID="RadScriptManager1" runat="server">
        </telerik:RadScriptManager>
        <div>
            <telerik:RadEditor ID="RadEditor1" runat="server" ToolbarMode="Default" RenderMode="Lightweight"  Skin="Metro"></telerik:RadEditor>
        </div>
    </form>
</body>
</html>

Reproducible in every browser.
Completed
Last Updated: 04 Dec 2017 09:54 by Анатолій
ADMIN
Created by: Rumen
Comments: 3
Category: UI for ASP.NET AJAX
Type: Bug Report
5
Problem:

With the latest version of Chrome 61 the context menu is not positioning correctly in the treeview. It only happens when the treeview is longer than the window height and there are scrollbars. The EnableScreenBoundaryDetection should be enabled too (it is enabled by default).

Reproduction: see this video for a repro https://www.screencast.com/t/Reehai09gMP. The problem does not happen in the Chrome versions prior 61.

Details and Resolution: 

The context menu positioning problem is due to the following breaking change in Chrome 61 (see release notes at https://blog.chromium.org/2017/08/chrome-61-beta-javascript-modules.html):

To align with the spec and preserve browser consistency, the scrollingElement is now the documentElement in standards mode.
Chrome 61 has changed the behavior of document.scrollingElement to return document.documentElement instead of document.body to match the CSSOM View specification and this broke the positioning of the context menu when the EnableScreenBoundaryDetection is enabled.

Solution 1
Place the following override over the RadTreeView declaration:

<script>
Telerik.Web.UI.RadMenu._getViewPortSize = function () {
        var viewPortSize = $telerik.getViewPortSize();
  
        // The document scroll is not included in the viewport size
        // calculation under FF/quirks and Edge.     
        var quirksMode = document.compatMode != "CSS1Compat";
        if (($telerik.isFirefox && quirksMode) || Telerik.Web.Browser.edge) {
            viewPortSize.height += document.body.scrollTop;
            viewPortSize.width += document.body.scrollLeft;
        }
        else if (Telerik.Web.Browser.chrome) {
            viewPortSize.height += Math.max(document.body.scrollTop, document.scrollingElement.scrollTop);
            viewPortSize.width += Math.max(document.body.scrollLeft, document.scrollingElement.scrollLeft);
        }
  
        return viewPortSize;
    };
</script>
<telerik:RadTreeView RenderMode="Lightweight" ID="RadTreeView2" runat="server">
    <ContextMenus>
        <telerik:RadTreeViewContextMenu ID="RadTreeViewContextMenu1"runat="server"  RenderMode="Lightweight">
            <Items>
                ...


Solution 2
Set EnableScreenBoundaryDetection to false. This will disable the screen boundary detection and some parts of the context menu could be rendered beneath the browser borders when there isn't enough space to be rendered on the visible screen. You will have to use the browser scrollbars to show the hidden part of the menu.

The issue is scheduled for fixing in R3 2017 SP1, the release date of which is not yet decided. Please use the provided solutions above until the SP1 goes out officially.
Completed
Last Updated: 11 Apr 2018 10:52 by ADMIN
Javascript errors are thrown when pie chart with custom skin is loaded. The issue is introduced as of version 2017.1.118.

Code to reproduce:
        <telerik:RadHtmlChart ID="Telerik1" runat="server" Height="250px" Width="250px" EnableEmbeddedSkins="false" Skin="CMS_Black">
            <ChartTitle Text="Financial Aid Status1112">
                <Appearance>
                    <TextStyle Color="Red" FontSize="12" FontFamily="Verdana" Margin="11" Padding="22"></TextStyle>
                </Appearance>
            </ChartTitle>
            <PlotArea>
                <Series>
                    <telerik:PieSeries Name="TypeMemberCount1" NameField="Name" DataFieldY="Value">
                        <LabelsAppearance>
                            <ClientTemplate>
                               #=dataItem.Name#: #=dataItem._Value# (#=dataItem._Percentage#%)
                            </ClientTemplate>
                        </LabelsAppearance>
                    </telerik:PieSeries>
                </Series>
            </PlotArea>
            <Legend>
                <Appearance Position="Right" Visible="true">
                </Appearance>
            </Legend>
        </telerik:RadHtmlChart>


Code bihind:

    protected void Page_Load(object sender, EventArgs e)
    {
        Telerik1.DataSource = GetData();
        Telerik1.DataBind();

    }
    private DataTable GetData()
    {
        DataTable dt = new DataTable("ChargeData");
        
        dt.Columns.Add("Id", Type.GetType("System.Int32"));

        dt.Columns.Add("Name", Type.GetType("System.String"));
        dt.Columns.Add("Value", Type.GetType("System.Int32"));
        dt.Columns.Add("_Value", Type.GetType("System.Int32"));
        dt.Columns.Add("_Percentage", Type.GetType("System.Int32"));

        dt.Rows.Add(1, "Item 1", 10, 34, 10);
        dt.Rows.Add(2, "Item 2", 65, 34, 65);
        dt.Rows.Add(3, "Item 3", 25, 34, 25);
        return dt;
    }


web.config:

    <add key="Telerik.Skin" value="CMS_Black"/>

Ticket 1113172 
1 2 3 4 5 6