Approved
Last Updated: 28 Mar 2019 15:05 by ADMIN
When you have 3 documents with picture, and texts in all - the texts are shows as expected. but when one of them does not have text and title, the loop of the gallery stop showing it for the other pictures.

<telerik:RadImageGallery ID="RadImageGallery1" runat="server">
    <ThumbnailsAreaSettings ThumbnailWidth="140px" Width="140px" Position="Left" ScrollOrientation="Vertical" />
    <Items>
        <telerik:ImageGalleryItem ImageUrl="Images/Yoga.jpg" Title="Title 1" />
        <telerik:ImageGalleryItem ImageUrl="Images/Swimming.jpg" Title="Title 2" />

            <%-- Title container disappears here and will not show up with the rest of the items --%>
        <telerik:ImageGalleryItem ImageUrl="Images/Surfing.jpg" /> 

        <telerik:ImageGalleryItem ImageUrl="Images/Snowboarding.jpg" Title="Title 4" />
        <telerik:ImageGalleryItem ImageUrl="Images/Skiing.jpg" Title="Title 5" />
    </Items>
</telerik:RadImageGallery>
Approved
Last Updated: 25 Oct 2017 17:47 by Gregory
ADMIN
Created by: Rumen
Comments: 2
Category: ImageGallery
Type: Bug Report
1
Slideshow rendering messed up in Chrome. After any slide comes in a segment the right side is corrupted as shown in the attached image.

The bug is reproduced if you set the animation to loop and fire the play button. After that leave the slider to work non-stop for 10-15 minutes and you'll see the corrupted rendering.

Here is some test code:
  <telerik:RadImageGallery  ID="RadImageGallery1" Width="100%" LoopItems="true" 
                                    ImagesFolderPath="slides" runat="server" DisplayAreaMode="Image" Height="450px">
                                    <ClientSettings>
                                        <AnimationSettings   SlideshowSlideDuration="6000">
                                            <NextImagesAnimation Type="Random" Easing="Random"  Speed="3000" />
                                            <PrevImagesAnimation Type="Random" Easing="Random" Speed="3000" />
                                        </AnimationSettings>
                                    </ClientSettings>
                                    <ThumbnailsAreaSettings Position="Left" Width="0" Mode="ImageSlider" ScrollOrientation="Vertical" />
                                    <ImageAreaSettings ShowDescriptionBox="false" NavigationMode="Zone" Height="100%" />
 </telerik:RadImageGallery>
Completed
Last Updated: 19 Mar 2019 14:23 by ADMIN
ADMIN
Created by: Peter Milchev
Comments: 0
Category: ImageGallery
Type: Bug Report
0

			
Approved
Last Updated: 24 Feb 2016 14:25 by ADMIN
Completed
Last Updated: 16 Jul 2015 07:51 by ADMIN
ADMIN
Created by: Angel Petrov
Comments: 0
Category: ImageGallery
Type: Bug Report
0

			
Completed
Last Updated: 16 Jul 2015 07:52 by ADMIN
ADMIN
Created by: Angel Petrov
Comments: 0
Category: ImageGallery
Type: Bug Report
0

			
Completed
Last Updated: 26 May 2015 08:46 by ADMIN
The ClientImageLoaded client-side event doesn't fire for the first loaded image when DisplayAreaMode="Image".

The issue can be reproduced for the following configuration:

        <telerik:RadImageGallery runat="server" Width="600px" Height="480px" DisplayAreaMode="Image">
            <ClientSettings>
                <ClientEvents OnImageLoaded="imageLoaded" />
            </ClientSettings>
            <ThumbnailsAreaSettings ThumbnailWidth="140px" Width="140px" Position="Left" ScrollOrientation="Vertical" />
            <Items>
                <telerik:ImageGalleryItem ImageUrl="images/Image1.png"/>
                <telerik:ImageGalleryItem ImageUrl="images/Image2.png" />
                <telerik:ImageGalleryItem ImageUrl="images/Image3.png" />
                <telerik:ImageGalleryItem ImageUrl="images/Image4.png" />
            </Items>
        </telerik:RadImageGallery>
        <script>
            function imageLoaded(imageGallery, args) {
                alert(args.get_image().src);
            }

        </script>
Completed
Last Updated: 22 Jun 2015 13:57 by ADMIN
Completed
Last Updated: 12 May 2015 13:21 by ADMIN
Approved
Last Updated: 15 Apr 2015 09:30 by ADMIN
Completed
Last Updated: 16 Jul 2015 08:39 by ADMIN
Completed
Last Updated: 23 Jun 2014 06:42 by ADMIN
Completed
Last Updated: 08 Apr 2014 10:15 by ADMIN