Completed
Last Updated: 02 Sep 2019 15:28 by ADMIN
Created by: Joao
Comments: 1
Category: DropDownTree
Type: Feature Request
0
Cannot add a label to a RadDropDownTree
Completed
Last Updated: 03 Sep 2019 16:13 by ADMIN
Release R3 2019
Created by: Sunil Sutar
Comments: 2
Category: TabStrip
Type: Bug Report
1

Hi Telerik team,

 

Few of our clients reported the following issue with respect to WCAG 2.0 SC 4.1.2 standard. (508 Standard and compliance) -

PracticeFunction (example)
Ensure ARIA roles, states, and properties are validLI has an aria-level attribute of 0, which is not an integer value greater than, or equal to, 1

 

Example: visit https://demos.telerik.com/aspnet-ajax/tabstrip/examples/wai-aria-support/defaultcs.aspx 

 

Observe the ul-li elements created for tabstrip. On each li element, there is aria-level attribute whose value is set to 0.

As per WCAG this value should start from 1. The value 0 is invalid. Refer: https://www.w3.org/TR/WCAG20-TECHS/ARIA12.html

 

Please let me know when are you going to fix this for compliance. 

--

Sunil

Completed
Last Updated: 14 Aug 2019 12:34 by ADMIN
Created by: Chris Dalessandri
Comments: 3
Category: UI for ASP.NET AJAX
Type: Bug Report
0

Reproduction steps:

Go to the Telerik demo at https://demos.telerik.com/aspnet-ajax/textbox/overview/defaultcs.aspx
In the Comment box, type "one two".  Do not let the textbox lose focus.
Highlight "two" and start to drag it to move it before "one". The other text ("one") will disappear, and is gone forever, as far as I can tell.

It can be also reproduced with this configuration:

<telerik:RadTextBox RenderMode="Lightweight" runat="server" ID="RadTextBox3" Width="200px" EmptyMessage="Enter comment" TextMode="MultiLine" Height="100px" Resize="None"></telerik:RadTextBox>

Completed
Last Updated: 16 May 2019 15:54 by ADMIN
Created by: Sergey
Comments: 1
Category: UI for ASP.NET AJAX
Type: Bug Report
3

Hello,

There seems to be a bug with the RadEditor "Find and Replace" feature. I have recorded a screencast available here documenting the issue and will also provide below the information written: https://www.screencast.com/t/MXFawxIPp

Reproduction Steps:

Expected: '<img' is replaced with '<picture'

Actual:'<img' is replaced with '&lt;picture'

Notes:This seems to be an issue with encoding as &lt; is a less than tag. As you can see in the video, I do not think there is a way to escape the character to allow it to be replaced correctly. If you have additional questions, please ask.

 

Best Regards

Completed
Last Updated: 18 Apr 2019 11:21 by ADMIN
Code snippets coming after remove table style from insert table popup in chrome,ie,ff.

I am facing a big problem in editor please give any solution.

Link: https://demos.telerik.com/aspnet-ajax/editor/examples/overview/defaultcs.aspx

Steps to reproduce

Step 1

Try to insert table from Insert Table from editor toolbar.

Step 2

Right click on cell then click on Table/cell properties. A table wizard popup will come.

Step 3

Click on Table Layouts tab on the table wizard popup.

Step 4

Select any value from table styles drop down.

Step 5

Now you can see  TABLE>TR>TD>RemoveElement on the bottom of the editor.click on RemoveElement .

After click on RemoveElement you can see STYLE>RemoveElement  again click on RemoveElement.

then you can see like below in the editor.

.telerik-reTable-2 { border-collapse: collapse; border: solid 0px; font-family: Tahoma; } .telerik-reTable-2 tr.telerik-reTableHeaderRow-2 { border-width: 1.0pt 1.0pt 3.0pt 1.0pt...........
Completed
Last Updated: 03 Oct 2019 15:11 by ADMIN
Hello guys,

 

We've faced an issue with menu on several RAD controls when running on MacOS 10.14.x (Mojave) with FireFox 66.0.x (Quantum).

Using touchpad or mouse, when right clicking for context menu, it just flashed and doesn't stay open: it opens and then suddenly closes.

We are using Telerik Asp.Net Ajax version 2017.2.503.40 but it can be also replicated on your demo version:

https://demos.telerik.com/aspnet-ajax/grid/examples/columns-rows/columns/context-menu/defaultcs.aspx

https://demos.telerik.com/aspnet-ajax/scheduler/examples/overview/defaultcs.aspx


Not sure if you can provide a fast workaround for this but I just wanted to let you know.

I've checked for some open cases before creating this thread and hope I didn't duplicate something. Please move/close it if necessary.

 

Regards,

Andrei V.
Completed
Last Updated: 02 Oct 2019 14:31 by ADMIN

When looking at MetroTouch (and other) skin on FF, Edge and Chrome we see a little discrepance in the stepper bar, see attached.

This will be solved when altering css like so:

.RadWizard .rwzBreadCrumb .rwzLink::before {

    right: -0.5em;}

original value is:

right: -0.6em;

 
Completed
Last Updated: 09 Apr 2019 13:17 by ADMIN
Created by: Aaron Main
Comments: 1
Category: Editor
Type: Bug Report
0
When you open the insert Table dialog window in the RadEditor using the Silk skin the layout is messed up.  Button text is wrapping and the text 'px' is wrapped under the input field.

You can see this happening in the following demo page.

https://demos.telerik.com/aspnet-ajax/controls/examples/integration/ribbonbarandeditor/defaultcs.aspx?product=editor

I have also attached a snip showing this.
Completed
Last Updated: 09 Apr 2019 13:40 by ADMIN
Created by: Anne
Comments: 1
Category: UI for ASP.NET AJAX
Type: Bug Report
0
Completed
Last Updated: 11 Apr 2019 08:13 by ADMIN

I have a problem with the deletecommand of the asp.net radgrid control (Telerik.Web.UI 2019.1.215.40).

This happens only in the latest release of Chrome.

I hope you can replicate this issue and eventually fix it. 

Completed
Last Updated: 10 Apr 2019 15:26 by ADMIN
When the ribbon bar is set to RibbonBarFloating, RibbonBarPageTop or RibbonBarShowOnFocus the menus cut off so you can't access menu items that would be displayed below bounds of the ribbon bar.

You can see this happening at:

https://demos.telerik.com/aspnet-ajax/controls/examples/integration/ribbonbarandeditor/defaultcs.aspx?product=editor

I have also supplied a snip of the issue.
Completed
Last Updated: 02 Apr 2019 14:15 by ADMIN
Created by: Scott
Comments: 1
Category: UI for ASP.NET AJAX
Type: Feature Request
0

Hi,

 

Trying to use a web testing tool (Selenium) and using xpath is not always working.  I was wondering if it would be possible to always add an ID property to controls, especially in drop downs etc. so that it can clicked properly.

Completed
Last Updated: 26 Mar 2019 14:50 by ADMIN
Created by: miksh
Comments: 1
Category: Input
Type: Bug Report
0
Change value by mousewheel does not work in Edge (Microsoft Edge 44.17763.1.0, Microsoft EdgeHTML 18.17763), Chrome is ok
try here:

https://demos.telerik.com/aspnet-ajax/numerictextbox/overview/defaultcs.aspx
Completed
Last Updated: 10 Apr 2019 15:23 by ADMIN

After upgrading the Telerik controls to v2019.1.115.45 we are seeing an issue with the RadEditor control. The issue is that the Toolbar formatting buttons like Bold, Underline etc. do not work for a particular scenario.

Scenario

We have 2 tabs - Tab1 and Tab2. Tab1 is the default selected tab. Tab2 contains the RadEditor control. When the page loads, Tab1 is displayed/selected. We then go to Tab2 and click on the Toolbar to format the text. We click on buttons like Bold, Italic etc. but they do not work. Please refer to the files in the attached zip to see the issue.
<telerik:RadTabStrip runat="server" MultiPageID="MultiPage1" CausesValidation="false" SelectedIndex="1">
    <Tabs>
        <telerik:RadTab runat="server" Text="Tab1" Value="Tab1" PageViewID="Tab1" Selected="true" />
        <telerik:RadTab runat="server" Text="Tab2" Value="Tab2" PageViewID="Tab2" />
    </Tabs>
</telerik:RadTabStrip>
<telerik:RadMultiPage ID="MultiPage1" runat="server">
    <telerik:RadPageView ID="Tab1" runat="server" Selected="true">
        TAB 1 
    </telerik:RadPageView>
    <telerik:RadPageView ID="Tab2" runat="server">
        <telerik:RadEditor Width="100%" ID="ERichTextBox1" Enabled="true" runat="server" ContentAreaMode="Div" NewLineMode="Br">
        </telerik:RadEditor>
    </telerik:RadPageView>
</telerik:RadMultiPage>



Completed
Last Updated: 27 Mar 2019 21:46 by ADMIN
After the alert was confirmed, a Post Back is expected which does not happen due to a JavaScript exception: Cannot read property 'toString' of null
Completed
Last Updated: 10 Apr 2019 15:28 by ADMIN
Bug introduced in build 2019.1.115+ causes 3 extra <p>&nbsp;</p> when user presses Enter key in FireFox.  Happens when Editor is in a Wizard with more than one step.  Bug does not occur in builds prior to 2019.1.115.

Try this to reproduce:

 <telerik:RadWizard runat="server" ID="rwMain" BorderStyle="Solid" BorderColor="LightGray" BorderWidth="1px" RenderMode="Lightweight" DisplayNavigationButtons="True">
        <WizardSteps>
            <telerik:RadWizardStep ID="RadWizardStep2" Title="Content Template" StepType="Step">
                <h1>hello!</h1>
            </telerik:RadWizardStep>
            <telerik:RadWizardStep ID="RadWizardStep3" Title="Content Editor" StepType="Step">
                <telerik:RadEditor ID="ContentEditor" runat="server" RenderMode="Lightweight"></telerik:RadEditor>
            </telerik:RadWizardStep>
        </WizardSteps>
    </telerik:RadWizard>
Completed
Last Updated: 10 Apr 2019 15:41 by ADMIN

This can be reproduced with the following sample:

<telerik:RadWindow runat="server" ID="RadWindowWithEditor" Height="1000px" OnClientShow="fixEditor"
 
    OpenerElementID="Button5">
    <ContentTemplate>
        <telerik:RadEditor RenderMode="Lightweight" runat="server" ID="RadEditor1" Width="700px" Height="700px">
            <Content>
Lorem ipsum dolor sit amet
            </Content>
        </telerik:RadEditor>
    </ContentTemplate>
</telerik:RadWindow>
<asp:Button ID="Button5" Text="open the RadWindow" runat="server" />
<script type="text/javascript">
    function fixEditor() {
        setTimeout(function () {
            $find("<%=RadEditor1.ClientID %>").onParentNodeChanged();
        }, 100);
    }
</script>

 

Completed
Last Updated: 15 Mar 2019 08:33 by ADMIN
Created by: Alex Kapitanovskyy
Comments: 1
Category: AsyncUpload
Type: Bug Report
0
After the update from version 2018.2.710 to 2019.1.2015 the files bigger than 2 MB are cut off (up to 2 MB) and broken during the upload.
Completed
Last Updated: 18 Mar 2019 12:47 by ADMIN
We've a RadEditor controls, we want disable editting in mobile render mode. How can we do it?

Here examle:

Case 1. RadEditor is LightWeight:

<telerik:RadEditor ID="redEdt" runat="server"    RenderMode="LightWeight"     Width="100%" Height="500px" ></telerik:RadEditor>

<script>
                $(document).ready(function () {
                    var editor = $telerik.findControl(document.documentElement, "redEdt");
                    editor.enableEditing(false);
                })

</script>   

--> It work great. All buttons in toolbar disabled.

Case 2. RadEditor is Mobile:

<telerik:RadEditor ID="redEdt" runat="server"    RenderMode="Mobile"     Width="100%" Height="500px" ></telerik:RadEditor>

<script>
                $(document).ready(function () {
                    var editor = $telerik.findControl(document.documentElement, "redEdt");
                    editor.enableEditing(false);
                })

</script> 

--> System error: 

M.enableContextMenus is not a function
    at c.RadEditor.enableEditing
Completed
Last Updated: 08 Mar 2019 09:39 by ADMIN
When the ChunkSize of RadAsyncUpload is set the files are not fully uploaded. A sample excel file to reproduce the issue is attached to this reply.
Temporary fix:
Remove the ChunkSize setting of the AsyncUploade:

        <telerik:RadAsyncUpload ID="UploadFile" runat="server" MultipleFileSelection="Automatic"
            OverwriteExistingFiles="true" ReadOnlyFileInputs="true" InputSize="45" EnableViewState="true" TargetFolder="~/UploadedFiles">
        </telerik:RadAsyncUpload>

Steps to reproduce:

1. Run the following configuration and upload the attached to this item file
        <telerik:RadAsyncUpload ID="UploadFile" ClientIDMode="AutoID" runat="server" MultipleFileSelection="Automatic"
            OverwriteExistingFiles="true" ReadOnlyFileInputs="true" ChunkSize="3145728" InputSize="45" EnableViewState="true" TargetFolder="~/UploadedFiles">
        </telerik:RadAsyncUpload>
        <telerik:RadButton runat="server" Text="Upload"></telerik:RadButton>


Expected: An 11MB file is uploaded
Actual: An 8MB file is uploaded (the last chunk part is missing)