Completed
Last Updated: 18 Oct 2019 13:52 by ADMIN
Release R3 2019 SP1
Created by: Charles Liang
Comments: 0
Category: Editor
Type: Feature Request
0
Improve XSS filtering.
Approved
Last Updated: 21 Aug 2019 15:08 by ADMIN

When text in the Editor has Track Changes then :

  • There should be Next/Previous menu icons to navigate through the Track Changes from one Change to another
  • When a Tracked Change is Accepted/Rejected the cursor should move to the next Tracked Change
Completed
Last Updated: 31 Jul 2019 08:40 by ADMIN

The problem happens when enter a period . , single ' or " double quote on a new line.

Approved
Last Updated: 22 Jul 2019 13:37 by ADMIN
I am using the option AutoResizeHeight ="true" for the RadEditor. When I click on add comment option, the editor scrolls right at the end and displays the add comment window.

How can I set the position of the add comment window as per by requirement?
Completed
Last Updated: 02 Oct 2019 14:29 by ADMIN
Test the code below on iPhone and mobile chrome/safari and you'll get a JS error:

<script type="text/javascript">
    EditorCommandList = Telerik.Web.UI.Editor.CommandList;
    EditorCommandList["ApplySizeColor"] = function (commandName, editor, args) {
        if (editor.getSelectionHtml() != "") {
            editor.fire("FontSize", { value: "4" }); //fire the FontSize command
            editor.fire("ForeColor", { value: "red" });  //fire the ForeColor command
        }
        else {
            alert("Please, select some text!");
            args.set_cancel(true);
        }
    };
 </script>
<telerik:RadEditor ID="RadEditor1" runat="server" RenderMode="Auto" NewLineMode="Br" ContentAreaMode="Div" Height="500" Width="100%" Skin="Metro" _OnClientCommandExecuting="OnClientCommandExecuting">
    <HeaderTools>
        <telerik:EditorHeaderTool Name="ApplySizeColor" />
        <telerik:EditorHeaderTool Name="Redo" />
        <telerik:EditorHeaderTool Name="MobileEdit" Position="Right" />
        <telerik:EditorHeaderTool Name="ToggleScreenMode" Position="Right" />
    </HeaderTools>
    <Tools>
        <telerik:EditorToolGroup>
                <telerik:EditorTool Name="ApplySizeColor" Text="Apply Size and Color" ShowText="true"></telerik:EditorTool>
        </telerik:EditorToolGroup>
    </Tools>
</telerik:RadEditor>
Approved
Last Updated: 05 Jun 2019 14:44 by ADMIN
Created by: pranav
Comments: 0
Category: Editor
Type: Bug Report
0
The dopdowns of the tools in the Editor's toolbar are shown below the video objects in the Editor's content area in IE 11.

Video: https://www.screencast.com/t/rzmzuZ0UFa

Steps to reproduce:

1. Open in IE 11: https://demos.telerik.com/aspnet-ajax/editor/examples/overview/defaultcs.aspx

2.  Insert a video through the Media Manager

3. Click over a tool having a drop-down menu (e.g. the Format tool)

Result: The heavy-weight object of the video is shown above the shown drop-down menu.

Completed
Last Updated: 18 Apr 2019 11:21 by ADMIN
Code snippets coming after remove table style from insert table popup in chrome,ie,ff.

I am facing a big problem in editor please give any solution.

Link: https://demos.telerik.com/aspnet-ajax/editor/examples/overview/defaultcs.aspx

Steps to reproduce

Step 1

Try to insert table from Insert Table from editor toolbar.

Step 2

Right click on cell then click on Table/cell properties. A table wizard popup will come.

Step 3

Click on Table Layouts tab on the table wizard popup.

Step 4

Select any value from table styles drop down.

Step 5

Now you can see  TABLE>TR>TD>RemoveElement on the bottom of the editor.click on RemoveElement .

After click on RemoveElement you can see STYLE>RemoveElement  again click on RemoveElement.

then you can see like below in the editor.

.telerik-reTable-2 { border-collapse: collapse; border: solid 0px; font-family: Tahoma; } .telerik-reTable-2 tr.telerik-reTableHeaderRow-2 { border-width: 1.0pt 1.0pt 3.0pt 1.0pt...........
Completed
Last Updated: 09 Apr 2019 13:17 by ADMIN
Created by: Aaron Main
Comments: 1
Category: Editor
Type: Bug Report
0
When you open the insert Table dialog window in the RadEditor using the Silk skin the layout is messed up.  Button text is wrapping and the text 'px' is wrapped under the input field.

You can see this happening in the following demo page.

https://demos.telerik.com/aspnet-ajax/controls/examples/integration/ribbonbarandeditor/defaultcs.aspx?product=editor

I have also attached a snip showing this.
Completed
Last Updated: 10 Apr 2019 15:23 by ADMIN

After upgrading the Telerik controls to v2019.1.115.45 we are seeing an issue with the RadEditor control. The issue is that the Toolbar formatting buttons like Bold, Underline etc. do not work for a particular scenario.

Scenario

We have 2 tabs - Tab1 and Tab2. Tab1 is the default selected tab. Tab2 contains the RadEditor control. When the page loads, Tab1 is displayed/selected. We then go to Tab2 and click on the Toolbar to format the text. We click on buttons like Bold, Italic etc. but they do not work. Please refer to the files in the attached zip to see the issue.
<telerik:RadTabStrip runat="server" MultiPageID="MultiPage1" CausesValidation="false" SelectedIndex="1">
    <Tabs>
        <telerik:RadTab runat="server" Text="Tab1" Value="Tab1" PageViewID="Tab1" Selected="true" />
        <telerik:RadTab runat="server" Text="Tab2" Value="Tab2" PageViewID="Tab2" />
    </Tabs>
</telerik:RadTabStrip>
<telerik:RadMultiPage ID="MultiPage1" runat="server">
    <telerik:RadPageView ID="Tab1" runat="server" Selected="true">
        TAB 1 
    </telerik:RadPageView>
    <telerik:RadPageView ID="Tab2" runat="server">
        <telerik:RadEditor Width="100%" ID="ERichTextBox1" Enabled="true" runat="server" ContentAreaMode="Div" NewLineMode="Br">
        </telerik:RadEditor>
    </telerik:RadPageView>
</telerik:RadMultiPage>



Completed
Last Updated: 18 Mar 2019 12:47 by ADMIN
We've a RadEditor controls, we want disable editting in mobile render mode. How can we do it?

Here examle:

Case 1. RadEditor is LightWeight:

<telerik:RadEditor ID="redEdt" runat="server"    RenderMode="LightWeight"     Width="100%" Height="500px" ></telerik:RadEditor>

<script>
                $(document).ready(function () {
                    var editor = $telerik.findControl(document.documentElement, "redEdt");
                    editor.enableEditing(false);
                })

</script>   

--> It work great. All buttons in toolbar disabled.

Case 2. RadEditor is Mobile:

<telerik:RadEditor ID="redEdt" runat="server"    RenderMode="Mobile"     Width="100%" Height="500px" ></telerik:RadEditor>

<script>
                $(document).ready(function () {
                    var editor = $telerik.findControl(document.documentElement, "redEdt");
                    editor.enableEditing(false);
                })

</script> 

--> System error: 

M.enableContextMenus is not a function
    at c.RadEditor.enableEditing
Approved
Last Updated: 06 Mar 2019 15:22 by ADMIN

This behavior is occuring only if use firefox browser:

1. If you set the EditModes within backend only to EditMode.Preview then all html table elements within content appears like in EditMode.Design with dashed borders.

You can reproduce it on your own demo site https://demos.telerik.com/aspnet-ajax/editor/examples/overview/defaultcs.aspx simple disable EditMode.Html and EditMode.Design.

Now you see the dashed table element borders like in design mode....

2. Sometimes if you switch edit mode from Html to Preview the same affect is occuring with displaying dashed border with html table elements. If you switch directly from Design mode to preview mode all works fine.

3. If you resize the editor in preview mode with resize button on right lower corner the display switch immediatly to dashed borders for all html table elements...

At the moment we use a fix to reset preview mode: If only preview mode is activated for the editor we set the preview mode again with a timeout of 250 ms after loading of dialog is ready (if the timeout is to low no affect appear).
Sys.Application.add_load(function(){ window.setTimeout(function(){$find('AjaxEditorClientID').set_mode(4)},250); }); });

Regards
Thomas

Approved
Last Updated: 27 Feb 2019 14:05 by ADMIN

Reproduction steps: 

<telerik:RadEditor runat="server" ID="RadEditor1">
     <Content>
        <span style="color: #548dd4;">asdas</span>this is sample text
     </Content>
</telerik:RadEditor>

When the mode is changed to HTML, the content is as follows: 

Expected: 

<span style="color: #548dd4;">asdas</span>this is sample text

Actual: 

<span style="color: rgb(84, 141, 212);">asdas</span>this is sample text

 

Completed
Last Updated: 29 Mar 2019 12:44 by ADMIN
Created by: Victor
Comments: 15
Category: Editor
Type: Bug Report
0

Hello,

The RadEditor's Design View became unusable in the latest Chrome Beta version (Version 73.0.3683.27). It is still working correctly on the latest stable Chrome 72, so I'm not sure if it is a problem that needs to be resolved on Chrome's end, just figured it'll be helpful to send this in as well. 

The HTML view still works, but switching back to Design causes an exception (attached). This is also directly off of the demo page, so it doesn't look like implementation is a factor. 

Won't Fix
Last Updated: 20 Mar 2019 15:54 by ADMIN

When editing certain HTML layouts in a RadEditor on a Mac, when you right-click on the empty space to the right of the text content in a table cell inside a nested table, then click Row -> Insert Row Above, the editor inserts a row above the current row in one of the parent tables, instead of in the table containing the specific cell that was clicked on.

To reproduce, paste the following code into the HTML view of a RadEditor. Then switch to Design mode, and right click in the empty space to the right of the text "Type your message here!", but within the same table cell as that text. Select Row -> Insert Row Above, and see that the editor inserts a row into the wrong table.

This is only reproducible on a Mac, but it has been confirmed to happen in both Safari and Chrome.

The project this is for is currently using version 2016.3.1027, however I've pasted this code into the Telerik RadEditor demo at https://demos.telerik.com/aspnet-ajax/editor/examples/overview/defaultcs.aspx , which I presume is running the latest version, and the problem is reproducible there also.

 

<!DOCTYPE html>
<html>
    <head>
        <meta content="text/html; charset=UTF-8" http-equiv="Content-Type" />
        <meta content="width=device-width" name="viewport" />
        <title>Newsletter from your Pro</title>
        <style type="text/css">
            <!--
	
	-->
        </style>
    </head>
    <body>
        <table style="background-color: #C9CAC8 ;" cellspacing="0" cellpadding="0" border="0" width="100%">
            <tbody>
                <tr>
                    <td>
                    <table style="border-collapse: collapse; mso-table-lspace: 0pt; mso-table-rspace: 0pt; font-family: Gotham, 'Helvetica Neue', Helvetica, Arial, sans-serif;" class="body" cellspacing="0" cellpadding="0" align="center" border="0" width="640">
                        <tbody>
                            <tr>
                                <td style="background-color: #ffffff; height: 60px;" class="side-pad" colspan="6" align="center"><span style="text-align: center;" class="devicewidthinner"></span></td>
                                <td style="background-color: #ffffff; height: 60px;" class="side-pad" align="center"><span style="font-size: 14px; font-family: Helvetica, Arial, sans-serif; color: #63666a;">February 5, 2019</span></td>
                            </tr>
                            <tr>
                                <td style="background-color: #ffffff; height: 87px;" class="side-pad" colspan="6" align="center"><span class="devicewidth"></span></td>
                                <td style="background-color: #ffffff;" class="side-pad" align="center"></td>
                            </tr>
                            <tr>
                                <td style="background-color: #d55c19; width: 201px; height: 30px;" class="side-pad" align="center"><span style="text-align: center; font-weight: normal; line-height: 24px; font-family: Helvetica, Arial, sans-serif; font-size: 13px; color: #ffffff;"><a style="color: #fff; text-decoration: none;" href="http://www.test.com">Visit website</a></span></td>
                                <td style="background-color: #ffffff; width: 4px;" class="side-pad" align="center">&nbsp;</td>
                                <td style="background-color: #d55c19; width: 86px;" class="side-pad" align="center"><span style="font-family: Helvetica, Arial, sans-serif; font-size: 13px; color: #ffffff;"><a style="color: #fff; text-decoration: none;" href="mailto:test@test.com">Email me!</a></span></td>
                                <td style="background-color: #ffffff; width: 4px;" class="side-pad" align="center">&nbsp;</td>
                                <td style="background-color: #d55c19; width: 122px;" class="side-pad" align="center"><span style="text-align: center; line-height: 15px; font-family: Helvetica, Arial, sans-serif; font-size: 13px; color: #ffffff;">123-456-7890</span></td>
                                <td style="background-color: #ffffff; width: 4px;" class="side-pad" align="center">&nbsp;</td>
                                <td style="background-color: #63666a; width: 201px; height: 30px;" class="side-pad" align="center"><span style="text-align: center; font-weight: normal; font-size: 12pt; line-height: 24px; font-family: Helvetica, Arial, sans-serif; color: #ffffff;">Test Testerson</span></td>
                            </tr>
                            <tr>
                                <td style="background-color: #ffffff;" class="side-pad" colspan="7" align="center">
                                <table class="container" cellspacing="0" cellpadding="0" align="center" border="0" width="600">
                                    <tbody>
                                        <tr>
                                            <td style="height: 250px;" align="center">
                                            <table class="row" cellspacing="0" cellpadding="0" align="center" border="0" width="580">
                                                <tbody>
                                                    <tr>
                                                        <td style="height: 250px;">
                                                        <table cellspacing="0" cellpadding="0" border="0" width="100%">
                                                            <tbody>
                                                                <tr>
                                                                    <td style="width: 100%; height: 205px;" valign="top">
                                                                    <table style="mso-table-lspace:0;mso-table-rspace:0;" cellspacing="0" cellpadding="0" align="left" border="0" width="100%">
                                                                        <tbody>
                                                                            <tr>
                                                                                <td style="font-size: 14px; color: #63666a; font-weight: normal; line-height: 20px; width: 205px;" colspan="4" valign="top">&nbsp;</td>
                                                                            </tr>
                                                                            <tr>
                                                                                <td style="font-size:14px; color:#63666a; font-weight:normal; text-align:left; line-height:20px;" colspan="4" valign="top"><span style="font-size: 14px; font-family: Helvetica, Arial, sans-serif; color: #63666a;">Type your message here!</span></td>
                                                                            </tr>
                                                                            <tr>
                                                                                <td style="font-size:14px; color:#63666a; font-weight:normal; text-align:left; line-height:20px;" colspan="4" valign="top">&nbsp;</td>
                                                                            </tr>
                                                                            <tr>
                                                                                <td style="font-size:14px; color:#63666a; font-weight:normal; text-align:left; line-height:20px;" colspan="4" valign="top">&nbsp;</td>
                                                                            </tr>
                                                                            <tr>
                                                                                <td style="font-family: Helvetica, Arial, sans-serif; font-weight: normal; font-size:14px; color: #63666a; line-height:18px; text-align:left;" colspan="4">
                                                                                <p>&nbsp;</p>
                                                                                </td>
                                                                            </tr>
                                                                            <tr>
                                                                                <td colspan="4" valign="top">&nbsp;</td>
                                                                            </tr>
                                                                            <tr>
                                                                                <td colspan="4" valign="top">&nbsp;</td>
                                                                            </tr>
                                                                        </tbody>
                                                                    </table>
                                                                    </td>
                                                                </tr>
                                                            </tbody>
                                                        </table>
                                                        </td>
                                                    </tr>
                                                </tbody>
                                            </table>
                                            </td>
                                        </tr>
                                    </tbody>
                                </table>
                                </td>
                            </tr>
                            <tr>
                                <td style="background-color: #63666a;" class="side-pad" colspan="7" align="center">
                                <table class="container" cellspacing="0" cellpadding="0" align="center" border="0" width="600">
                                    <tbody>
                                        <tr>
                                            <td align="center">
                                            <table class="row" cellspacing="0" cellpadding="0" align="center" border="0" width="580">
                                                <tbody>
                                                    <tr>
                                                        <td>
                                                        <table cellspacing="0" cellpadding="0" border="0" width="100%">
                                                            <tbody>
                                                                <tr bgcolor="#63666A">
                                                                    <td style="height: 18px;" valign="top" align="center">&nbsp;</td>
                                                                </tr>
                                                                <tr>
                                                                    <td valign="top">
                                                                    <table style="mso-table-lspace:0;mso-table-rspace:0;" class="full-width collapse" cellspacing="0" cellpadding="0" align="left" border="0" width="100%">
                                                                        <tbody>
                                                                            <tr>
                                                                                <td style="font-size:12px; color:#63666a; font-weight:normal; text-align:left;" class="center">
                                                                                <p><span style="font-size: 12px; line-height: 14px; text-align: left; font-family: Helvetica, Arial, sans-serif; color: #ffffff;" class="footer">Here is some footer text.</span></p>
                                                                                </td>
                                                                            </tr>
                                                                        </tbody>
                                                                        <tbody>
                                                                            <tr>
                                                                                <td class="center" valign="top" align="center">&nbsp;</td>
                                                                            </tr>
                                                                            <tr>
                                                                                <td class="center" valign="top" align="center">
                                                                                <table cellspacing="0" cellpadding="0" align="center" border="0">
                                                                                    <tbody>
                                                                                        <tr>
                                                                                            <td align="center"></td>
                                                                                            <td style="width: 12px;" align="center">&nbsp;</td>
                                                                                            <td align="center"></td>
                                                                                            <td style="width: 12px;" align="center">&nbsp;</td>
                                                                                            <td align="center"></td>
                                                                                            <td style="width: 12px;" align="center">&nbsp;</td>
                                                                                            <td align="center"></td>
                                                                                        </tr>
                                                                                    </tbody>
                                                                                </table>
                                                                                </td>
                                                                            </tr>
                                                                        </tbody>
                                                                    </table>
                                                                    </td>
                                                                </tr>
                                                            </tbody>
                                                        </table>
                                                        </td>
                                                    </tr>
                                                </tbody>
                                            </table>
                                            </td>
                                        </tr>
                                    </tbody>
                                </table>
                                </td>
                            </tr>
                            <tr style="background-color: #636666a;">
                                <td style="background-color: #63666a;" class="side-pad" colspan="7" align="center">
                                <table class="container" cellspacing="0" cellpadding="0" align="center" border="0" width="600">
                                    <tbody>
                                        <tr>
                                            <td align="center">
                                            <table class="row" cellspacing="0" cellpadding="0" align="center" border="0" width="580">
                                                <tbody>
                                                    <tr>
                                                        <td style="height: 20px;">&nbsp;</td>
                                                    </tr>
                                                </tbody>
                                            </table>
                                            </td>
                                        </tr>
                                    </tbody>
                                </table>
                                </td>
                            </tr>
                        </tbody>
                    </table>
                    <p>&nbsp;</p>
                    </td>
                </tr>
            </tbody>
        </table>
    </body>
</html>

Completed
Last Updated: 19 Mar 2019 14:19 by ADMIN

Setup:  

  1. Create a page with a basic Rad Editor, with HTML mode enabled
  2. Go into HTML Mode, add at least the following:
    <input type="number" />
  3. Go back to Design Mode
  4. Click on the numeric input

To See the Problem:

  1. In the console of the Browser's Developer Tools, get a reference to the Rad Editor
  2. Call its getSelectedElement() function
  3. In Chrome, the returned element will be a <body> tag (NOT GOOD)
  4. In Firefox, it will be an apparently random (maybe the first?) user-selectable element within the HTML (NOT GOOD)
  5. In IE11, it will be the numeric input (DESIRED)
  6. In Edge, it will be a <body> tag (NOT GOOD)
Completed
Last Updated: 11 Feb 2019 10:07 by ADMIN

I've been trying to upgrade an existing solution to use the latest release version (2019) of the Telerik UI for ASP.NET AJAX and have encountered a major problem with the 'Tool Provider', a technique which is significantly used in my solution.  This same error displays in your own Telerik Demo.  Details are:

 

Description of the issue

Having multiple RadEditors on the same page, and trying the property "ToolProviderID" (to reuse the same floating tool amongst the different editors on the same page), causes a "javascript exception" on the client side.


   
URL of the Demo (Telerik Website)

https://demos.telerik.com/aspnet-ajax/editor/examples/toolprovider/defaultcs.aspx



Exception description

Uncaught TypeError: R.get_canAcceptTrackChange is not a function at c.RadEditor._initializeToolProvider (RadEditor.js:8239) at c.RadEditor.initialize (RadEditor.js:8297) at c.RadEditor.endUpdate (Telerik.Web.UI.WebRe597d4b%3ab25378d2:6) at Sys._Application.endCreateComponents (Telerik.Web.UI.WebRe597d4b%3ab25378d2:6) at Sys.WebForms.PageRequestManager._scriptsLoadComplete (Telerik.Web.UI.WebRe97d4b%3ab25378d2:15) at Sys.WebForms.PageRequestManager.<anonymous> (Telerik.Web.UI.WebRe597d4b%3ab25378d2:6) at Telerik.Web.UI.WebRe597d4b%3ab25378d2:6 at Sys._ScriptLoader._loadScriptsInternal (Telerik.Web.UI.WebRe97d4b%3ab25378d2:15) at Sys._ScriptLoader._loadScriptsInternal (Telerik.Web.UI.WebRe97d4b%3ab25378d2:15) at Sys._ScriptLoader._loadScriptsInternal (Telerik.Web.UI.WebRe97d4b%3ab25378d2:15)
    



How to reproduce the error (on Telerik demo website)

    - Mark the checkbox at the bottom of the page and click on "Update":

(the error can be seem on console, pressing F12)




Error message happening in our system

RadEditor.js:8239 Uncaught TypeError: R.get_canAcceptTrackChange is not a function at c.RadEditor._initializeToolProvider (RadEditor.js:8239) at c.RadEditor.initialize (RadEditor.js:8297) at c.RadEditor.endUpdate (Telerik.Web.UI.WebRe597d4b%3ab25378d2:6) at Sys._Application.endCreateComponents (Telerik.Web.UI.WebRe597d4b%3ab25378d2:6) at Sys._Application._raiseInit (Telerik.Web.UI.WebRe597d4b%3ab25378d2:6) at Sys._Application.initialize (Telerik.Web.UI.WebRe597d4b%3ab25378d2:6) at b (Telerik.Web.UI.WebRe597d4b%3ab25378d2:6) at HTMLDocument.a (Telerik.Web.UI.WebRe597d4b%3ab25378d2:6)
   



Sample code, causing the issue (our system)

Refer the attached image.

Completed
Last Updated: 08 Mar 2019 10:04 by ADMIN

I am using Telerik.WEB.UI version: 2018.1.117.45 in my website. I am getting as issue in RADEditor control when I create a hyperlink within Editor. Right clicking on that hyperlink opens a context menu, when I click on properties from the context menu, it opens an 'Image Manager' instead of 'Hyperlink Manager'.

The issue is occurring only in IE 11, rest all the browsers are opening 'Hyperlink Manager'. Please advise.

Thank you

Completed
Last Updated: 08 Mar 2019 09:45 by ADMIN

There's a bug in the RadEditor WordListConverter convert method.  See the attached image for details.  Note that the variable z is initialized and treated as an array (a stack, actually, with its items being pushed in and popped out).  However, perhaps because of a naming scope failure in the js-minifier, the z variable is, under certain conditions, set equal to an HTMLCollection, so a subsequent z.push method call fails.

This sample Word document reproduces the error.  It is admittedly full of bad list formatting, because it began life as a PDF, but it does exercise the RadEditor code in a way that causes the problem.  Select and copy its content and paste it in the RadEditor demo page here:

https://demos.telerik.com/aspnet-ajax/editor/examples/overview/defaultcs.aspx

Click OK to "clean" the pasted content and note that nothing appears because of the error shown in the attached image.

Verified in the latest Chrome and FF builds on Windows 10.

Under Review
Last Updated: 20 Mar 2019 16:36 by ADMIN
Created by: Arvind
Comments: 3
Category: Editor
Type: Feature Request
2
In RadEditor with Ribbon Bar Toolbar When we click  Type 1 Dropdown (Here "Font Name", "Real font size", "Foreground Color", "Background Color", "Apply CSS Class", "Paragraph Style" and "Undo") it is opened or expanded and if click on same expanded drop-down control it still remains open instead it should be closed(Toggle Behaviour) on any "Type 2" Dropdown then "Type 1" dropdown is still remaining open or expand.
Completed
Last Updated: 29 Jan 2019 11:22 by ADMIN
Inconsistent Behavior of RadEditor with Ribbon Bar Toolbar for a different type of dropdown toolbar controls.

In RadEditor with Ribbon Bar Toolbar, there are two different types of drop-down control observed.

Type1 includes "Paste" and "Strip All Formatting" 
Type2 includes "Font Name", "Real font size", "Foreground Color", "Background Color", "Apply CSS Class", "Paragraph Style" and "Undo"


Issue1:
In RadEditor with Ribbon Bar Toolbar When "Type 1" Dropdown is opened or expanded and we click on any "Type 2" Dropdown then "Type 1" dropdown is still remain open or expand.

Issue2:
vice versa In RadEditor with Ribbon Bar Toolbar When "Type 2" Dropdown is opened or expanded and we click on any "Type 1" Dropdown then "Type 1" dropdown is still remain open or expand.
1 2 3 4 5 6